Diablo 3 wont start

Technical Support
It started first time was all purple. closed to relaunch went to a black screen and froze comp, turned off tried again same results. Turned up clocks same result only after underclocking did it work
i have a AMD Radeon HD 6900 Series
You can try running in windowed mode for the "black screen on game start" issue. It works for some people.

a. My Documents -->Diablo III --> D3Prefs.txt
b. Edit DisplayModeWindowMode "0" to say DisplayModeWindowMode "1"
After the game finished downloading I hit the play button. beside the mouse icon, it had the loading symbol for about 5 seconds and then after that, nothing happens. I clicked the game icon on the desktop and it said it was already running. WTF?
I am having this issue. I am clicking on Play, the logo comes up and then nothing. If I hit Ctrl + Alt+ Delete I see it running..but nothing pops up. I even got the HotFix they recommended for my card. Still the same thing.
this happens to me almost every time I try to launch the game. Just cancel the process for Agent.exe in process tab of taskmanager and it will restart. it has worked for me.


well it enables the play button. Pressing the button still doesn't do anything.
I am now reformatting my computer...again lol. Going to update drivers...again...reinstall...again and pray it works. If not...Imma call them and wait 5 hours for them to talk to me. I have been so excited about this. Funny my computer that didn't meet all the reqs. ran it fine..well Beta (that computer died) but my new one which is above reqs..wont work lol
I am having this same issue! Let me know as soon as someone finds out what it is
Same thing's happening to me as well.
Well I noticed when I went into my display settings, my Video card was reading as a Generic VGA adapter. Instead of getting the driver from ATI I got it from VisionTek and it reads correctly now...I will let you know if this works for my issue or not once I get D3 reinstalled.

Here all day to keep ya updated on my progress.
Okay, after installing the updated Driver from ATI's site, it went back to generic VGA drivers. Reinstalled the VisionTek driver and the card was read. Started up D3 and *cries* It LOADED! Make sure..that even if you have your drivers installed, the card is not read as a generic.

This worked for me. Too tired to play though so bedtime! lol

Join you all in a few hours.

Join the Conversation

Return to Forum