Failed to Launch a critical file

Technical Support
"Please close all other applications, temporarily deactivate your anti-virus software, and try again. Alternatively, log in as an administrator and try again." Nothing is blocking it reinstalling after completely removing all traces made no difference. Anyone know whats the deal?
Right click the icon on your desktop and run as administrator got rid of the above described error for me.
Hope that helps.
I'm receiving the same error. Was all fine and dandy at 10 Eastern, was half way done patching. Now i'm receiving that error after cancelling patching to watch a movie an hour ago
i right click and run as admin doesnt fix it for me. i was in the game watching cinematics earlier today and it all of a sudden started doing this for me tonight now. uninstalled and reinstalled using the dvd and still same error.
I had a similar error, with similar symptoms (it didn't manifest itself until after the install had been working, etc). Solved it by running the launcher in Windows XP SP2 compatibility mode. (Right-click -> properties -> compatibility -> dropdown)

Hopefully it'll work for you as well.
when running as admin i get the error, when running as not an admin it loads the game and tells me it needs a patch, says it will auto restart and dl the patch but when it tries it says the game is already running and closes.
xpsp3 compatability mode fixed my problem. still doesnt make sense since i launched it fine hours ago and randomly it stopped working.
No error... just blinky blinky blinky blinky blinky for 20 minutes goes the DVD drive.... So the work around is to DOWNLOAD THE CLIENT but wtf good was the DVD? Why couldn't blizzard just allow me to buy the collectors set from their WEBSITE with a KEY TO download the game immediately like EVERY OTHER SOFTWARE OUT THERE? I can buy Roxio toast 11 online download it and have a DVD shipped to me... get with the new era of distribution. At least admit that the DVD's are useless or make them compatible with all DVD ROM drives. I have a lightscribe DL DVD drive that works with EVERY OTHER DISC I've put into it to test this game DVD. I'm not pissed because the likelyhood of being able to play today was not very good (because of updates and my tight schedule personally) but now I'm definately NOT PLAYING until tomorrow because the download is massive and I have crappy DSL.
run Diablo 3

Open task manager and end process agent.exe

(i tried playing D3 at this point, and it stalled until i exited, then it promptly closed)

exit Diablo 3

Run Diablo 3, hit play and enjoy.

I got this friendly bit of advice from

I had this same problem and that's how i fixed it.
Fixed this error with the Post above. Setting the launcher as Compatiblity mode Windows XP SP3 and "Run this program as an administrator".
Tried all these, downloaded new drivers now re installing, able to click play still nothing.. anything else you guys know to do? I am on hold with blizzard support now. Please help =\
Same here! Anyone have any help with Mac OS problems? I can't do administrator mode, can I?
hello everyone, i had also this problem,just fixed it

So just cut+paste you Diablo III folder from program files to your desktop.
Fix to this: Start D3 Launcher as administrator. Then hit ctrl + alt + delete, close agent.exe*32, hit launch, voila.
Fixed this error with the Post above. Setting the launcher as Compatiblity mode Windows XP SP3 and "Run this program as an administrator".

Also worked for me

Join the Conversation

Return to Forum