Screen Turns Black and alt tabs me out.

Technical Support
Prev 1 2 3 4 38 Next
Brother is having same issue, any guide on how to set the max fps
video settings - switch (foreground) fps to 50

there is a new nvidia beta driver
i'll give it a try
im down to max fps 23 and running the beta driver..

still the occasional quick screen blank every 2-3 mins but no desktop crashing yet.

but still...

23 frames...
Using a GeForce 9800 GTX, video card driver is nvd3dum.dll
Same problems here, was happening in beta as well :\

Before I changed my max FPS it was happening every few seconds, now it only happens every like 2-3 minutes. If it happens enough sometimes my computer will blue screen. I'm at the point where I don't know if I should continue playing, I'm not sure if its damaging my computer when the driver stops responding over and over and over :p
Dropping FPS to 50 seems to have fixed it here. Couldn't go 30s without it happening before. Just finished a 30min test without a single driver crash. (2x9600GT SLI)
I have the same issue with 9800gtx+ in sli, what actually happens is one card stops working completely, then the other can't keep up and the other card's temp skyrockets to 150-200 degrees and shuts down so it doesn't fry. like everyone else, i have the latest "stable" drivers from nvidia
Any news/updates with this issue?
9800gtx, also having this issue. i'll try the fps "fix"
lowering my fps to 50 worked great thank you to whomever suggested that.
I am also facing a similar issue with a GTS 250.

When I played the Beta, I did not have any issue with the game and any black screens/freezes.
05/15/2012 02:39 AMPosted by Moelock
same thng is happening to me 9800gtx

I have the same card and am having this problem.
Exactly the same problem here, GTS 250 and the latest beta driver from nvidia.
I had this problem in the beta aswell, but not as frequent.
Wondering if I have the strength to play it at all when it keeps doing this. :(
I am having this problem as well. First starts with the game freezing and the sound stuttering for a second then the screen goes black for about a second then everything comes back and seems to catch up. Occasionally I get alt tabbed out and can't bring the screen up for several seconds. The same thing happened in the open beta. My gpu is a 9600 GSO. I will give the 50 fps limit a try.
=======================EVERYONE TRY THIS !=======================
Inside the folder libraries/documents/diablo III there is a file named "d3prefs.txt". Open it.

- DisableTrilinearFiltering "1" (from 0 to 1)
- HardwareClass "1" (from 0 to 1)

Save the file and close it.
When you launch the game, you will still get the same “Unsupported graphics card” error that pops up. Press esc and the game will load.

put my framerates at 45 and hadnt had any problems since
Lowered to 50 and it still happens more than I would like. Not to mention that the game looks so choppy compared to when things were fluid at 150 fps.

I also tried changing the text file suggested above with the same result - still having problems!

Please come out with a fix for this soon Blizzard!
my turns black ans stays that way on the log in screen, i can only hear the music playing.

Using Nvidia Geforce GT525M

please help.
Same Deal.... GeforceGTX 260
This is really frustrating. I was thinking I would buy a GTX 260 to hold me over until my new PC build in a few months, but from the sounds of it that card is having issues as well.
Same prob w/ my GTS 250 as well...hope they come with a fix for this...seems to be a big issue with a lot of people.

Join the Conversation

Return to Forum