Diablo 3 cant get to the launcher?

Technical Support
I realize I am reaching but try this:

- Open the C:\ProgramData\Battle.net\Agent folder (Keep it open)
- Open your Diablo III Installer Folder
- If possible, have them side to side
- Double click on Agent.exe, then quickly run the Diablo III Setup.exe

See if that works?
i did it to and its still now working
Yeah bro I am still having major issues installing the game also
I am installing from battle.net full game client, it gets to the same spot every time. It proceeds to say Updating setup files... and then it jumps to Launching Blizzard Launcher and RIGHT back to updating setup files.... and at the same point
Go into Internet Explorer, press Alt + T, then click on Internet options > Connections tab and select "Never dial a connection". Now click the LAN settings and ensure every box is unchecked. Sometimes these settings can cause problems... even if you don't use IE
I have tried every option i've found on this issue. Fire up the installer only to watch the Agent.exe 32 blue screen of death me. It does a memory dump. I have changed file names, and folders. I have run in safe mode. I've tried the backdoor agent.exe 32. I have deleted files people mention. I have redownloaded installer just in case. I have turned off anti virus and firewalls. I am running Windows 7. The thing is, this same issue is happening with the MoP beta as well. Both using that Agent.exe. At this point I am done looking for solutions as diablo beta should have fixed all this crap. I just wanted to play, not go thru system restores and bug fixes. *rage*
Tried all of this, still isnt working. MUH WANNA PLAY DIABLO. :(
I got to the Launcher...
I have tried every option I've found on this issue and some other fixes that slightly resemble this problem.
I am running Windows Vista on my gaming rig :(
Since Vista cannot run programs in compatibility mode XP service pack 3 i tried running it in XP service pack 2...
Doing this it got to the launcher in under 10 seconds...
but because its Service pack 2 compatibility mode another error pops up that states the operating system is below system requirements... and the installer is stuck at 0%
I knew this would happen but my question is why it would launch in service pack 2 mode that is below system requirements and not in Vista?

Join the Conversation

Return to Forum