Strange Graphical Glitch! Please help!

Technical Support
The glitch starts as soon as the sign-in screen. The crows in the background are see through in parts, and the news section is just a bunch of golden lines and dots (the color of the font). Then, when I get into the game, there are triangular patches of see through areas all over the ground. Like with the crows, parts of myself, and all NPCs and enemies also have these see-through spots. Then, inside buildings, things will be stretched out, and the objects will block my view and I cannot see inside the buildings.

This is so frustrating, please, someone help me.
I am having the same exact issues here too. The game doesn't seem to be lagging at all, the graphics are just mega messed up. I've tried all manner of tweaking the settings and I don't think it has anything to do with my system I am pretty sure it's the game itself that is messed up. I am running everything the same as I did on the Beta, which had no issues at all.
I'm having the exact same problems. I'm reverting to an older driver for my graphics card, because I have updated once since Open Beta weekend. I'll let you guys know if it changes anything.

I've also crashed to the desktop a few time at "Old Tristram road" like a few people have posted about.

Edit: Completely uninstalled my old AMD/ATI drivers and rolled back to 12.3. No graphic errors at all. So there is your fix. :)
Thanks Zilther, I had the same problem. I still don't roll back my drivers, but after researching in Blizzard, for an alternate fix, you can download the Hotfix Driver 12.4a in here: http://support.amd.com/us/kbarticles/Pages/AMDCatalyst124ahotfix.aspx
It seems that it resolves the driver issue for ATI Radeon HD's users. I'm trying it right now.
Gonna try that out, thanks for the support ;)
There also exists a problem with using 'Override Application Settings' Anti-Aliasing settings in the 12.4 drivers from AMD/ATI. If you continue to have graphical glitches and/or crashes try setting Anti-Aliasing to 'Use Application Settings'. This tweak has helped me solve graphical anomalies in games like TERA, DOTA2 and others.
I have this problem descripted from Kuroakuma with my ATI Mobility Radeon HD 3400 with all settings, Catalyst 12.3, Catalyst 12.4 and Microsoft driver from Windows 7 64 Bit (en-US) and on my Thinkpad T400 in "Fullscreen Mode".
I am having all of these problems and none of these fixes work! You actually get used to the mega messed up graphics but I'd like to see what the game is supposed to look like.
Plz help!

EDIT: I system restored, uninstalled all my drivers and then installed ATI's 10.3 driver and it works!
ty for the heads uop ive been going for 3 hours now trying to get passed tristram road and no luck so il try the fix and hopefully all is well
Same problem here, Radeon 4500 series. I'll try reverting to the older drivers and report back.
Since legacy driver 12.6 everything is alright.
Yeah but i have the same thing with Nvidia, I tried 5 different versions of drivers even betas - always same bug, btw it started since last patch.

Join the Conversation

Return to Forum