Install super slow

Aus/NZ General Discussion
installing from a cd have been for an hour or more now and its at 12% ive tried restarting, deleting everything, running as admin, im all up to date (win7 64bit) nothing is working some1 plz help
Mine is not taking that long but it's definitely taking it's sweet time..
are you installing from disk? mine keeps spooling up and down but not doing a thing
ok so now its maybe been 1 1/2 hours and its at 13% wtf is going on should i just wait?? what am i doing wrong
Same here... It's annoying the crap outta me. Apparently there is a fix where you go into internet options in control panel, click the connections tab and then click on the LAN settings button below then deselect the 'Automatically detect settings' checkbox... I tried it but it didn't work. Let me know if it does for you guys...
nope didnt work for me
05/15/2012 04:43 AMPosted by Darkasaur
Same here... It's annoying the crap outta me. Apparently there is a fix where you go into internet options in control panel, click the connections tab and then click on the LAN settings button below then deselect the 'Automatically detect settings' checkbox... I tried it but it didn't work. Let me know if it does for you guys...


He's talking about INSTALLING, not DOWNLOADING.

Mine is uber slow as well, 4% in almost 2 hours... If this is all decryption stuff they'd better never done that just for people not playing a couple days earlier...

I hope it gets done by tomorrow afternoon (unlikely at this rate). I want to play on my day off.
If its taking to long...some of you are downloading the whole 7.62 gb game file...shouldnt be taking that long at all...no more than 20mins on a 1500kbs speed internet to download and be played..!
installation is so super slow for most people. i have been looking for it on internet and seen a lot of people complaining about it.

sad.
Heh I don't mind. I started my install and I'll let it install while I go to work.

I'll be back in 12 hours so hopefully it's done by then right? ^_^
Same problem here, 5% in 20 minutes now.. and ofcourse I just sit and stare at the meeter, making the wait a whole lot longer!
woot i left mine and went to bed to wake and it was done YAY!! maybe it took all night i dont know, now trying to get in to the servers...
I was having the same problem. I'm running on 64-bit Windows 7, on a quad core w/ 16GB of RAM and a 24x DVDR, so it's impossible it's an under-spec PC. Probably the same for most of you.

One thing I did that seems to have sped it up, was I started to think maybe I should copy the files to the HD and try installing from there. I did this while the game was installing. I figured since it appeared to be reading the drive very sporadically, this wouldn't present a major problem.

Well, when I did that, it said it would take 17 min to copy the file. I figured rather than wait 17 min for the files to copy, I'd be a little more patient on the install, so I cancelled the file copy. When I went back to check on the installer, the percentage started ticking up MUCH faster than before.

Give it a shot and see if maybe it helps... Just kind of poking in the dark here, as I'm sure most of you are as well. So to summarize: while the install is running and you're watching the grass grow, start copying all the files on the DVD to your HD somewhere, let it start copying for a minute or two, then cancel. See if that speeds things up for you at all.
I'm glad I decided to go to work today instead of staying home for Diablo.

I think I would have been driven insane watching the slow install and the inability to get in to the servers...
holy..... this has been quite the epic fail so far. #1 vista as usual is nothing but a pain in the !@#, took forever to update. #2 finally get it to not say uncompatible, and its been installing forever and got stuck on 12%..... i sence a sick day tomorrow......
05/15/2012 08:42 AMPosted by AnonymousOne
no more than 20mins on a 1500kbs speed internet to download and be played


It'd take a little longer than that.
Closer to 85 minutes at a constant 1.5MB/s actually.
The slow installation is probably due to your disc-drive , i had the same problem ( slow install ) on blizzards starcraft II ( took an hour to install ) and have the same problem with diablo III.

I looked around a bit and it seems my disc-drive has problems reading the dvd's on full speed due to the disc protection on their games.

Dont think there are any fixed for it. I can only recommend that you download the game files and install the game from those files on your HD. It should speed up your installation.
Haha it realy worked. Thank you GeekLad
Still 1% after 1 hour!
Mine took a good hour and a half I think, but it finished ok. Good luck once you get it installed though.

Join the Conversation

Return to Forum