Auction house problems

Bug Report
Hey, i bought something from auction house like 4 hours ago, transaction was completed successful (at least the game said me this, i made few buyouts), then the lags with servers started again (i play on euro) , so I exited the game and i was some time offline. Then i finally managed to connect again few hours later and :
1. I lost my money for the items i bought. But i did not receive them (items)!
2. also I lost my bids placed
3. I noticed that items in the auction changed! For example it was like 100 pages of different rings, but now its 1 or 2 pages only
4. I tried to buy again from auction and had the same story! This time i had request timeout during the buyout, then i got another error, and item became listed as SOLD in the auction and i noticed that i spent a money (so somehow i "bought" it) and... sure i did not receive it!
update: i have an items now!

too late, while i played they became old haha
i have a problem too with the auction at mid day it worked just fine when i try to look at the items there...none there is :( nothing zipp...any help ?
I having the same problems.. Prob down for a bug fix or something
Today it has lagged , all day i tried to buy something it just does not load the offers.
Sad to see i am not alone. why is it so hard for blizz products to work? still waiting on items i bought in the auction house to show up. FIX THIS or did you fire support after you finished counting your money?
Similar issue here. I sold an item and did not receive the gold. I put a cheap bow up there just to try the AH mechanism, so I'm not really out any real sum of gold. However, the transaction failed at some point. And that is the point.
same i bought a witch doctor helm like 2 seconds ago it timed out but ate my gold
BUMP!! gold gone, item nowhere
nvm i got it
i hope it works this good when real money is involved. why do you beta test? you know you guys have BAD programers. it seems cheap but with the hype and time between the last one you would put some real time in making nuts and bolts work. i cant seem to think you don't give a crap but you are making me a believer. wait i forgot. you cant fix and count money at the same time. GG
I had the same problem....the request timed out...took my gold but no item. The log says it was purchased. Going to bed now...perhaps it will show up in the morning.
same problem, request timed out, took my gold, log says it was puchased, but no item, this better get fixed soon, i lost 293k
Just lost 27k... I "bought" an amulet and my request timed out... So I tried again.
Lost my gold, checked the transaction history... nothing. F!@#!
same prob 60k gone no item. T_T pls help hope it just takes awhile but ive been waiting for it for 10min already :(
I also had this problem.
have the same problem lost abut 60k
like i said i had the same problem but after bout 30mins to an hour i got to send the item to stash, during that time tho i logged out and back in, went into and out of games and exited and reopened D3,
Another AH victim here two. Ran into three issues so far.

1. Got "buyout accepted" message, but the item doesn't show up in complete tab.
2. Got a message that an item of mine sold, gold doesn't show up in completed tab.
3. Timeout errors

Join the Conversation

Return to Forum