GeForce GT 525M 2GB

Technical Support
Curious to see if anyone else is playing with this graphic card. I know it's not that great of a card, but I want to know what is the best setting to play at, to get the most I can for performance and visualization-wise. I'm playing on my XPS15z with the following specs:

- 2nd Generation Intel® Core™ i5-2430M processor (2.40 GHz with Turbo Boost 2.0 up to 2.90 GHz)
-1080p display
-8GB RAM

I'm currently playing the game with everything on low and at a resolution of around 1300x900 or something like that. I just chose this setting so I could just focus on playing and leveling up haha. If anyone knows what I can to do to tweak the card, such as the Nvidia Control Center (I have no idea how to use it. Only thing I did was to select Diablo 3.exe to launch with Nvidia High Processor) or can tell me what's a decent setting to play the game at, please help!

Thanks in advance.
I have this card on a laptop running an i7 and it runs like crap. My 6 year old desktop runs the game better. Any ideas?
When i play, sometimes the graphics !@#$s up and i see black lines on my screen, or all over the screen, sometimes the color changes and it freezes so i have to go to my windows and open my diablo 3 tab again so it restores (if it works) and most of the time, it tells me i got disconnected. I was wondering if it's a graphic card problem, i have a Geforce 7900 GTX . I went on canirunit and it says i can, passed minimum.

What's going on!!?? And can I lower the fps rate and will it affect the gameplay or just the visual? Please help a fellow comrade!
I have the GeForce 9500 GS and the game looks fine but my game play is in slow motion i cant stand it.
05/16/2012 11:17 AMPosted by forch17
I have the GeForce 9500 GS and the game looks fine but my game play is in slow motion i cant stand it.

Weird, i have a old computer with a 9500GT and runs nice.
i have a pentium 4 3.4ghz and an nvidia 520gt 2gb(pretty close to yours) 3 gigs of ram, and it runs flawless on my computers with everything on high except physics that on low but everything else looks great but i am running on 720p instead of 1080p
Sometimes it just freezes put i can always move my mouse around, there's no program running in the back
I'm playing on an Allinone PC with a Geforce GT 525m 1.6GB
i5-2400s (Quad Core, 2.5ghz - 3.3 turbo boost)
6GB of Ram

I have the resolution at 1280x720 and runs at ~50fps, and about 42fps during heavy battle. All other settings are still on default

Tested it on 1080p, 25fps traveling, and 20fps while in battle

Things I tried to improve Performance using the NVIDIA control panel, 1080P
-Setting Maximum pre-rendered frames to 8. 28fps, and 25fps in battle. Good improvement. (This setting can cause some input lag, but it isn't a twitch shooter, so it shouldn't interfere)

Tried switching Texture filtering - Quality(Default) to High performance. Helped VERY slightly. (Maybe placebo effect)
I'm curious to see if this works but try it on 720p, I have a Gt 525M coming in a couple days and now I'm freaked out whether it was a good decision or not.
tt
--
Actually it works fine for me now lol. I play on high settings but I turn off shadow and the other extra option...forgot lol (at work can't check) I play at max resolution since my screen is 1080p. My average FPS is about 35..jumps up and down. Highest I've seen the fps jump is in the 3 digits range haha idk what exactly. Its just a bit laggy when I first join a game, but after a few seconds, the game turns out smoothly. ** Error in my original post, I have 2nd gen i7 not i5 too
what laptop? After I updated to the newest driver, I can play perfectly fine now. Maxed out settings except for shadow is off.
Hello, the same problem occured here, I have dell inspiron n5110 and the game freezes so badly with high performenced graphic card...
My parameters of the laptop are:
Geforce gt 525M 1.5 GB of ram,
Intel core i7-2670QM 2.20 GHz (up to 2.90 GHz with turbo boost)
6 GB of RAM.
Anyone have any ideas? I have the newest drivers of nvidia cuz of some fixes for diablo 3. There are like 3x-4x fps, but problem occurs when I am buffing myself, moving around, trying to hit mobs or when I am in the middle of fight with bosses, the game iteslef freezes and fps are going down to like 9-15...
Same exact machine here with the same exact problem. I'm using the minimum settings, and tried to lower resoultion to 1280×768 16:10 widescreen. Now it's a bit better, but FPS still goes down to 5-10 from time to time.

Any ideas? This problem is even more annoying since i bought the laptop just to be able to play this game on maxed settings. Haha, fail..
I have Dell VOSTRO 3750 i7 2GHz 4GB RAM and same problem. I've tried different settings, but noone working. At resolution 1280x720 and lowest or none details I can play somehow, but game also freeze (lag increase into >100). When I start to play then lag is 78 and playing is possible, but only for few minutes. Then I need to make pause and minimalize screen ;] 2 minutes for net and can go back into battle lol. At higher details or resolutions lag increase and back faster. I have tried different nvidia settings, etc., nothing help.
Any ideas what can I do? I don't believe my notebook is to slow for DIII ;]
I have a Dell xps 15 with an i5 and it runs fine on bottom settings. You'll get some lag spikes when theres a ton of enemies on screen (which can murder you) but I've done okay.

Join the Conversation

Return to Forum