OS question.

Games & Technology
I have windows vista ultimate 32 bit for my os and it says I can't run the game because I need a newer operating system. Any reason for this. Thank you for the help:)
What is the specific error message?
According to the requires specs that I see, XP, Vista, and Win7 should all work; nothing is stated to indicate that a 64 bit OS is required (so your Vista 32 bit should work):
http://us.battle.net/support/en/article/diablo-iii-system-requirements
What is the specific error message?
According to the requires specs that I see, XP, Vista, and Win7 should all work; nothing is stated to indicate that a 64 bit OS is required (so your Vista 32 bit should work):
http://us.battle.net/support/en/article/diablo-iii-system-requirements


That's pretty unusual for the game to demand that you need a newer operating system. According to the System Requirements page on Blizzard's website, the lack of them mentioning 32-bit or 64-bit makes me suspicious. I would try contacting Blizzard directly about that.
have you installed the latest service pack for vista?
I think that not having the latest service pack might be the problem. I only have sp1 on my cpu, but I can't seem to get sp2 installed. I keep getting an error and it quits. I might have to buy win7 as i don't have my install disks due to the fact that I have moved around a lot in the past. Thanks for all the help everyone:)

Join the Conversation

Return to Forum