Mouse Cursor disappears

Mac Technical Support
Prev 1 3 4 5 Next
Can you look at this thread and post the requested information?

On Windows 7 I found that that when this happens all I have to do is open the task manager, then under the Applications tab find Diablo 3, right click it, and press "Bring to Front."

After this my cursor comes back.
This is one of those problems that make no sense. I've been playing DiABLO 3 for over 50 hours now and this just started happening. I have not touched anything on my settings. It was working perfect, now I have no mouse cursor when I launch D3.

Fullscreen, no mouse cursor.
Windowed Fullscreen, the mouse cursor appears.
Mine is doing this too!
I have a macbook pro and this happens to me as well. I just do a quick 3 finger swipe which causes all the windows to appear and I click back on the game. You have to go to options and select play the game in a window to do this. Hope this helps.
Same thing happening on a 2011 MacBook Pro running 10.8.3

Pref's added to pastebin.
Still no updates? We are seeing this generally when entering boss fights, such as the Butcher.

Last seen minutes ago on an Early 2009 iMac running 10.8.3.
happened to me. i came across this thread while searching for an answer.

i switched to full screen after losing my cursor in windowed. that didn't work.

i opened task manager while D3 had fullscreen enabled but was minimized and Switched To diablo 3. my screen went all white, i clicked, d3 went back to normal and the cursor was visible.
This was first reported in this thread on 5/5/12 and now it's 10/15/13. This has been an issue for over a year. It affects me EVERY day. It occurs when I drag items from my inventory and drop them on the ground. I've seen several suggested fixes (I usually restart the game, but I'll try some of the other suggestions) but no game fix from Blizzard. I consider this a serious bug since I run into it all the time. When can we expect a fix?

I'm on a late 2009 iMac running OSX 10.8.5.

This has never happened to me at "cut scenes" .. only during inventory moves. It's also never happened to me in a boss fight like other people have experienced. Also, I'm running full-screen, not windowed.

This doesn't ALWAYS happen during every inventory move, it's random. Perhaps that's why you haven't been able to reproduce it. But play long enough, and it happens. At least once per day for me.

Can we at least get a progress update? Thanks.
This happens almost every time in my Mac (fullscreen) sometimes I can reproduce this bug opening my inventory and throwing stuff into the ground very quickly (also it happens often before bosses fights, but I'm not 100% sure)
Same here...happens on my early 2011 15" Macbook Pro all the time. I'll be right in the middle of a battle or something, and my cursor just completely disappears.
I am using a iMac and this has happened to me a few times but the pointer does come back to me when i am in my inventory and just move the mouse till an item is highlighted then click on it and my pointer appears might have to move item like your going to drop it. that works for me.
wow over a year with this issue continuing, happening to me everyday

2012 macbook pro
Processor 2.6 GHz Intel Core i7
Memory 8 GB 1600 MHz DDR3
Graphics NVIDIA GeForce GT 650M 1024 MB
Software OS X 10.9

usually happens after a cinematic, most commonly during or before a boss fight.

i play in fullscreen mode.
Yep, this just happened to me right now. 4 stacks and I don't want to restart :/
It happened to me today as well. Damn I was not playing Diablo 3 for few months and decided to have some fun again since auction house is disappearing and something like that happened.

I am running Diablo from Macbook Pro with OS 10.9
There is a way to fix it and you might want to take note of this.

Usually this happens because an item was dragged (out of your inventory) very quickly. Do the same thing again, except slower. When I did that, my cursor came back.
I cant start the game at all to get to my inventory. The mouse just doesnt appear. I am runningn win 8. I havent played in months
Update on this since I first posted in October. Surprise! It's still occurring (in January now)!. I've upgraded my 27" iMac to OSX 10.9.1 and the problem still occurs. This happens to me when in full screened mode and dragging items from my inventory to the ground.

I've also changed my mouse from the bluetooth wireless magic mouse to a usb wired logitech mouse (for unrelated reasons) ... but the mouse change had no effect. Definitely something in the game code.

My fix: Cmd-Tab out of the game to Finder, open Finder window, click on a couple directories or files, Cmd-Tab back into the game, and the mouse cursor is magically back.

Still annoying. Any progress with the Dev's tracking this down?

Just being curious..

You are mentioning a third-party mouse device (non-Apple). Did you also use 3rd party mouse device drivers? Maybe it makes a difference?
01/04/2014 10:29 AMPosted by Tuna
Just being curious..

You are mentioning a third-party mouse device (non-Apple). Did you also use 3rd party mouse device drivers? Maybe it makes a difference?

It happens on both Apple and third party mice, with or without third party drivers. It's also happening on Windows as well with all kinds of mice.
Technical Support MVP
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.

Join the Conversation

Return to Forum