Error 3007 win7 fixed

Technical Support
I've been having error 3007 since release at all hours of the day and night but actually have it fixed now, just had 1 1/2 hours straight for the first time.
I did three things all at once so I'm not sure which in particular fixed it:

1) Secondary logon:
-Start -> Control Panel -> Administrative Tools -> Services
-Scroll down to 'Secondary Logon' -> double click/right click and select properties -> next to 'Startup Type' select 'Automatic' (mine was on 'manual' thanks to AVG installed by new firefox)

Courtesy from:

2) Port forwarding AND triggering
note: my computer is wirelessly connected to my router and I am unable to connect to it by ethernet cable or bypass the router and plug straight into the internet because I have to share it.

-Access your router interface, find out how by checking its manual (lol), googling its name or going to The name will likely be written on a sticker under the router itself. Mine is a dynalink rta1025wv6 accessed by entering '' into the web browser bar. I once had a D-Link router accessed by entering '', so each is different.
-Find where 'Port Forwarding' is located. Mine is under 'Advanced -> Virtual Servers -> Port Forwarding'
-Add ports '80', '1119' and '6881-6999 ('External Port Start 6881' and External Port End 6999'). I put them under TCP/UDP because no one told me what the difference is.
*Also under 'Server IP Address' I put the router's address ( not my computer's internal IP address ( I'm not sure if this is correct because no one online has clearly stated either way so I thought I'd experiment.

-Add these same ports to the 'Port Triggering' section, which is directly under 'Port Forwarding' on my router interface.
*This step is supposed to be a vital one that is often missed.*
I don't know the technically correct procedure, but I entered:

-'Trigger Port Start: 80, Trigger Port End: 80, Trigger Protocol: TCP/UDP'
-'Open Port Start: 80, Open Port End 80, Open Protocol: TCP/UDP'

The same for 1119. With '6881-6999', I entered '6881' into 'Trigger Port Start' and 'Open Port Start', and '6999' into 'Trigger Port End' and 'Open Port End'.

Courtesy from:

3) Windows port opening
From what I read in the article above, port forwarding in the router is useless if you don't do the same in Windows itself (kind of like having 2 doors with different keys to get into your house).

-Start -> Control Panel -> Windows Firewall -> Advanced Settings (on the left side with the blue and yellow admin shield icon)
-'Inbound Rules' (far left side) -> 'New Rules' (far right side)
-'Port' (second option in the centre) -> 'Protocol and Ports' (far left side)
-Select 'TCP' (will probably be already selected by default).
-Next to 'Specific Local Ports', type in '80'
-Click 'Next'
-Select 'Allow This Connection' (will probably be already selected by default)
-Name the rule ('Diablo III troubleshoot' if you like) and 'Done'.

-Create two more of these inbound rules with '1119' and '6881-6999' (no spaces) entered into 'Specific Local Ports'. You can use the same 'Name' for all of these rules.

-Now you will need to create these three rules again ('80', '1119' and '6881-6999) under 'Outbound Rules', which is underneath the 'Inbound Rules' we have just been using. All the details are the same.
*This time make sure you actively select 'Allow This Connection' at the end of each step becuase by default it will say 'Do Not Allow this Connection'.

That's it. Took a little bit of time to set up, and I didn't restart my computer or router after any of these and am able to play as I supposed to be doing at release date.
If this helps one other person (like someone helped me just now) then this will be worth while. Good luck!

New Zealand

My two sources once again:
Thank you so much! Can't say how much I appreciate this help!
You're a legend :D
when im trying to add the ports forwarding it says my ip is wrong. i tried useing my router ip and my computer ip and it wont let me add the ports
If I have Windows firewall disabled I don't need to open the ports there right?

@Alta - you need set a static lan IP.
hmmm If I get this issue on my NEW computer, I'll try this. I tried playing D3 on my dad's comp but was hit with error 3007 so I gave up on it after trying a few things(did port forwarding but not port triggering, and also forgot to change 2ndary log in from manual(default) to automatic), because I hadn't seen those suggestions yet. My new computer parts should all arrive in 3~4 days.
I've been having this issue since yesterday, the game would randomly disconnect completely, back to the login screen, with Error 3007.
It doesn't slowly lag out or anything. Just immediately drops out of no-where.
@bigheeno, I tried the port forwarding and triggering, did all the steps exactly like you put it, but didn't help.
I'm not having any issues with anything else on my pc, or with my internet for that matter.
Also, when I first bought the game I was able to play normally, went on for hours and was reduced to a zombie at work the next day. This just started, as far as I know, yesterday.
Now not a single game goes for more than about 15 or 20 minutes before dropping.
This didn't help, and error 3007 usually occurs during peak American times.
@Mattdaemon, it's not just peak american time, it's always. Bnet has finally commented about this issue and has made a sticky post with some fixes.

It's a networking error and if you follow that link and go to the second post, there is a few suggestions there on how to fix it.

My wife and I were getting d/c'ed every 2 to 20 minutes until I found someone saying that turning general chat on will fix it, so we tried that 2 days ago and that has worked for us so far.

Coincidentally we have just changed our ISP and was given a new router, a netgear. Our old router was a D-Link which is the router that everyone being disconnected seems to have. I have been sitting idle on D3 for 40 minutes now and no D/c yet, woot =) So I suggest updating your firmware on your D-link if that's what you have.

I haven't needed to mess with ports, windows firewall nor secondary login, but the problem seems to be in the router somewhere. I knew that I always loved netgear, now I have another reason to like them, go netgear!

-Cheers, Curtis
Why should Blizzard use port 80 on your side? Port 80 is mostly used by webservers (Apache, IIS). Most ISP's block this port by default so i don't think Blizzard uses this port to communicate with our systems.
Extremely happy that have fixed your issue, which I have never had.

I do highly advise you change one of your settings however - secondary logon should be set to DISABLED.

That's how mine is set, it's how everyone should have it set. The automatic setting means that an application is automatically elevated to SYSTEM LEVEL PRIVILEGE. Basically by having that disabled you've allowed a remote user running an app on your PC to have full system rights - not good.

Since I don't get, and have never had 3007, we know that this setting is not relevant to the issue.

It would be far more advisable to run the Diablo III application "as an administrator". That is, right-click the shortcut and choose "Run as Administrator".
Hey there bigheeno, thanks for your post.

did the whole "general chat" thing... didnt work.
did the whole"secondary logon" thing... didnt work.

so i figured i'd try the whole port forwarding thing.

Now, i'm not a computer tech, but I have some knowledge of how they work.
having said this,
i'm confused.

I have the same router as you, tried following your instructions, and couldnt quite figure them out.
Tried going to and follow their instructions, but had the same problem.

I think the issue is that I can't get to the "add new port forwarding rule" screen.
When I click on "add" it gives me a completely different menu than shown on the website.
was this the same for you?

OS: Windows 7
Connecting to my router wirelessly via my desktop as I don't have a LAN cable, and my computer is too far from my router to run a cable anyway. I DO, however have full wireless signal.
Very helpful thread. I'm using Windows XP, are these same steps applicable?

I was getting 3007 maybe once a night so it wasn't a problem but today it's been incessant. Joining general didn't seem to work.

Try this site, not telling you to pay for the service but it has some good tips.

I think my 3007 is attributed to horrible lag plus server issues, my character would stop interacting with the environment then bam... disconnect.
joining local chat appears to have solved problem for me. maybe not for everyone though
My brother had the same problem, we live in Australia
and somehow, for some reason the blizzard downloader, downloaded
the EU version of diablo 3 and installed it on his system.
So he kept having the error 3007 problem until I noticed that he had the EU version,
only reason I noticed is because where you choose your language it said 'English"British"'
whereas my copy says 'English'......
So i got a US version of the installer, installed it and the error 3007 is no longer a
maybe work for some other people, i hope

sorry forgot to mention we are playing on the US server
Thanks heaps Mike.

Was having lots of problems with 3007 and general chat made it slightly better. Was not sure about trying the port thing but since I found your thread and you have the exact same router/modem I gave it a go and was able to follow step by step.
I have only been on about 30mins but so far no problems, fingers crossed.

Cheers and thank you very much!

Cheers Mike!

You are my personal hero right now. Took a few minutes and bam, been playing to almost an hour without incident. We've got the same router so I'm guessing it's a D-link thing. Had to do something similar to get my flatmates' xbox's to work online about a year ago.

- Len, NZ.
if it wasn't for this error i would have bought the game, as i have the beta.
(3007 won't be fixed if i buy the actual game right?)
Thunaz, I came from the Beta and continued to have error 3007 throughout full version.
This port fix has worked for me, played hours without DCing. Definitely glad there was a help thread with my exact modem/router/whatever it is.
Mike your awesome bro,

Im from New Zealand and have the same router (Dynalink RTW1025WV6) and problem.
It was fixed by Port Fowarding, the other options didnt work.

Cheers !

Join the Conversation

Return to Forum