Patch won't apply

Technical Support
I started up Diablo 3 and it started to download a new patch. When I log into the game it authenticates and the comes up with a message that says there is a new patch available, and that the game is going to restart and apply it. When i click ok the client restarts and the launcher comes up with no update and the same thing happens each time I try to log in.
Yes I am getting this same error. I have tried restarting and attempting again but the same thing keeps happening.
Me as well. I feel like I am stuck in a Diablo patch day purgatory... fml
Yeah same with me I just patched and I get the same bug.
(Everyone hit request sticky to get this up)
Ya I am having the same issue :(
same here!
Yea same, I even restarted my computer, when I log in it says a patch needs to be applyed, so I click ok, it applies it, and tehn its a loop, So I close the game, re opened it and it says D3 is allready runing.
Same here. Its saying Diablo 3 is already running then an error comes up saying Diablo 3 has stopped working
yeah it just loops the whole process and patch never begins updating and then goes straight into the login screen and then sends me back to the patch and so on....
Come on Blizz....
Fix quickly, please!:)
Same problems here
yeah same here
me too, Diablo 3 is already running then an error comes up saying Diablo 3 has stopped working
same here
Yep, same issues here. They did say it won't be ready until 11am PST, which is in an hour and a half. I'll wait until then before complaining again.
it says that its expected at 11am pdt to be back up ... another 1hour and a half
Yeah, happening to me as well. I don't know the forum policy about external links but here are a couple screen caps:

Join the Conversation

Return to Forum