3007

Technical Support
I like many others am currently experiencing the random disconnects from bnet with error code 3007.

Earlier today I checked your support page and saw that next to 3007 it showed that blizz was looking in to it and working on a fix. But I just checked it again and now it just links to your general troubleshooting info.

Problem with that is that I played beta for 5 months and never once experienced any kind of issue like this. And now that its live I am getting it constantly. And my hardware and setup has not changed since beta.

So I want to know if blizz is still working on a fix or if your just going to tell us its a problem on our end even though we paid between $60-$100 for this game.
I think they are working on it but unfortunatelly they dont have a clue about what it causes it. I have done everything they recomend and I still keep getting that error in random intervals, sometimes it looks it wont happen again, sometimes I get 3 disconnections in 5 minutes.
yup...its happening to me too. I had it happen approx. every 20-30 minutes.
Yeah same thing happens to me. And the thing that bothers me was earlier I read a blue post saying that it happens in their other games too but it only disconnects you from bnet chat not the game. But in D3 it kicks you out.

My question is if they had designed their other two games with this issue in mind then why the hell would you release this game with such a fundamental flaw?
Same issue for me too guyz - but my RealID always stays signed in when I'm playing WoW - it never drops out....... so why is it constantly doing so for this game? That's where the issue is - fix the RealID (battlenet) dropouts and hopefully our "friend" 3007 will leave us for good!
I can't get through an area without losing connection. I can still chat with friends in-game while lagged out waiting to get booted.
same thing is happening to me
Third one of these threads i'm posting in. Same issue here, still no explanation.
I just want confirmation from a Blue that they are indeed looking in to this and not just leaving it at "its a problem with your router/modem"
Well...up until about an hour ago, there WAS confirmation that they were working on it.

Now it just seems like they are back to blaming the end-users again.

Awesome!
05/16/2012 05:47 PMPosted by Rennix
I just want confirmation from a Blue that they are indeed looking in to this and not just leaving it at "its a problem with your router/modem"


Agreed. Just some recognition that there is still a problem being recognized and worked on. At least make a post about it in the forums.
05/16/2012 05:50 PMPosted by GoFreaks
I just want confirmation from a Blue that they are indeed looking in to this and not just leaving it at "its a problem with your router/modem"


Agreed. Just some recognition that there is still a problem being recognized and worked on. At least make a post about it in the forums.


Exactly
Try joining General Chat (/join general) at the character select screen.

For some people this works like a charm.
thats all im after as well really, to know that its being looked into, i got this at launch in australia, ive now had the game for 3 days and i still only have a level 6 because i cant be online for more than 3 minutes at a time in this game... all other online games, starcraft 2 etc work fine, and my realID never dropped out.

all i want to know is blizzard is looking into it and will fix in in the future, otherwise ill be forced to refund a game that i cant play.
Happens to me and my roommate when either of us stops moving for too long. The issue seems to be way worse when in town though...at least with New Tristram it only takes like 5 seconds of standing still to get booted back to character select, then back to the main screen with the 3007 error a short while after. I've gotten around it for a little bit but I can't really afk and I have to do a little back and forth in town while handling my business. Pretty annoying I know we have good internet and I've tried all their options, so I'm not sure what's up to be honest. Hopefully there's a fix soon.
Joining general chat channel did NOT solve the problem for me. I was chatting in [General] and I still got DC'ed. Both from the hero preview screen and inside the game.
i am also experiencing the 3007 message when trying to enter the game. YET i can play wow and starcraft just fine! what's going on blizz? I have done everything you have asked me to do to fix it and nothing has made a difference at all.
Please can we get a blue to give us a real response about this?
Rolling restarts going out...lets hope this helps us out!
same issue as everybody else :/

Join the Conversation

Return to Forum