How I Fixed Diablo 3 FPS Slowdowns

Mac Technical Support
Prev 1 5 6 7 Next
This recommendation did not work for me at all.

Still getting abhorrent frame rates. While connected to my 30" Cinema display.

Model Name: MacBook Pro
Model Identifier: MacBookPro8,2
Processor Name: Intel Core i7
Processor Speed: 2.2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB

AMD Radeon HD 6750M:

Chipset Model: AMD Radeon HD 6750M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6741
Revision ID: 0x0000
ROM Revision: 113-C0170L-573
gMux Version: 1.9.23
EFI Driver Version: 01.00.573
Cinema HD:
Resolution: 2560 x 1600
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: ****
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Adapter Type: Apple Mini DisplayPort To Dual-Link DVI Adapter
Adapter Firmware Version: 1.03

System Software Overview:

System Version: Mac OS X 10.6.8 (10K549)
Kernel Version: Darwin 10.8.0
Boot Volume: Mac HD
Boot Mode: Normal
Computer Name: ****
User Name: ****
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: Yes
Time since boot: 12 minutes
Didn't quite help.. My game has been running awfully slow right off the bat, there's no 4-5 minute delay. Repaired disk, made a bunch of space on my hard drive, nothing's been working. I really hope the next patch solves something.
This helped me a lot, areas where I couldnt even move around I am getting a pretty consistent fps now, thanks for the link, I know it will not work for all but it makes the game playable, couldnt kill Balial with my fps, ran through your checklist and was able to complete the battle.

You are awesome
Thanks OP, worked for me! Followed your steps exactly and went from 9-10 FPS to 15-20FPS.

Would love to know why my system suddenly went from flawless play on the default settings since release date, to heavy stuttering from last night though. It coincided with a 'launcher update' from last night. Very odd.

I have a mid 2010 MBP 15" with a 330M graphics card.
so i know people have mentioned about the fps problems going beyond just the 9400M (i have a 2gb 6970 imac 27" with 20gb of ram and get same issues). So I tried this and didn't really notice a difference. but i also changed LimitForegroundFPS to 50. and although the game is spitting out that it's doing 26 fps, i'm getting what seems to be better fps. haven't read this whole thread, so not sure if this has been talked about. either way. i'd rather blizz just fixed the issue (which seems to be mac wide) rather than us having to delve to such depths.
No improvement. Frame rates got worse in fact. Now I am opening the game with only 5-7 fps at one point it was a 0 for a solid ten seconds.

Going to try deleting D3Prefs.txt like some people have suggested.
Good to know mac users paid to be in the beta,

MacBook Pro 6,2 (Mid 2010 15")
Nvidia 330M GT 512mb
Intel i7 2.66 GHz
4 GB ram

Edit: That didn't help either.
Didn't make any difference for me still at 2-10 fps in act 4 everything on lowest settings. Blizzard really dropped the ball womp womp womp woooooooooooooomp.
I'm on the 9400m chipset, spoken to Tech Support twice who - on both occasions - couldn't help me either...

This didn't work for me. $60, down the drain :(

I'd like to point out that my FPS drops when I enter the Forgotten Mines of ActII. I haven't noticed it before then. If, IF - I can play a different character I'll test the theory, but I'm guess I wont be able to run faster than a hobbling pirate.


**Nope... can't move, didn't work for me. Joy. I want a refund -.-
it's weird. I did the first fix, no improvement. then i did the one i was talking about and like i said, fps was saying around 30, but it was playing better. then i logged out, restarted and played with friends...2 actually, and was getting upwards of 90 fps... wtf? go back to single player... back to 30. luckily this game is just a break for me in between homework sessions, but this is a little ludicrous.
I have similar specs as the OP. I have tried all tips/tricks to play for more than 45-1hr w/ out restarting and doing every trick again.
05/17/2012 03:55 AMPosted by SoulReaper
DisableTrilinearFiltering "1"

is the only thing I haven't tried. After doing this, I played 4-5hrs, w/ just a slight fps drop from 30 to 20. And only minor drops during intense fighting, 15 fps. I have played 3 session over 3hrs or more, with the same result.

So I recommend trying this if your having FPS suddenly drop.

My Specs:
MacBook Pro 15-inch, Mid 2010
Processor 2.4 GHz Intel Core i5
Memory 8 GB 1067 MHz DDR3
Graphics NVIDIA GeForce GT 330M 256 MB
Software Mac OS X Lion 10.7.4
Like many other Mac users, after 4-5 mins of gameplay, the game would slow down to a crawl. Looking at the forums, I saw I was not the only ones with the same problem. I ended up fixing the problem myself by doing numerous things both Inside and Outside of Diablo.

In Diablo 3
I set my display to full screen
resolution to 960x600 (or whatever your native resolution is)
Check - Vertical Sync
Check - Max Forground FPS and set to 50
Check - Max Background and set to 1
Set Texture Quality to Low
Set Shadow Quality to off
Set Physics to Low
Set Clutter Density to Off
Make sure Anti-Aliasing is OFF
Check Low Fx

Exit the game and now do into System Preferences in Mac OSX
Go to Energy Saver and make sure Automatic graphics swithing is unchecked!

Now its time to edit the config file for Diablo III
You will have to edit a diablo preference file in
/Users/<<<Your User name goes here>>>/Library/Application Support/Blizzard/Diablo III/D3Prefs.txt

To get there the EZ way (because its a hidden file)

Click on the background of your desktop to make sure you in the "Finder Menu"
- Hold Down the Option Key and hit GO, then click Library (should show up under home)
- Open the Application Support Folder
- Open the Blizzard Folder
- Open The Diablo III Folder
- You will see a file called D3Prefs.txt open that with your text editor
- You will see a line that says DisableTrilinearFiltering "0" change this to DisableTrilinearFiltering "1"
- save file!

My Specs are 2.66 Intel Core i7 Macbook Pro, 8 GB Ram, NVIDIA GeForce GT 330M 512 MB, OSX Lion.

I Hope this helps everyone in the mean time until we get a patch to fix this issue!

i would suggest everyone try this. reason why is this helped me a !@#$ ton i'm using a really old card NVIDIA 8500 GT and i was unable to run the game at ALL on any other res besides 800x so i did this and gave it a shot and set my res up to 1680x1050 and i was expecting it to drop back down to 5 fps well it dident i toggled the fps botton and it was 28 fps! I was unable to play at this res at ALL befor i did this so thank you very much dude

Edit: i would like to know why this gave such a huge boost though.
Ok so here's the thing, I can't seem to find the hidden folder (tried both options), since there's no Library under the Home folder when I hit Go in Finder :(

Also, how can u see ur FPS ingame?
I found on the PC forums that laptops are having the same issues! The fix? Run D3 on a 16gig USB 2.0 Flash Drive! The reason this works is because during play, the game is constantly loading the game from your hard drive. Running the game from the flash drive frees up the hard drive so it can focus on running your video card and collecting the online data. I'm buying my flash drive tonight so i'll update you on how it goes. I have a 2009 macbook 4300m.
Don't u need to make sure your USB is 2.0 too?

Also, anybody on my question?
To see your fps in game press CTRL+R
For those of you unable to find the d3prefs.txt, my assumption is you are running OSX Lion.

There are two sets of "/library/application support" one is on your hard drives base level and another is in your user folder. The one in your user folder is the one you want. Snow Leopard users can simply access this folder by going to Users/yourusername/library/application support/blizzard/diablo III/.

Lion, however, by default hides the "Library" folder in your user profile. In order to see it, you must open a terminal (applications/utilities/Terminal) and type the following:

chflags nohidden ~/Library/

Exit out of your terminal and open a finder window. Now go to Users/yourusername/library/application support/blizzard/diablo III/ and you'll see the d3prefs.txt file. If it's not there, run diablo III, log in, access your preferences, and exit diablo III. The file should now be there.
Tried all of the above... even played around with almost every other value in that file. Nothing.
this scrap is a ploy on blizzards part to sell quad core processors, they make the game only support hardware that came out after the year 2011 and then everyone has to go buy new computers just to play their game, and the economy gets stimulated.

well guess what blizzard im tired of being lied to, and i wont drop 1200 bucks on a new computer just to play your game without lag, make it work properly, good day sir.

Well if we NEED hardware that is 2011 Quad core. Why doesn't my 2600 i7 3.4 ghz Quad core perform. I guess what I should have bought was 2017 Intel 24 Core i34 Processor with Super duper hyper threading. Then I might be able to achieve a consistent 30 FPS.

This is a lesson on what not to do as a developer. I swore off buying EA games and have been successful at doing so now going on 4 years. Last year I said the same about COD games like the new Modern Warfare 3. Am I going to add Blizzard to this $hit list? Would be a huge disappointment, but I am certainly willing to do so when they toy with our money.

And besides, why don't they take the Monthly dues down on WoW. You might actually see more people come back to play the game as evidenced in your bribing people to do so and get a free copy of Diablo 3. WoW is dying and is a 8 year old product. Stop charging like it's some shiny new toy. It really isn't.

Join the Conversation

Return to Forum