BUG: Frame Skipping / Camera Stutter

Bug Report
Prev 1 5 6 7 32 Next
Game designers/developers on reddit for a Q&A:


Game designers Jay Wilson, Wyatt Cheng, and Andrew Chambers will be taking questions live from the /r/Diablo community until approximately 5 p.m. PDT today.

http://www.reddit.com/r/Diablo/comments/uooo/i_am_we_are_wyatt_cheng_andrew_chambers_and_jay/

Feel free to use this thread to continue any relevant discussions pertaining to the AMAA as well. Questions or comments not relating to the AMAA (or topics discussed therein) will be removed from this thread.


Let's see if we can get a question in and get a timeline on this?

SOURCE: http://us.battle.net/d3/en/forum/topic/5626187541#1
I know what stuttering is, I know what low FPS is, and I know what OP is talking about. Fraps will display 60fps(naturally) even during this camera jitter-ness. I could never explain it well enough, but I am posting here to say I have this issue also.
I am really pissed off that the forum mods moved this to Tech Support. after the support folks told me to put it under "bug reports".

It's a bug. It can't be fixed by "Technical Support".

The devs will not see it, or fix it, if it is in this section.
The devs will not see it, or fix it, if it is in this section.


Just so you know, the developers do not read the Bug Report section of the forums. However, I am always in direct contact with them.

We are planning several performance fixes for the upcoming 1.0.3 that should hopefully fix (or alleviate) issues like these.
Good to see a Blue post here... Thanks for dropping by.

Would you happen to know if the devs are aware of this specific issue? Keeping in mind, this doesn't really have anything to do with asset loading, etc.

Also... Thanks for moving it back to the correct section, Vasadan. Much appreciated!
After reading more in detail, it seems like all the people who are having problems even after trying all kinds of supposed fixes are NVidia users. Doesn't NVidia have some special vsync feature called adaptive vsync? Perhaps that is something to check.

Found on NVidia forums:
http://forums.nvidia.com/index.php?showtopic=230423

Just noticed you posted there too gray. I feel sorry for ya man, I hate it when people have to deal with these super frustrating issues. I've been in that position before.

This post seems to suggest that downgrading to 300.83 drivers was the only solution:
http://forums.nvidia.com/index.php?showtopic=226227
Of course, after 30+ hours of trying to fix this, I have tried every permutation of vsync & frame limiting imaginable. Adaptive, adaptive half-refresh, in-game vsync, forced from NV Control panel, etc. None of it fixes the issue, because it's a coding issue, and can only be fixed by developers.

And I've also read of a few people with ATI cards who claim to have the same issue... although there is a possibility that it is slightly different issue they are experiencing, and they may not realize it, because it looks the same? I can't confirm, because personally, I only have a GTX280, and a GTX680 based system. My neighbor has the same frame skipping, and he has a GTX570TI (something like that...)

Hopefully if there are more AMD users experiencing this exact same issue, they will speak-up, as it may help the developers narrow down the problem.

Thanks for re-posting that link - there are quite a few people in there still complaining of this same issue. Hopefully nVidia & Blizzard can figure it out. The one thing is that the OP in that thread claims that with normal vsync he doesn't get a stutter. However in the case of both my PC's, plain vsync DOES cause a major stutter. Every 2-3 seconds.


And I've also read of a few people with ATI cards who claim to have the same issue... although there is a possibility that it is slightly different issue they are experiencing, and they may not realize it, because it looks the same?


That's exactly what I think. Similar, but slightly different issue which seems to be fixable (well I know it is because I fixed it on my own AMD) with some effort whereas NVidia users can't seem to find anything that works. Probably has to do with the difference in how AMD cards do vsync compared to NVidia.
Same issue here on my Asus laptop with GTX260m. I also get the 3-digit spike, although I don't see that everytime. Going to try some of the suggestions in this thread to be sure they don't work for me either, but this is obnoxious for sure.
Hi Mykillk, I am using an ATI card as well (Mobility Radeon HD 4670), I'd like to try option #1 but am not good with computers. Link to your workaround - http://us.battle.net/d3/en/forum/topic/5270834509?page=4#70

My questions:

1) How do you get it into full screen windowed mode (and switch it back to normal fullscreen)?
2) How do you turn Aero on?

Notice I mentioned workaround as I still think that it should be 'fixed' without having to do anything special each time I want to play a game.

Thanks.
Hi Mykillk, I am using an ATI card as well (Mobility Radeon HD 4670), I'd like to try option #1 but am not good with computers. Link to your workaround - http://us.battle.net/d3/en/forum/topic/5270834509?page=4#70

My questions:

1) How do you get it into full screen windowed mode (and switch it back to normal fullscreen)?
2) How do you turn Aero on?

Notice I mentioned workaround as I still think that it should be 'fixed' without having to do anything special each time I want to play a game.

Thanks.


Fullscreen windowed mode is an option in the in-game Diablo 3 graphics settings. You can change between fullscreen (i.e. fullscreen exclusive), fullscreen windowed, and windowed mode.

Aero is turned on by default in all versions of Windows 7/Vista that have it. Windows Home Basic does NOT come with Aero (but can be made to work with some effort). You will know if Aero is enabled if you have the semi-translucent bars on all your windows, rather than the opaque bars, as seen here:

http://upload.wikimedia.org/wikipedia/en/thumb/d/df/Aero_Example.png/250px-Aero_Example.png

If you find the game too bright in fullscreen windowed mode, like I did, the only way you can adjust it is to change your graphics settings in the AMD Catalyst Control Center application (which is part of the drivers for your AMD video card). I found dropping my contrast from 100 to 60 and saturation from 100 to 80 made the game look a lot better in fullscreen windowed mode. Let me know if you need some instruction on doing this, it's easy.

I'll give you detailed instructions on how do option #2 if you'd like as well. It's definitely more involved but it's a one-time-only kinda deal.

And yea, it's a workaround, not a fix, agree completely.
Radeon 6950 1gb Crossfire and I'm experiencing the exact same issue.

Fullscreen Windowed mode does not fix this in my case, if anything it makes it worse, as the FPS meter goes crazy a bit more often in my experience.

Forced DirectX Tripple Buffering via RadeonPro, it helps slightly, but the bouts of stuttering still occur.

Setting Flip Queue Size to 0 + Agressive API Detection + High Process Priority + Tripple Buffering has the effect of a) completely eliminating the worse periods of stutter, when probably half the frames get dropped, however it b) forces frames to get dropped regularly instead - when moving sideways you can almost count to it - 1, 2, 3, drop, 1, 2, 3, drop - regardless of what's being displayed on screen and where in the game you are - pretty much exactly like in the youtube videos the OP linked to. If you can live with this it's probably the most viable, or at least predictable, fix for AMD users (not sure whether Overrider has the same options), but it still annoys me...

P.S. Tested again and I don't think Tripple Buffering actually gets applied, with or without Agreesive API Detection
I am having this exact same issue as described here.

My system in brief:

i7 2600K 3.4-3.8 stock.
Asus P67 Pro
16GB Corsair Vengeance 1600MHz
Gigabyte GTX 580 1.5GB Ultra x2 in SLi
Dell 2711U @ 2560x1440 59/60Hz
OS running on OCZ Vertex 3
Game running on OCZ Vertex 2E

I have tried a torrent of suggested fixes & tweaks using nvidia cpanel, nvidia inspector, regedit for CPU core parking, etc etc etc etc etc etc etc etc etc.

I disabled SLi altogether in nvidia cpanel (not just per game but globally switched it off) and this seemed to help the most but it never went away completely, just seemed to alleviate it a bit, which is odd because turning it off just for D3 didnt do anything.

I hope they fix this soon because its discouraging me from playing the game as it gives me a headache after a while, and if they don't fix it at all I certainly will not be purchasing another game from Blizzard again!
Wonderful OP. Excellent write-up. Exact same problem.

i7 @ 4.0GHz
Gigabyte GTX460 (1GB)
6GB Corsair 1600MHz (triple channel)
Windows 7 64-bit

Should be absolute priority #1 for Blizzard right now, even more than reducing lag.
The problem has already been fixed.

Here is how to fix it:

1) Disable v-sync
2) Set max foreground fps to 60
3) Set max background fps to whatever you want
4) Launch a website with flash in it ( Youtube for example )

You can laugh all you want, this fixed the problem for me.

My FPS was limited at 50 and I had the micro stutter, and as soon as I open something with flash, it limits to 59, just as intended.
Thanks Wyloch.

BTW, I find more youtube videos, forum posts around the web, etc., everyday about this issue. I think it is FAR more widespread than I had thought when I created this post.

Euphy... No, this problem has NOT been fixed. Running a youtube video will not fix an engine issue, although it may help you stabilize the fps on *your* system for some odd reason. However, it does nothing for me. Clearly the issue you are having is not what I am experiencing... and running without vsync in D3 creates a LOT of tearing. This issue can only be fixed by the coders. Thanks for the suggestion, anyways.
Well what you described is exactly what I had so... You might want to give it a try.
+1

GTX 550ti

Join the Conversation

Return to Forum