Game Connection Has Been Lost

Mac Technical Support
I don't know how much this will help, but I'm seeing a very similar issue after the most recent patch. Every time I start/join a game, I get a disconnect after ~10 seconds.
Does this happen when you optimize internet connections? Also, when a new user is created and D3 tested?
07/23/2012 05:05 PMPosted by Machkhan
Does this happen when you [url="http://us.battle.net/support/en/article/optimizing-your-internet-connection-mac"]optimize internet connections[/url]? Also, when a new user is created and D3 tested?


Yes, give him the information and then he'll be sure to get back to you in the next month or so.

Good luck!
Same thing happening to me. I get disconnected just like the others. I use a repeater but it happens w/o using it as well just using the router. I have no issues using my PS3 from the repeater or streaming. I have cable and this started happening after the patch ONLY. So I feel (know) it has something to do with that. It's starting to get very annoying when I dont have friends online to play with because then I lose all my stacks.
It would be nice to see Blizzard fix this soon.
I am having this issue as of 4/9/2013!!!!!!!! I live if California and use a MacBookPro on AT&T Home DSL! Error 3007! I hate you
Is this issue still happening Baal?
i have same problem....after 20-30 min of playing, game crashed... I get disconnected just like the others guys :/ its happen to me over 6-8 months, and blizz do nothing with this issue, damn too bad, and how to play? btw my net and comp are fine, so its the game problem imo.
im having this issue on both PTR/LIVE is unplayble at the moment i dio believe is the whirlwind from barbs?i could be wrong,please m8 whats your name again,machkhan please fix it is really a pain to be on ptr and get dc every pull,some times it does last longer but the dc is 100% incoming you dont know when,please this guys they acting like technicians look in to this matter ty
please look in to this 2 weeks now imposible to start a game and finish we get dc at any time the game wish is it anyone at least to look those bugs ?
I was having the same issue. I simply opened my start menu, searched for cmd. when you open it type in ipconfig/release, wait for it to load. Then type in ipconfig/renew. wait for it to load. exit and then try to load into a game. let me know how this works for you!
This must be related to patch 2.0.3. More often than not, I get disconnected from the server when I try to start a game. Was not happening before the latest patch.

Mac mini, running the latest OS (10.9.2 I think)
i have been playing for months now not a prob same internet isp same everything then out of the blue it seems with this new patch last tuesday (maintenance day for me) i play with a friend he is in america i am in australia he has no issues i never use to up till about 5 days ago or so i run windows 7 ultimate in game i can play maybe 5 mins then it states lost game connection- your game client is disconnected iv never had this problem before the patch and im just guessing here i dont run wirelessly its all wired and iv tried both tried to flush out my modem tried run cmd promt to renew ipconfig nothing works the game is unplayable for me i open a rift half way through it disconnected i do 2 to 3 bountys disconnect i cant do a single thing now and i love this game so addicted now i cant play it at all
I have the same problem. Suddenly I can't start a new game, it goes to the loading screen for a while,then I get the message "the game connection has been lost: your client has been disconnected from the server". I just bought the expansion and now I can't play at all so it's kind of frustrating. Still no fix for this? it seems like quite a few people have it. (Actually I just bought the game for my girlfriend too, so we could play together)
10/07/2015 08:15 AMPosted by residentcrow
I have the same problem. Suddenly I can't start a new game, it goes to the loading screen for a while,then I get the message "the game connection has been lost: your client has been disconnected from the server". I just bought the expansion and now I can't play at all so it's kind of frustrating. Still no fix for this? it seems like quite a few people have it. (Actually I just bought the game for my girlfriend too, so we could play together)


This is a very old thread, you might want to start a new one.
Same here 'the game connection has been lost"

Join the Conversation

Return to Forum