Tempest Rush bug

Bug Report
Occasionally, after my monk uses Tempest Rush to get to a spot, she teleports back to where she started the rush. Might be due to lag as it seems to happen more frequently on high latency
This is very frustrating because it makes the skill not consistent in its usability. I have also noticed it only happens when used for escape as well.
its terrible. I'm in Hell mode right now, not being able to use the tempest rush is costing me greatly. i glitch back to the previous position and get caught back in fire chains. i understand enemies can pull you back, but that's not the case here.
This is happening with all the movement spells. DH vault, wizard teleport etc. Very annoying.
I m having same problem. Wasn t too much big deal until i get on Hell mode. Now i die so often because of this ANOYING glitch.

Hope they will fix it
I have this problem even when I try to run from mobs mid fight, I'll get teleported back more often than not and die from it. I made a tempest rush build and noticed it happens frequently as well. I've probably got some video of it from my speed run.
I'll post what I posted in the other similar thread. This issue has to be looked at. We need to be heard.

Blizzard please fix this!! I get the same thing also. It's not lag, it's not vortex...it's simply glitched.

Sometimes it's like confining you in a certain zone/area that you cannot get out of after using TR. You either have to move to another direction or simply wait for a while.

Let's say I use TR to go torwards the bottom of the screen then I get pulled backwards where I started to use it in the first place. If I try to move down the same path again while simply running I'll get pulled back to the original starting piont over and over again until I move to another direction or wait a little bit.

I really love that skill so please fix it or at least tell us you're working on it.

Give us something!
This glitch just cost me a lvl 55 Monk. Feel a bit cheated now that I see other people are having the same issues. Please look into this devs!!
are dev replying to any thread or not? its fun to know that they are looking into it at least...
bumping
^
I had terrible latency issues recently (cause of my isp) and I found was able to get it working more reliably by standing still until it triggered and then moving. Still needs to be fixed though.
I see this all the time and my latency is frequently around 100 ms. Most of my deaths are due to this bug.

I'm using the increase speed rune.

This seems to happen when you are in an large elite group of mobs, getting hit. It was a minor annoyance in the easier difficulties, but with inferno. It's made me want to stop playing.
I play a monk designed explicitly to be able to tr away. I spent a fortune getting spirit regen items so i could tempest rush+use cooldowns while having to run away across large expanses. I just lost a 60 HC monk due to this bug. I only play monk, and I love this build, so this bug has literally made the game unplayable for me. I hope we can get some insight as to if this is even being looked at.....
Also confirming this.
yes extremely bugging. It happens so frequently when kiting with the elites that it is no longer funny and not even lag instance.

extremely annoying. been paying so much gold for repairs for some mistakes that's not even mine! I witnessed so many times that I have escaped from the elite packs but just to be pulled back shortly after to their elite faces and death awaits! Those elites dun even have the suck-you-back kind of teleport skills!
Confirm.
Bump.
--Non Vortex Champs/Rares--
Use TR to get out of harry situations quickly, but glitch right back to the start (molten, plagued, or Arcane enchanted orb) only to die.
--105ish ms latency--
This really needs to be fixed.
I have this issue when surrounded. Make sure to completely get clear of the mobs before stopping usually prevents it from happening.

Join the Conversation

Return to Forum