Auction House Bug

Bug Report
So i just bought a helm on AH for 200k, then an error came up and when i tryed to buy it again it said it was sold, i then noticed i had lost the 200k and i never got the item.
Has anyone else experienced this?
Same thing just happened to me.
Yeah this just happened to me and I lost 400k. Actually, it usually comes back after a while, but this time it was a permanent 400k loss...
Just happened to me as well I lucked out and only lost 10k. Anyone know how to fix this?
Well now i just lost 800k because of timeout bugs..
Just happened to me too lost 12k. Not so bad, but still...
It says I won the item and it is in my completed auctions list but is not in my completed items list so I can not put it in my stash. Is that what happened to you as well?
Same thing just happened to me. I bought out an item, it shows up as purchased in my auction log but, no item in my completed list so I can send to stash. Out 15k
It's not in either list for me, but i definitely lost the gold. >: (
I just bought a belt War Pursuit for 20k

In my Completed it shows I bought it but does not show up any where .

So now out of the 20k.
Bought a conquest aim for 20k, says completed, but i can't see it to send it to my stash
same here, lost 145k =(

so... sad...and disappointed...
This happened to me on a bunch of items yesterday. Happened on a few weapons, it'd timeout, my gold would disappear, no item, and when I went back, it said it was sold. Today, I logged in to find 3 weapons and a bunch of gems all in my completed list. So, at least for me, it was just a case of very severe (~24 hours) lag. I love the game, but the last couple days the AH has been almost unusable.

Just happened again with a ring I bought. Perhaps it'll show up tomorrow too.
Just bought a falcon conclave bow for 20k. Bought out the bid and then it !@#$ing timed out. Lost my 20k and I have no item...

I'm assuming blizz can't do anything for us? How is this gonna work when the real $ gets used? Broken system is broken and instead of silently needing things why don't they publicly announce them fixing things that should be working day 1....?

Edit:
The item showed up in the completed tab and says I bought it out for 20k. I'm assuming it will show up sooner or later?
same thing happened to me and the worst part is that I though I didn't buy that so I purchased the other and still don't have them, also my item does not appear on auction house, U guys need to give that back so I can post again. I can't find my item that I have posted on AH
Just happened to me minutes ago, gold gone but no item given :(
An update on my situation, I checked before I got off for the evening... It was there waiting to be out in my stash. Just about 3 hour lag after it timed out.

All in all the auction house is extremely laggy/buggy. I hope people wait for a patch in that alone before wasting cash.

Join the Conversation

Return to Forum