Terrible FPS? Possible fix for Nvidia users

Technical Support
I found a possible fix for Nvidia users(I have a GTX 260M).

When I first got D3 my computer was running on the lowest settings possible and on a good day could barely hit 15 FPS. The game was basically unplayable and I almost quit playing after none of the recommended fixes had any effect.

Yesterday I decided to give it one last shot and went in to the Nvidia Control Panel and changed a bunch of things around ( make sure you have the latest update from May 22). I am not sure exactly what I did but it worked like a charm. I am now playing with all settings maxed at a constant ~60 FPS.

Here are my Control Panel settings for those who want to give it a shot:


Ambient Occlusion Off
Anisotropic Filtering Application controlled
Antialiasing - FXAA Off
Antialiasing -Gamma correction On
Antialiasing - Mode Application controlled
Antialiasing - Setting Application controlled
Antialiasing - Transparency Off
Maximum pre-rendered frames Use the 3D application setting
Multi-display/mixed-GPU acceleration Multiple display performance mode
Power management mode Adaptive
Texture Filtering - Anistropic samp.. Off
Texture filtering - Negative LOD... Allow
Texture filtering - Quality Quality
Texture filtering - Trilinear opt.... On
Threaded optimization Auto
Triple Buffering Off
Vertical Sync Use 3D application settings

PROGRAM SETTINGS ( Make sure you add D3 to the list)

Ambient Occlusion Use global setting ( Off)
Anisotropic Filtering Use global setting (Application controlled)
Antialiasing - FXAA Use global setting (Off)
Antialiasing -Gamma correction Use global setting (On)
Antialiasing - Mode Use global setting (Application controlled)
Antialiasing - Setting Use global setting (Application controlled)
Antialiasing - Transparency Use global setting (Off)
CUDA - GPUs Use global setting (All)
Maximum pre-rendered frames Use the 3D application setting
Multi-display/mixed-GPU acceleration Use global setting (Multiple display performance mode)
Power management mode Prefer maximum performance
Texture Filtering - Anistropic samp.. On
Texture filtering - Negative LOD... Use global setting (Allow)
Texture filtering - Quality Use global setting (Quality)
Texture filtering - Trilinear opt.... Use global setting (On)
Threaded optimization Use global setting (Auto)
Triple Buffering On
Vertical Sync On

I hope it works!
im not computer savy and all this just seems like a voodoo to me, i have a ASUS laptop 2 years old and all i know is that im sick of the lag in this game, how do i change these settings?
What video card model do you have?
Anyone confirm this helps?

Other posts have recommended many of these settings to be the opposite.

It'd be nice to have a unified Nvidia and in-game optimal settings for max performance thread somewhere. I've used almost every combo I can think of
best fix is underclocking that i found
05/27/2012 08:28 AMPosted by Pippin
im not computer savy and all this just seems like a voodoo to me, i have a ASUS laptop 2 years old and all i know is that im sick of the lag in this game, how do i change these settings?

Open start menu and type in Nvidia. You should see NVIDIA Control Panel on the list. Just open it and go to manage 3D Setttings.

05/27/2012 08:30 AMPosted by Apoctalyte
What video card model do you have?

Nvidia GTX 260M

05/27/2012 08:37 AMPosted by ZerotheHero
Anyone confirm this helps?

A few people from other forums seem to be having luck with it.

Here are my in-game settings as well since there have been questions about that too:

PreferencesVersion "42"
PlayedCutscene0 "15"
PlayedCutscene1 "15"
PlayedCutscene2 "23"
PlayedCutscene3 "143"
DisplayModeFlags "0"
DisplayModeWindowMode "0"
DisplayModeWinLeft "320"
DisplayModeWinTop "156"
DisplayModeWinWidth "1280"
DisplayModeWinHeight "720"
DisplayModeUIOptWidth "1920"
DisplayModeUIOptHeight "1080"
DisplayModeWidth "1920"
DisplayModeHeight "1080"
DisplayModeRefreshRate "60"
DisplayModeBitDepth "32"
Gamma "1.000000"
MipOffset "0"
ShadowQuality "2"
PhysicsQuality "1"
ClutterQuality "2"
Vsync "0"
Letterbox "0"
Antialiasing "0"
LowFX "0"
LimitForegroundFPS "1"
MaxForegroundFPS "150"
LimitBackgroundFPS "1"
MaxBackgroundFPS "8"
DisableTrilinearFiltering "0"
ColorCorrection "1"
MipBias "0.000000"
ReflectionQuality "0"
TonemapExposure "1.900000"
TonemapContrast "1.500000"
TonemapSaturation "1.000000"
TonemapGain "1.000000"
HardwareClass "3"
PCIVendor "4318"
PCIDevice "1560"
MasterVolume "0.620000"
EffectVolume "0.560000"
MusicVolume "0.270000"
NarrationVolume "0.900000"
AmbientVolume "0.090000"
ChannelsToUse "16"
ReverseSpeakers "0"
QuestSubtitlesEnabled "0"
CinematicsSubtitlesEnabled "0"
EchoQuestDialogToChat "0"
MuteSound "0"
MuteEffects "0"
MuteAmbient "0"
MuteVoice "0"
I have a 260m in my alienware m15x and it renders diablo beaut.
There are only two settings you changed that are different from default:

Power management mode - Prefer maximum performance
This will prevent the video card from downclocking during non-intensive graphic needs. Unfortunately, it doesn't always work well. It will often downclock at the wrong times, causing stuttering.

Triple Buffering - On
This will provide more consistent fps but is not really an fps booster.

That said, fps can change on a day to day basis, even hour to hour. The current state of D3 servers/networks/congestion and client-side optimization is providing very unreliable readings. Quitting out of the game and restarting can often solve problems.

Most of these 'fix' threads will be unnecessary once Blizzard has this all straightened out. No telling how long that will take but I would guess by July.
What worked for me is just deleting my D3Prefs.txt file (exit Diablo 3 completely first) and letting Diablo 3 recreate the file. Then, restart Diablo 3.
Same comp, Alienware M15x with the 260M. I get awesome FPS even in monster fights but am still dealing with the stuttering problem. It's not the same as normal lag you'd experience from poor hardware, but the new drivers did improve my fps.
so the first week the game was out, my M15x ran this game like a pro. I was really happy with the quality that I was getting. Mainly medium settings, but full resolution. Fell in love with the game, and played every day.

Turned it on Monday to show some friends my new character, and I can't get the game to go over 15 FPS. I don't understand what changed, but I'm really upset. Played it long enough to fall in love with the game, but now I can't. Is there really no solution and we are just waiting for blizzard to fix this?
I had to bump this. I just applied his settings on my Alienware M17X R1 with a GTX 260m; it changed my world.

I gained over 20 FPS. I could never understand why the game was running so poorly and I still don't. I'm just happy it's running as it should.
Game does not like nvidia cards, i dont know why i have fps drops on my gtx650ti oc pe

Please don't bump old threads like this from several months ago.

Nvidia cards work just fine with Diablo III.

If you have an issue, please start your own thread, describe the problem as completely as you can, and tell us what steps you've tried so far to fix it.

Your dxdiag info and D3Prefs.txt file will be helpful as well.

You can find this information in the Direct X Diagnostic Tool:

Click on Start
Click on Run
Type in: dxdiag (In Vista, type dxdiag in the search field)
Hit Enter or OK

Click on the Save All Information button at the bottom, and create a dxdiag text file, and copy and paste it ALL here.

The D3Prefs.txt file is located in the My Documents\Diablo III folder.
First what does it matter if I posted in this thread, its on the forum, I really dont know what thread age have any importance here and second if that is the case why You just dont delete old threads?

Join the Conversation

Return to Forum