Diablo 3 Crashing On Startup

Technical Support
Same issue here. As soon as i get past the head and try to login it, it crashes. EVERY SINGLE TIME.
I guess I'm a bit late to this party, but I'm now in the same boat. Was able to play the game without any issues at launch, now when I try to launch the monitor loses its signal after getting past the head, then after about 30 seconds the game has crashed back to the desktop and the monitor comes back on. No error message or anything. I've put a ticket in with Blizzard support, but judging by what I've seen on the forums, it may have been a waste of time.
I'm just now getting this as well. Sounds like the same problem you have. I get a little pop-up saying "Diablo 3 is unable to validate core data files" after the crash. sad face.
Try deleting the cache folder in Diablo 3 > Data_D3 > PC > MPQ's and delete the .tfil and .mfil files in the root D3 folder. Run the game again, and let it download and recreate these files and folders. This is the usual fix I try when something goes wrong after a patch or a maintenance cycle, since it seems to do odd things to those particular files.
Thanks for the reply. I found out that the fan on my graphics card isn't turning on. I feel silly now. I will get a new graphics card and see if that fixes everything. =)

nvm, I plugged the fan into a port and have it running at a constant. Still get the same issue. Also, I did what you said. I think I'll be quitting D3 for now.
Hmm dunno if this will help anyone, but I get it from time to time as well.. I go in, rename Diablo III.exe as Diablo III.old and launch the game again... works for me
This or some other newly introduced change causes my system to halt immediately. By that I mean total power down without closing anything. It just started doing it. I am wondering if a .NET mod from another source may cause this?
07/04/2013 03:12 PMPosted by RushDL
This or some other newly introduced change causes my system to halt immediately. By that I mean total power down without closing anything. It just started doing it. I am wondering if a .NET mod from another source may cause this?


I would suggest you look at the windows event log to try to find any errors pertaining to DiabloIII

the event log may tell you what is going on.
same prob here nvidia gtx 280
I'm reinstalling now but since I read these, I don't think it'll help much. I'm pretty pissed off considering I literally just upgraded to RoS xD. Anyone have a fix yet?
mine just starting to crash....idk whats going on...been playing since the game came out and now im having probs...
Having same issue.

Bump.
xZurari ,

In a new thread of your own, please describe the issue you're having along with any error messages you may be seeing. Include all the steps you've attempted so far to resolve it.

Also post your D3Debug.txt file. It's located in the main Diablo III game folder.

______________________________________________________________
I'm available in the forums Monday - Friday 6:00 am - 3:00 pm Pacific Time,
Feedback? - https://www.surveymonkey.com/s/Omrakos

Join the Conversation

Return to Forum