Terrible lag

Technical Support
Jakweezy,

Your hardware looks fine, not really lacking anywhere. Your connection is what still bothers me though. We aren't able to offer support for troubleshooting wireless connections. There are just too may variables involved that could be limiting performance and causing dropouts.

Running wired is the one true troubleshooting step we have for determining if that's a cause of a problem or not. I can't simply ignore it and continue as if we've done that. It just takes a cable, even a long one will do stretched across the floor. If you're prohibited by the distance between your computer and the modem/router, that alone is good cause for running a cable as that distance can be a major factor.

____________________________________________________________________
Support Information Administrator
I completely understand. I have a sense there is a problem with the connection as well. I will try to get the ethernet hooked up tomorrow. The main problem I have been finding though is that I can play with other people and talk to them on skype, but when D3 lags out, as I described before, skype will act perfectly fine. I'll just sit there talking to my friends about how D3 lagged out again. Any other internet required application works fine as well. It is possible that Kanaloa will give you better insight into the issue, as he stated that he uses ethernet. Either way, thanks for your help on the issue.
Here is 2 photos to show you the proof that my internet connection is not the problem!

1: diablo 3 laggy with 409 ms ping http://ctrlv.in/89599

2: bf3 fine with 20 ms ping http://ctrlv.in/89600

BOTH AT THE SAME TIME!

please don't ignore my post and say that our internet connection is the problem

Edit: just to be sure, i just ran a speedtest
here is the result

http://ctrlv.in/89602
Any information that could help increase my games speed and playability would be great. Mahalo.
Im having the same issue. But i dont even bother posting here, cause they will block the thread or they just ll tell you it ur problem and not the servers. It s always the same thing.
Im trying to progress on inferno but with 500 ms and having a class that gets 1 shoted, after dying 20 times u just give up and go back to jump in orgrimmar.
Found and update for my video card. installed it and tried the game. Still lagging out on any pull over 10 mobs. It is getting harder and harder to progress due to this issue. Please any help would make a difference.
Just want to say seeing the same issues. I had lag spikes before but never like this.

Besides the standard connection errors like "your client has been disconnected" or error 3007, the following new errors I have never seen before popped up.

-There was an error creating the game. (Error 316609)
-There was an error loading the hero's data. (Error 3006)
-There was an error sending the whisper message. (error 3006)

Funny thing is, my roommate who bought the game at a later date is doing fine as far as I can tell in normal mode, while my inferno mode wizard can't even cast spells. So it can't be my internet connection. I highly doubt it is the hardware as all other games works fine and I rarely had those issues before with d3.

All I can think of is that there multiple servers and each account uses a specific server and only that server, and the ones we uses are just screwed up. :(.
I just started experiencing the same issues this evening. Complete lag out when ever anything happens, and latency spikes up to 3 seconds. But its not latency, because when that drops back to ~250, my framerate still drops to 1-2 frame per second as soon as anything starts to happens.

None of this occured until tonight.
Relax guys. It's Blizzard's servers, not your internet connection. Give it awhile and Blizzard will realize that it THEIR problem. Then they will finally do something about it (hopefully).

Although, Blizzard has been quite rotten lately. The aren't the Blizz they used to be.
Do I need to create a new post to get a reply from Omrakos? Only the creator of the thread is given a response? Or do i just need more patience?
Relax guys. It's Blizzard's servers, not your internet connection. Give it awhile and Blizzard will realize that it THEIR problem. Then they will finally do something about it (hopefully).

Although, Blizzard has been quite rotten lately. The aren't the Blizz they used to be.


I just wished they would have made the single user version of this game offline.
05/30/2012 06:47 PMPosted by Tabascosauce
Relax guys. It's Blizzard's servers, not your internet connection. Give it awhile and Blizzard will realize that it THEIR problem. Then they will finally do something about it (hopefully).

I've been saying this to myself for the past 2 weeks regarding the assest/stutter issue, we got a response basically saying we're exaggerating the issue and it doesn't actully happen in the retail release (not joking, we really did).

I just think with certain issues they're just not bothered (and if they are bothered, they're keeping it quiet for some reason), i hope they finally show there good side and fix these 2 quite major issues and admit they exist.
I would also like a lag fix or server fix so I can beat Diablo on Inferno. This game is less fun when you are rubber-banding and abilities delay. I am also on a Cable connection that does not give me any problems in other online games.
Relax guys. It's Blizzard's servers, not your internet connection. Give it awhile and Blizzard will realize that it THEIR problem. Then they will finally do something about it (hopefully).

Although, Blizzard has been quite rotten lately. The aren't the Blizz they used to be.


I agree with you it is Blizzard's server. But even then, we are completely at their mercy. Will Blizzard acknowledged it is their server? will they fix the problem? if they fix the problem, how long will it take? In the mean time, the game is completely unusable. it is a laggy auction house/commodity trading simulation right now.

It sucks that my roommate who uses the same internet connection, via wireless, can play fine while it takes me 20 seconds just to use the waypoint.

I wonder if I can request Blizzard to move my account data to whichever server my roommate's account is housed in.
The only resolution to my lag was to change my screen resolution to 800x600. The graphics aren't so bad looking and I only lag in the spider cave.
Yeah I can only play on 800x600 as well, but then again I have an ATI Radeon 3000. lol........
05/30/2012 07:19 PMPosted by StarchCraft
It sucks that my roommate who uses the same internet connection, via wireless, can play fine while it takes me 20 seconds just to use the waypoint.
If it is Blizz's servers then everyone would have that problem would they not? As far as I have seen only a small percentage of users have lag issues, not enough to say it is Blizzard's servers. I don't know what else to do except to post your computers specs with the lag posts and hope they can give you a solution to your problem. It may also be a problem with your ISP but considering your roommates runs fine and assuming you use the same ISP it might be a different problem.
tried the resolution, Helps but is not a fix, game looks worse than D2. I am able to move more easily in the lowest resolution but still have problems with large puls. I tired to make another post but did not get a response. My opinion in Blizzard is declining with the more i play D3, and the more i try to get help with the problems I am faceing.
05/30/2012 07:43 PMPosted by Darqfang
It sucks that my roommate who uses the same internet connection, via wireless, can play fine while it takes me 20 seconds just to use the waypoint.
If it is Blizz's servers then everyone would have that problem would they not? As far as I have seen only a small percentage of users have lag issues, not enough to say it is Blizzard's servers. I don't know what else to do except to post your computers specs with the lag posts and hope they can give you a solution to your problem. It may also be a problem with your ISP but considering your roommates runs fine and assuming you use the same ISP it might be a different problem.


You are assuming that Blizzard has one big server, instead of server farms.

Secondly, you are referring to graphical lags. When my latency goes to hell my fps is fine. I can issue all the commands, just nothing happens. Monsters stay still, actions are not registered, and if I run far enough I see a black wall.
Running wired is the one true troubleshooting step we have for determining if that's a cause of a problem or not. I can't simply ignore it and continue as if we've done that. It just takes a cable, even a long one will do stretched across the floor. If you're prohibited by the distance between your computer and the modem/router, that alone is good cause for running a cable as that distance can be a major factor.
I run my computer wired with a long ethernet cable from my kitchen to my bedroom. I still have lag and I ran WoW and SC2 good on this computer. In fact I bought this comp right after Cata came out because every time I got on the game it crashed my comp. I have had no crashes with D3 however the performance is not what it should be.

Join the Conversation

Return to Forum