Attack speed boots

Bug Report
I am wondering when the "Increases attack speed" on boots (Boj Anglers) will be repaird.Because now it doesn't work.
So i wait for a smart answer.
There are several threads regarding this issue, but no blue post.
it will be fixed in 1.03 atm only boots/betls with attack speed increase work and not the increase atk speed ones and there are several blue posts that confirmed blizz is awxer of it and it will be fixed soon )
SOON™
soon is not good enough on an issue like this...a vast number of items being sold for top gold and they're practically useless because the major affix of the item is broken...but that's not important, let's make is so people don't have to spend 20 sec to go repair an item before they can sell it....soon is not good enough!
I just got off the phone with a representative from Blizzard and he informed me to place this bug report hoping to speed up the process of having this issue fixed. I noticed that the pair of Boj Anglers that I have that read "increases attack speed by" do not buff any of my heroes but the other pair that I have that read "attack speed increased by" work perfectly fine. Just to note, I had this issue both pre and post the attack speed nerf from patch 1.0.3. I will try to get before and after screen shots of both pairs of Boj Anglers on one of my heroes to show that they dont work properly. If anyone else can post screen shots maybe it will help Blizzard fix this problem more quickly. Thanks.
06/19/2012 09:04 PMPosted by Sporkn8er
I just got off the phone with a representative from Blizzard and he informed me to place this bug report hoping to speed up the process of having this issue fixed. I noticed that the pair of Boj Anglers that I have that read "increases attack speed by" do not buff any of my heroes but the other pair that I have that read "attack speed increased by" work perfectly fine. Just to note, I had this issue both pre and post the attack speed nerf from patch 1.0.3. I will try to get before and after screen shots of both pairs of Boj Anglers on one of my heroes to show that they dont work properly. If anyone else can post screen shots maybe it will help Blizzard fix this problem more quickly. Thanks.


This info may help, from one of the other posts Vasadan made (the patch notes mentioned this as well):

Items
Existing Legendary items that had the bugged Increased Attack Speed affixes will not get fixed until a future patch. All newly-created Legendary items (created by the player or the game) will correctly increase your attack speed.


I have a couple legendaries that are waiting for the fix as well, but for now, anything you had before the patch still won't work just yet. Hopefully the fix will be coming soon, but it may take some time. They did say in the patch notes that existing legendaries are being worked on.
Asheara's Lock is also affected by this bug. I bought the boots for the attack speed increase and paid way too much for them and the attack speed bonus does not work. i stopped play for about two months now because i was pissed off, and then got busy. Now i come back and the bug is still there... Seriously pisses me off.
07/17/2012 04:12 PMPosted by Mïng
Asheara's Lock is also affected by this bug. I bought the boots for the attack speed increase and paid way too much for them and the attack speed bonus does not work. i stopped play for about two months now because i was pissed off, and then got busy. Now i come back and the bug is still there... Seriously pisses me off.


seriously pisses me off when people don't read the known issues list....and then i laff at them for buying boots that have been bugged and noted as bugged since day one ...rofl

Join the Conversation

Return to Forum