Need some help please

Games & Technology
Is it the AMD system monitor or AMD catalyst manager I have to uninstall? If not I cant find it :p

Could it be that it was messed up when they were instsalled? because it says they were released on 4/25/2012 and version 12.4 but dxdiag says 04/02/2011 version 8.832.0.0
AMD Catalyst Manager
Will I need to get USB drivers and Audio drivers again aswell?
No, this should only uninstall graphics driver

Check to ensure only graphics driver and catalyst control panel is getting uninstalled
For the DriverSweeper, Do I only want to clean the AMD-Display, or do I also want to clean Intel-chipset, Nvidia-chipset, Nvidia-display, Nvidia-Physx?
Only AMD - Display. Leave rest unchecked.
Well that didnt work too well. Installing the graphics drivers didnt work, shows nothing in dxdiag and in device manager it has that yellow triangle with the "!" on it. what should I do? xD
Did it install completely in the end, or did it quit with errors?
Pretty sure it finished, but I think it said something about errors at the end
Yellow ! icon, but saying that it finished completely?
I always get that error but works fine for me.

Did you reboot after installing?
Yea I restarted after, Should I just try it again? or what should I do?
Uninstall using control panel -> CCC manager
Reinstall again

During installation, it detected your hardware and didn't say anything about not finding AMD hardware?

If it doesn't work again, try with drivers found here:
I'm not sure, wasnt really paying attention to it, ill watch more closely this time.

I tried those drivers before I asked for help on the forums, didn't work.
Well it said it finished successfully that time.
Reboot and see what happens
No good. Still says there's nothing in dxdiag, and still has the yellow triangles with the "!" in device manager.

Oh and I forgot to ask, will leaving my laptop plugged in ruin the battery or will it just run off the power from the outlet?
Download and run GPU-Z, does it report which GPU?

Also, it'll just run off the power from the outlet
It shows them both on GPU-Z, The Radeon HD 6520G & the Radeon HD 6750M
Then it seems to be installed correct if GPU-Z can detect them with no problem.

Try running a game now.
Tried Diablo 3. It won't start up, the launcher will open and after i press play that loading thing with diablos face will pop up, but the game doesn't start. Also cant change any graphics settings, like the crossfire and stuff. It only shows power settings and things like that.

Join the Conversation

Return to Forum