Diablo 3 Launcher won't start...

Technical Support
1 2 3 6 Next
Ever since the latest patch my Diablo 3 launcher won't even show up. It came up the firs ttime with the option saying there is an update and gave me the choice of restarting the launcher... so I did. Ever since then the launcher won't start.

- I run as admin, it won't show up.
- I run it normal, it won't show up.
- I open the processes and watch as I try to start. The Launcher shows in the processes for 7-10 seconds and then goes away as it it were closed. There is also a battle.net updater that tries to run but also closes.
- From here I uninstalled Diablo 3 and restarted my computer. While trying to install Diablo via disc... The launcher / installer will not show up. Again, it shows itself in the processes but closes itself shortly after.
- So I download the client from battle.net.... Same exact issue. The installer / launcher will not show up and shows itself in processes just close yet again.

Any fixes or solutions to this? I've tried system restore, updates, driver updates, 3 virus scans from AVG, Norton, and a Lavasoft product with nothing found. Please help.
I am having the same exact symptoms.

I have the game installed to my f: partition, and the Blizzard launcher on my c: partition.

Are there any diagnostic to run to send?
I honestly have no idea :( I tried deleting my my battle.net folder in the program data folder and ran it again.. I got 1 step further but all it did was reinstall the folder I removed and I'm back at square one, lol.
I too have been having Launcher issues. The issues have been apparent since I initially purchased and downloaded the game on May 15th. However, since June 6th I have been unable to play Diablo at all due to the current Launcher issues. I have spent 12 hours now in the past 3 days, doing every known and reported fix. I have a ticket that has a total of 4 responses from Blizzard during that 3 day timeframe. The first response me to check the support page... (I absolutely could not believe that response... like I wouldn't check the support page before filing a ticket!?) And, moments ago I just ended my phone call which was equally absurd. When I called the automated system advised the wait time for a representative was 8 minutes. Well, I held the line for 2 hours with no response.

I love Blizzard to death, and they have been my favorite gaming company since I began playing the original Warcraft in 1995. But, I have to say that this is some of the worst service I have ever experienced. (The second advisor was somewhat helpful, however I am now anxiously awaiting a response) It's not to say that the advisors are the issue, however the system in place for the technical support needs is substantially flawed for several diffferent reasons that I have noticed so far.
I'm glad I'm not the only person with this issue and I hope they find a fix for it soon. It's not on our end *it is* on theirs. It has to do with the battle.net folder and it's updates contained within. Because if you delete it it will get to the point where it installs the battle.net updates but still won't start the launcher to reinstall or start the game.

*edited.... typo*
Yes, I completely agree. However, I unfortunately am unable to uninstall the Battle.net folder. It says that I do not have the permission to do so, even though I am operating as an administrator. Also, I just uninstalled the game and it showed a laundry list of issues all related to the Diablo Updater. It stated that dozens of files could not be uninstalled. And, sure enough, when I returned to ProgramData/Blizzard.net folder, it still remained, and I was still unable to delete the folder... I don't think I have made any progress in 3 days now.
I know how you feel... I've been working on this since Tuesday :( I searched the forums for 3 days but never found anyone post anything like this so I finally made a post.
Same problem here for the first time tonight.
I have a support ticket open. If I get a reply worthwhile and has some sort of solution I will post it here for everyone.
If you can get the launcher started, I was able to start the game if i ended the process Agent.exe
Again, Flagg, the Launcher / installer does not run. Thank you for your input about agent.exe. I have looked into it already but it's not the solution here. Key words you used were "If you can get the launcher started".
06/10/2012 12:15 PMPosted by Æcés
Again, Flagg, the Launcher / installer does not run. Thank you for your input about agent.exe. I have looked into it already but it's not the solution here. Key words you used were "If you can get the launcher started".

Yah man, I was gettin that issue as well, although I know you've done it all... but it might help some folks that get to this post and are having my problem. I was occasionally getting the issue with nothing starting... the process starting and then just disappearing, I reinstalled, I stopped my AVG and was able to at least get launcher going. I changed my host file up like some others had suggested in different threads, still didn't work, then I killed my agent.exe and the last time I started the game, it actually worked completely.
Flagg, your idea might work if I could actually install the game -.-
Have you attempted temporarily disabling any antivirus/antispyware software currently running prior to attempting to install?
I have a Mac and I'm experiencing the same issues so I don't think t's linked to anything running in the background program wise or antivirus/spyware. Just my .02
@Lotos: I have tried that already. Did so before I made this post. Thank you though.

@Kryssa: I am on windows, however, I have had other people around my area with the same issue on Mac and PC both.

An update. I recieved word from my open ticket. They told me to check the support section. Lovely help right? That didn't work... Though just passing info along.

I'll get back to you when I find a solution or get another reply from my reopened ticket.

Try deleting both the Blizzard and Battle.net folder in C:\ProgramData

Then start your launcher.

hope that helps.
@BTCH38: I have also tried this. I have even gone to the extent of completely uninstalling World of Warcraft, Warcraft 3, Diablo, and Diablo 2. Removed everything remotely related to blizzard, and installing D3. The launcher still won't start but the others reinstalled just fine.
I'm signing for this too, was working fine last night but now won't do anything, 2-4 secs of trying to launch then just dead.

Come on Bliz fix this already

Join the Conversation

Return to Forum