Diablo 3 Launcher won't start...

Technical Support
Prev 1 2 3 6 Next
OK have allso just found this

Blizzard Launcher and Installer

Stopped working

‎12/‎06/‎2012 21:59

Report sent

Faulting Application Path: C:\ProgramData\Battle.net\Client\Blizzard Launcher.1640\Blizzard Launcher.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: Blizzard Launcher.exe
Application Version:
Application Timestamp: 4fbfbc6f
Fault Module Name: StackHash_0a9e
Fault Module Version:
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: febf1e2f
OS Version: 6.1.7601.
Locale ID: 2057
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Extra information about the problem
Bucket ID: 3007737321

What is interesting is that it seem sto be looking at C:\ but i have diablo installed on my E:\ drive
If it does manage to come up, clicking play has no result.
@Drus: Welcome to the thread, lol. I've been at it since last Tuesday.... I've reopened my ticket twice now and am awaiting my 3rd reply. I'll keep everyone posted.
Was having the same issue last week. Brand new laptop with only diablo 3 installed and on tuesday the launcher wouldnt actually launch the game. I reinstalled diablo it still did not launch so i reformatted the computer reinstalled d3 and it ran just fine. Now today back to the same issue!

Hopefully they fix this issue quickly!
I literally just did everything in this thread before i opened it. Nothing worked what so ever. I have two computers with D3 installed on both of them, it doesn't work on either my laptop or desktop. and my desktop is new. It MUST be fixed some time soon if it has been happening since the release of the update, June 6th. I was thinking maybe I could delete the "bad update file" but I have uninstalled D3 sadly... :( I wish Blizzard would get better help for the people (almost everyone that got the update) that spent $60- $120 dollars on Diablo III.
Lol, I just want to welcome everyone to my thread. This is sadly an issue that seems to be expanding quite a bit since June 6th. And to agree with malomobster.... About spending the money on this game for this to happen. I don't see compensation coming either most likely.
Hi, i've been having the same issue every single update (4 now).

Here's some more info and link to some relevant information about it too http://us.battle.net/d3/en/forum/topic/5789979019?page=1
so frustrating no methods work for me I just cant seem to get it working keeps saying "Failed to update tools" AHHH
I found the following worked:

Delete all files out of the /update dir

end all processes (agent.exe / blizzardupdater)

run diablo III.exe - should re-download the content, but then won't work.

end process blizzardupdater

run diablo III.exe as administrator
^^ I would do that if the game would re-install... but sadly, im stuck half way through nightmare mode, and I cant play any further.
Besides, when it was installed, it would just say updating tools- o% i let it run over night. NOTHING happened.
UPDATE: I just got Diablo 3 installer to work. Hopefully the launcher works as well.

The Launcher didn't work... This is a grim moment for us all...
Finally got the thing to download today now the launcher wont start error 304
Very frustrating. I have the same issue on my macbookpro os x and i've also been in and out of tons of forums and done all you can think of on my end. but everything i have done locates to something on Blizzards side. I loved playing diablo 3 and have got really far in the game. I just ordered my authenticator a couple days before the latest patch so i could use the real money aution house and im really bummed to say the least. Please fix this blizz
Very grim indeed @malomobster
I just called Blizzard. They said the wait would be 20 minutes. I thought it would be worth it. I WAITED 2 HOURS. NO ONE ANSWERED MY CALL. I WAS ON HOLD LISTENING TO THAT !@#$TY MUSIC FOR 2 HOURS!!! I am officially pissed off. Not at Diablo III, but at Blizzard.
Same issue here. Can't start d3...
I honestly think they dont know what's wrong because it shouldn't be this hard to figure out what's not adding up in the equation. I hope that this is fixed by next tuesday restarts...
This did not work for me but I promised to relay messages from my ticket to everyone here. This is from the most recent reply I have recieved.


(Name I cannot give) from Account Services here! I first did want to apologize for the wait, as I know it can be a bit long. I appreciate the steps that you have already taken, and I do have a few more. As, there are a few things that could be causing this.

1. Run the diablo insaller.
2. Close it, and ctrl+alt+delete and end the “Agent” process.
3. Go to C/programdata/battle.net/agent and run the “Agent” executable
4. Run the diablo installer

The agent is a background application and works to ensure the connection to the game and our servers, sometimes it does want to block its own game though. Please attempt these steps, and let us know if you have any further changes. =)

This did not work for me, however I hope others have luck with it. I will keep you posted, however, if you still have issues. I have reopened my ticket once again.
@malomobster: How did you manage to get the installer to work? I may be able to work with that and possible come up with something for us.
Was having the same issues, I just downloaded the digital client off of battle.net. Prompted for install and it did a mini game install after I selected "I've already activated my key" then prompted the play button. Good Luck !

Join the Conversation

Return to Forum