Diablo 3 Launcher won't start...

Technical Support
Prev 1 4 5 6
I just got the installer to work.

I'm on a mac this is what I did:

1st: I restarted my computer and opened up nothing else except the D3 updater.
2nd: When it prompted me to enter my admin password I clicked cancel.
3rd: I waited about 30 seconds and it started the patch download it's only around 20MB so it
didn't take long to dl.

Once it installed I was up and running and playing the game. Good luck and I hope this helps for those that don't want to uninstall and reinstall.


Thanks this worked great for me.
Weather Man, this worked for me aswell.
Just cliked cancel when it asked for my admin password and the initializer started normally, showing 100% download and ready to play.

thanks!
Haven"t been able to play Diablo for weeks. Not much information on what to do to launch. Any sites recommended to information. Can I get my money back. Noticed the stock is dropping over the past couple of months.
hi guys i having trubbel with this new patch.
only updating setup files ands witch to blizzard....
takes ears to download can i fix this? pm pls
Ok. Spent a solid 5-6 hours trying to figure this thing out. Not sure if this will help anyone or not but it worked for me.
I had been able to play (semi)perfectly since launch. It wasn't until I tried to make more room on my SSD that I had any problems. I followed a video I watched online (http://www.youtube.com/watch?v=eH28VTqD82c) regarding freeing up space and that bit worked just fine.
Then the troubles began. Steam, D3, WoW, and any other game I wanted to play just wouldn't work. I had a different problem for everything and any time I thought I got somewhere it would make up a new problem. I was going in circles.
So after hours of assuming I had done everything right, I thought maybe I dun goofed.
I retraced my steps and when I had altered the TEMP/TMP, I had entered it wrong (see video, towards 2:00).
I entered D;/TEMP and D;/TMP...bad move. It should have been D:/TEMP and D:/TMP
: not ; ...see the difference?
Once I corrected this everything seems to have fixed itself. WoW works. Steam launched, and most importantly, D3 started and is steadily downloading itself. (Healthy 5% right now)
So maybe you have an SSD and/or did something along the lines that I did, if so hope this helps you out.
Try changing your UAC (User account control) settings
You can also make sure that your Secondary logon Service is enabled

"Verify that the Secondary Logon Service is Enabled

The Secondary Logon service must be enabled for Diablo III to install and run. Depending on your version of Windows, you should be able to navigate to this service with one of the following methods:
Start > Control Panel > Administrative Tools > Services
Start > Control Panel > System and Security > Administrative Tools > Services
If the service is disabled in your Windows, please change it to Automatic. Be advised that some security programs (such as AVG) can potentially be turning this service off. If the service becomes disabled again after you've switched it to automatic, you will need to configure your security program to stop disabling the service."

http://us.battle.net/support/en/article/diablo-iii-installation-troubleshooting-pc
When I try to open Diablo III.
I'll get this error:
The program couldn't start correctly (0xc000005)
All the time I try to open I'll get this error.

NOW the game will not even start.. Fück
Got a mac...

Won't launch...

Off it!!!!
you MUST use archive utility to export it. I tried using a few third party unzipping programs, it started working after i used Archive Utility.
could be a google dns problem.
ce I corrected this everything seems to have fixed itself. WoW works. Steam launched, and most importantly, D3 started and is steadily downloading itself. (Healthy 5% right now)
So maybe you have an SSD and/or did something along the lines that I did, if so hope this helps


SSD TEMP DELETION!!!! OMG YOUR AWESOME!!!!

-I didnt edit my temp folders but did delete some temp so this narrowed down my no launcher problem i tried everything else in this forum and this one caught my eye as i ran outa space on my SSD.
After changing my temp locations to my d: off your video not only saved me space

FIXED DIABLO noLAUNCHER!!! user error totally not blizzards fault
I installed d3 and everything but when it goes to launch the d3 icon shows up in the middle of my screen then dissappears and then nothing. When I tried to launch it again it said that d3 was already running. yet nothing is open or anything. i looked at my Processes and it says "Diablo III.exe". I honestly have tried alot but still cant get it to work, can someone help me.
On windows XP sp3 myself, just purchased this game the other day and when I first put in the disc it loaded the launcher screen and just hung there for awhile. Restarted pc got everything installed, game played. Exit game, go to log in again and once again the launcher screen loads and hangs. Unless I restart my pc this launcher won't load, I've changed privileges and deactivated my anti-virus but nothing works unless I restart the pc, every time. Anyone know what might be preventing this besides anti-virus and Secondary login privileges?
After last patch I hit launch and it crashes. Diablo 3 retail has stopped working
I experience the same problem. The gamestarts up and there is a black screen for 5 seconds and then it pops down, and can't open.
i was having same problem i had to disable my anti virus before it would load me into battle.net

Join the Conversation

Return to Forum