Diablo 3 Freezes Computer (Only Recently)

Technical Support
Prev 1 9 10 11
Dont know if you sorted your problem out but see my solution below that worked for me.

Found on my router under the lan SERVERS list a weird server named DEMONWARE and deleted this due to me not reconizing this. Now the game works fine. My question is what was this server diong on my router list, i never put this there. Could a hacker get this on the router or was this installed by the last patches installed by Diablo. In any case the game is working
Nothing to do with anything, keep playing and it will freeze again eventually. What you mentioned is probably just a neighbors router signal you're getting. The thing is I've had it happen 2 mins after starting a game, and several other times where I've gotten to play maybe at max an hour.

Display()
Operating System: Windows Vista (TM) Home Premium, 64-bit (Service Pack 2)
DirectX version: 11.0
GPU processor: GeForce GTS 240
Driver version: 306.97
DirectX support: 10
CUDA Cores: 112
Core clock: 675 MHz
Shader clock: 1620 MHz
Memory data rate: 2200 MHz
Memory interface: 256-bit
Total available graphics memory: 3838 MB
Dedicated video memory: 1024 MB GDDR3
System video memory: 0 MB
Shared system memory: 2814 MB
Video BIOS version: 62.92.93.00.08
IRQ: 16
Bus: PCI Express x8
GPU processor: GeForce GTS 240
Driver version: 306.97
DirectX support: 10
CUDA Cores: 112
Core clock: 675 MHz
Shader clock: 1620 MHz
Memory data rate: 2200 MHz
Memory interface: 256-bit
Total available graphics memory: 3838 MB
Dedicated video memory: 1024 MB GDDR3
System video memory: 0 MB
Shared system memory: 2814 MB
Video BIOS version: 62.92.93.00.08
IRQ: 16
Bus: PCI Express x8

I'm using a BenQ xt2420t monitor also at 120hz, maybe 120hz is the problem any correlation? Are you guys experiencing this also running monitors at 120hz?
Nearly everyone in this thread who has had issues described a similar problem I'm having. The weird sound looping, complete hard lock, etc. On one occasion I noticed a brief screen tearing right before a freeze which made me assume this is a graphics issue. I double-checked my drivers and it appears to be fine. Sometimes it occurs even before logging in. And it has only started recently for me as well.

I am about to install another performance hog game and see what happens.
Logged in this morning before work and everything ran as normal. Was going to log back in after work to check AH and I can't even get in the game. When I press 'PLAY' on the download page my computer freeze once the Diablo face appears and I have to hard restart.
My screen froze yesterday for the first time. I played for a long time and this was the first time it happened to me. Today again. Just once though, but this isn't supposed to happen!
Since the patch I have had a few complete game lock-ups. It doesn't lock up my entire computer, but the game locks up and Windows forces me to close the program. I don't know what's going on, but since the patch I've had the lock-up problem and severe FPS drops to the point of complete hang-up for 5+ seconds while framing Act 3.
This is happenening to me too. WHYYYYYY. I don't want to ruin my laptop by keep pressing power button to force restart my laptop. Blizzard please fix this :(
i tried all options that admins suggested but i cant play i can sit on ah but cant enter the game freezing sound looping i was playing before patch i just turned back to game after 2 months but there is no game for me i guess :)
This has also started happening to me since the latest server maintenance last week...
This happens to me at least once everytime I play started happening about a month ago and I've been playing since launch.
Within the sound options put it to low, I had tried playing on medium/high and had sever sound/lag issues. I didn't read the whole thread.
Hi all, not sure if this would help anyone , but it may.

I encountered another 'hang-up', but this time, I managed to recover and went on with the play game without any problem.

Upon exit and back to desktop, I discovered Windows 7 desktop composition has been disabled. On the assumption that it may stop the hang-ups, I tried running D3 in compatibility mode with desktop composition and visual themes disabled.

Upon logging in, I tried to go through the AH to see if I will encounter another hangup, but so far so good.
im acctually having the same problem 2 right now. i messed around with it and did a bunch of things that never ended up working but. i heard from a couple of friends that they called tech support and they upgraded the bios of their computer and it worked for them. i acctually didnt do that and i just kept logging on and trying to play and eventually it worked all night long but now today its doing the same thing so im wondering if its just traffic

Please be mindful of a thread's original posting date when replying. We want to avoid resurrecting old threads. Thanks!

- Forum moderation team
07/01/2013 10:19 AMPosted by MasterPwN
im acctually having the same problem 2 right now. i messed around with it and did a bunch of things that never ended up working but. i heard from a couple of friends that they called tech support and they upgraded the bios of their computer and it worked for them. i acctually didnt do that and i just kept logging on and trying to play and eventually it worked all night long but now today its doing the same thing so im wondering if its just traffic


really if you are having a game freeze issue, or any other issue in particular for that matter, you need to start your own thread rather then resurrecting a year old thread. there have just been way too many changes since this thread was opened. its quite possible you can get help for your issue if you detail the problems you are having in your own thread. at the very least someone will try to help you.. and thats something.

Join the Conversation

Return to Forum