"patch required" message on attempted log in

Technical Support
The Problem:

The Americas server launched an update few minutes ago (1.0.2a), servers in Europe dont have this update yet, in other words you are not going to be able to connect to the Americas Server, i think they will perform this update in Europe tonight and they will finish at 4am GMT.

I already tried adding the update file into my updates folder in diablo3 and it did not work, so there is no workaround. The only thing we can do is wait until tomorrow.
I know guys who are playing right now on the americas server..
The Problem:

The Americas server launched an update few minutes ago (1.0.2a), servers in Europe dont have this update yet, in other words you are not going to be able to connect to the Americas Server, i think they will perform this update in Europe tonight and they will finish at 4am GMT.

I already tried adding the update file into my updates folder in diablo3 and it did not work, so there is no workaround. The only thing we can do is wait until tomorrow.


This seems to be it for me. Somehow my settings were set to English (EU) instead of English (US) and this meant I had the wrong version of the game client trying to run. Now reinstalling the correct version because it will probably take slightly less time than waiting for the patch to go live in Europe. o"o
Do you have to reinstall the game to change this option ?
I switched to the european server but I got stuck on "retrieving hero list".
bump
Once again same problem, I had to wait a whole day due to the last maintenance because of this fking problem.
Hopefully blizzard can take action and fix this stupid bug that shouldnt be there in the first place and not just this one time but for following patches as well
It doesn't seem to be a problem with which version you installed. I have the same installer (the GB one or aka EU one) on two computers. The patch downloaded for 1 computer without a problem and not on the other one.
WooT! I got the fix. I put it in this thread http://us.battle.net/d3/en/forum/topic/5573700590?page=2#34
Same here. My OS is Windows 7 and my server is Americas.
what the hell is this, i already payed D3, and i demand to play whenever y want, if you are going to patch do it well, fast, and let me know more clear how long is it going to take. And i know that the game is working, becouse my friend is playing on his house right now. So FIX ME THIS BUG
Yep happening to me too. The launcher says game is up to date, when i log in it says "A new patch for Diablo III is available. The game will now close and apply the patch automatically." When you press OK, you will get a crash window and another message saying "Diablo III is already running"
I had this problem just today, stuck in a loop that told me I needed a patch, but the launcher told me the game was up to date.

After much searching I found the solution, even though it is from 2 days ago, it still worked.

Hope this helps :

http://us.battle.net/d3/en/forum/topic/5152415037?page=1

Join the Conversation

Return to Forum