Crazy D3-related computer crashes are afoot

Technical Support
The initial problem started about a day or two after purchasing the game. Initially, I got a freeze in-game. It would turn my screen black for a couple seconds, then stutter, then resume play. After about 4 days of this my display driver start completely crashing without recovering. Upon restarting I get error reports saying there was a BSOD, but I've never actually seen the BSOD itself. When the crash occurs the colors on my screen blur, with whatever was on the screen frozen in place, opposite, inverted or otherwise weird colors. Occasionally, the screen just stays solid black. Occasionally a sound loop comes with the crash, sometimes there's no sound at all.

This occurs at extremely random times, but usually within 5 minutes of starting Diablo 3. Occasionally I get the crashes when I'm not even doing anything but opening my web browser. I have NEVER even once, had an issue with my graphics card before Diablo 3. I have tried [literally] everything on the Diablo III Lockups and Crash Troubleshooting guide and Diablo III Video Performance Issues Guide, and the crashes persist. I have tried reformatting my hard drives, rolling back drivers (and of course updating to the most recent), re-installing, resetting to factory defaults on hardware, flashing my bios... The list goes on; nothing works. Sometimes, I'm able to play the game without ever having a problem for hours (this is quite rare, usually just once every 2-3 days), and the next day, without changing any settings, I start up Diablo 3 and the computer crashes again. The issue is absolutely NOT heat related, in fact I have a photo of the game in windowed mode with a hardware monitor in the background that says the GPU sensor is at 60c while playing.

I have been troubleshooting for about 5-6 days now, and nothing has helped yet, besides taking out the graphics card. I submitted a ticket on 5/30 and it hasn't been responded too yet, which is interesting considering I had another ticket submitted 30 minutes post on an unrelated topic that was answered yesterday. Thanks for any help.

Hardware is as follows:
AMD Athlon 7750 Black Edition
MI-A78S-8209 Motherboard (XFX GeForce 8200 Chipset)
8gb of OCZ DDR2 6400 400Mhz RAM
BFG Tech NVIDIA GeForce GTX 280

Running Windows 7 Ultimate 64-bit

Edit: I should add that I have never had a hardware problem since I built this computer about 3 years ago, nor a problem with this graphics card in 2 years.
bmpity bmp
bump
Picture of said failure:

http://i.imgur.com/dg1Xc.jpg
It's not overheating, I'm 95% sure of that. It doesn't even have time to overheat most of the time, as straight from start up I turn on hwmonitor and then d3, with the crash usually happening before I even get to the log-in screen. The only way an overheat could be related, from what I can tell, is if the first time the BSOD happened it permanently destroyed my card. Every time since that first full crash, I've been running hwmonitor with normal temperatures.

I have tried to take out the card and use my onboard GPU (nvidia 8200) and it doesn't crash.
If that is the case though, why does it work sometimes? The only other time I had a card go bad due to overheating, it flat out would not work. This card still seems to run; it plays SC2 fine.
If you have disabled Vertical Sync and also turned off max foreground FPS while running the game on high settings, it's going to be pulling near-100% usage from your GPU which can cause temps to skyrocket. My GTX 680 was pushing out 260 FPS at all high settings in D3 and also overheating to 80°C +/- 2. Obviously that high of FPS is completely unnecessary, but it's the reason why the GPU was under such heavy load.

While I have since ruled out my own hard system locks being caused by GPU overheating, I did turn on Vsync to limit this problem. There's no reason a game like this should be requiring 100% pull from the GPU at any point.
Yea I have always played with clutter off, shadows off, and 50fps cap. Any time I have messed with the video settings I make sure to track my heat. Even in what seems like an offchance that my card overheated, it is more than capable of running this game on high graphics, barring the excessive settings that are possible.
I am sorry to say this, But I had the exact same problem 2 months ago. Looked exactly the same and I tried evrything. I eventually had to change my graphic card. This is a known problem to the nvidia graphic cards, which is a shame since I'm abit poor ^.^
I played today and every 5-10 minutes or so, my screen would flicker the same types of discoloration from that picture but it recovered every time.
I have exactly the same problem.
I can sit on the AH for hours and sometimes even stand in the city.
but every time I try to go out of the town killing monsters I get a black screen with sound loop.
I can play WoW without any problems what so ever but when I enter diablo I get the black screen.
I have the exact same problem. Tonight I even got blue screen of death. Usually I get stutter, sound loop, black screen then game resumes. I have looked on the forums and tried things suggested in technical support. I have tried installing new drivers, lowering graphic settings, driver sweeper. The problem seems to be getting worse/more frequent. Usually the problem is associated with a "atikmdag has stopped responding..." or something like that. I have crossfire Radeon HD 3870, it's a 3 year old comp. so that might be it. However, my computer does exceed the minimum system requirements for diablo 3 and sc2 (I get similar symptoms when I play both).
Same problem here, my screen goes pink and crashes out. One time I happened after I logged out of D3 and was doing something else, but every other crash was D3.

I'm running the NVidia GTX280. I've got a program on monitoring my heat, and one of the times after I returned to WINDOWS it told me I had a BSOD.

EDIT: Not just same graphics card as OP also WIN7 64 bit. But I've got an I7 and an ASUS Motherboard
I am having the same exact problem. I can play any kind of game perfectly fine. Star Craft 2 Absolutly perfect runs great. thats probly the only game i have that can really work my computer and still nothing. I try to run this game and boom computer crashes. I just bought this game at about 5:30 Central time started playing 15 minutes later after it was done installing. I played dor 2 minutes and my computer crashed. Thought nothing of it went back to playing. 10 seconds later it crashed. So i stopped playing. I went to play other games such as garrysmod, left 4 dead 2, and i even played Star Craft 2. Absolutly no problem. There is no way anyones video cards are going at this point.
Having this issue too. pretty much all my other games, no matter the graphical load, run just fine. D3 fluctuates between nrunning just fine and causing my computer to randomly crash out in this exact same manner.
Honestly this is quite sad. I paid 60 Dollars to play this game i should be able to. If its something with the hardware in the games it should be fixed immideatly. 60 dollars is a lot for me at this given time and im wishing i could just take the game back and get my money. Someone needs to fix this
I've tried many things as well, running GTX580 SLI, temps never exceed 68 degrees Celsius. I have a x79 chipset board, newest drivers. Tried turning off Link State Power Settings under power options for PCI Express Power Options. Hope Blizzard patches this.
06/10/2012 02:48 PMPosted by Faxanadu
I've tried many things as well, running GTX580 SLI, temps never exceed 68 degrees Celsius. I have a x79 chipset board, newest drivers. Tried turning off Link State Power Settings under power options for PCI Express Power Options. Hope Blizzard patches this.


Faxanadu,

I too have a x79 chipset board (gigabyte) and I was having random computer freezes while playing Diablo from 2 hours in too 5 seconds, I tried all workarounds on the forums and some other test on my own. Eventually I got my last option, check the BIOS version, and my version for the chipset was 3 version old and the version I had came out in January 2012, so I updated that and the damn thing runs smoother in everything and no more crashes in diablo! Something you might want to look into!

Join the Conversation

Return to Forum