Diablo III and 2012 MacBook Pro Retina Displays

Mac Technical Support
First time posting here. I just received my rMBP yesterday and after watching WWDC decided to buy D3 after seeing it there. Now I'm not usually a RTS/RPG gamer but I must say I'm loving it already.
I do however have a graphical issue when switching from native res to anything else. But this could be down to other issues which I can't really go into at this time.
Any update? Its been quite a while and could any Blizzard Employee share if there is any work done?
Hello all, yesterday i was playing diablo 3 to consume my battery for charging cycle process. I was getting 20 fps at max res and details (medium shadows). When my battery was down %10, nvidia card replaced itself with 4000 (for power saving)and game become awfull as i expected (fps was awfull).

However when i fully charged my macbook pro retina and tried diablo 3, guess what? Game was still awfull and i m sure that i m using the nvidia card(downloaded the app the tracks gpu)
I tried everthing but now only resolution i can play the game with high fps is 1440's. What the hell happened guys? Did i damaged the gpu pr something? I also tried warcraft, i m getting around 15 fps at 2880, but game really slows at bgs . So i preffer 1900's for better performance 20fps in bgs 30 fps in normal areas. Should i replace my macbook pro retina?:(

Please help
Should i replace my macbook pro retina?

No. Just send it to me - I could use a second one.

Seriously though, this happened to me a few weeks ago. My theory is that you overwrote D3's default card class setting when you launched the game with the integrated card (4000).

I encourage you to download and install gfxCardstatus. It can be found here: http://codykrieger.com/gfxCardStatus

You can use gfxCardstatus to force your rMBP to use the 650m when you launch D3, which will reset the card class setting. You will have to reset your graphics settings to where you want them because it will not remember what you had when you last played it with the 650m.

The app is awesome for general use as well - it will save you a ton of battery life. Check out what arstechnica had to say on it: http://arstechnica.com/apple/2012/07/retina-macbook-pro-maximizing-battery-life-with-gfxcardstatus/

I think this will fix your problem.
I have gfxcardstatus aswell, but it doesnt seem to solve my problem. I tried to start d3 with nvidia card by choosing it from the gfxcardstatus and nothing changed:( still got the low fps problem. Another interesting thing is, when i start d3 with hd4000 or nvidia card (by choosing from gfxcardstatus) there is difference at all, can it be possible? Maybe i should reinstall nvidias driver again? Is it possible?

Hmmm ...

A couple of ideas from this forum (SMC/PRAM/D3 cache):

If those don't work, open a support ticket or start a new thread to draw the attention of the Mac team here on the forums. Please let us know what happens in case others run into this issue.

Good luck!
any updates coming to boost fps at 2880? :) would be nice..
I wouldn't expect any big improvement on this side since at that resolution we are limited by the GPU.
I had a similar issue to Soilworx above. I'm running a Macbook Pro Retina (2.7Ghz i7, 16Gig Ram, 756gig SSD) and normally i'm playing D3 at max resolution with all settings on high apart from shadows which is medium, all in all i've found the gameplay to be perfectly fine, however on this particular occasion i was just about to confront Ghom in normal difficulty on my HC Monk when i started to get a severe loss in FPS to the point it was unplayable. Luckily enough i was able to exit D3 unscathed but realised i must have knocked the mag safe power adapter loose and was running on reserve power (i.e. it had switched to the Intel HD4000 card).

Thinking it was a simple fix of plug it back in and reboot i loaded D3 to find i still found the gameplay unplayable and could only just getting it running by minimising every setting possible and reducing the resolution. I thought i'd damaged the graphics card.

Thankfully i saw mimefrogs link above and followed the steps for resetting SMC/PRAM and rebuilding the diablo cache, after i did all three things it was back to normal and running perfectly again. Kudos to you mimefrog!

Hope this helps anyone else experiencing similar issues.
In today's 1.0.4 patch notes you state that "Retina displays are now fully supported". What exactly does that mean?
Retina support means the game will fully render at 2880 x 1800 and scale properly.
08/21/2012 04:12 PMPosted by Machkhan
Retina support means the game will fully render at 2880 x 1800 and scale properly.

Something is wrong with this patch.
First the resolution is wrong, now you can choose 2950*1840, 3360*2100 and so on.
When I run the game in 3360*2100 (wich is 2800*1800 I think) the fps is around 15-20. Before the patch it was 30+ at al the time.

Fix it please...
Something is wrong with this patch.
First the resolution is wrong, now you can choose 2950*1840, 3360*2100 and so on.
When I run the game in 3360*2100 (wich is 2800*1800 I think) the fps is around 15-20. Before the patch it was 30+ at al the time.

Fix it please...

Don't select the more space option for your retina display. This will cause this bug to appear.
So you're basically saying we can't set our resolution to our liking in order to play the game well?

I'll have to echo what JokerM6 said ... before patch 1.04, I was able to run D3 on my Retina Macbook Pro with really great FPS at full 2880 x 1800 resolution ... now with this "retina update", the game is much choppier. What happened?!
The same happened to me, I can play high physics, high texture and high clutter(and everything else either lowest/turn off) and I can play without lag AT ALL. Now, being in town walking around seems laggy to begin with, seriously some optimisation need to be done.
You either fix it or revert to how retina previously works, please don't make things worse in an update.
Yeah, I have the highest pimped out "Build To Order" Retina Macbook Pro. The game was running excellent before 1.0.4. Even to the point that I was shocked at how good it looked... The effects even visually improved compared to highest settings on my last 2009 Macbook. The FPS were running without any noticeable frame drops. I can't say it enough, it ran soooo well.

After the 1.0.4 patch it is running horrible. As slow as it was on my old Macbook. Areas that were bad back on my old computer (Oasis, Act 1, Spider Cave) are sooooooooo slow. Practically unplayable. What happened? The game was awesome on my Retina and now it's playing like my 2009 Macbook??? What's the deal? I wouldn't say it's internet speed laggy, but graphics FPS speed reduction. Surely, I'm not the only one that is having this problem. Something changed for the worse. Please address my issue Blizzard Blue Text. Other than that, I like the other 1.0.4 changes (except the no visual Allie PowerBoost Effect Icons missing in the top left. Like Allie healing, allie protection. Don't know if my effect is activated now. But that's a seperate thread post)

Please fix my Retina Display drop in FPS. It was working great before the 1.0.4 patch.
Sublucent, were you playing the game in a window or fullscreen windowed before the patch?
Kaysin, S4d1k is a Mac Developer... And look who responded... Hehehe. And I mean no disrespect to you or S4d1k. Just want to play my $60 and +$3500 Retina that I specifically upgraded for this game. I know, pricey but shows how much of a fan I am of this game. That's why I was disappointed in such a FPS drop after the patch.

S4d1k: I was playing in Fullscreen mode (no Apple white bar up top). I haven't changed any of the settings after the patch. You know what, let me double check my settings and get back to you. In the mean time, what recommended settings should I do to get maximum graphics (I'm a video game artist hehe) while having little game play Frame drops? Thanks for responding. :)

Join the Conversation

Return to Forum