Cannot validate core files!

Technical Support
Everytime I stacked 5x NV the games crashes with cannot validate core files and I'm returned to windows.
If I don't hurry to close Diablo on the Job list afterwards my computer freezes and need a reboot.

I think I've been really patient the last couple of weeks, trying to hold my frustration back a little. But now I'm about to explode.

Please Blizzard fix this game already!
Bump
you have to do something about this crash already blizzard! what are you waiting for? more players to abandon your game?
Excidium,

It happens when your game files are corrupted. Sometimes you can see which file it is by examining the D3Debug.txt file and then deleting it so the game can re-acquire it, but reinstalling is usually the best way to resolve it.
Thank you. Been there, done that. How can I stop my game files from becoming corrupt? (assuming i am pretty much spyware free)
Excidium,

I've no idea what would be corrupting them for you if it's happening on an on-going basis. It's never happened to me on any of the systems I use to play on.

It seems to usually be related to a patch not being applied correctly through no fault of your own. I wouldn't attribute it to spyware. For now, as I said, reinstalling is the easiest way to resolve it. We can dig deeper and find where the corruption lies and delete the affected file, but that method has undesirable side effects.
Just had this occur to me for the nth time as well.

It's always an issue with the same file for me, the 12840.mpq.

I've already deleted that file once and reapplied the patch, but I'm still getting the same error, in various Acts (mainly Act 3, but Act 1/2 sometimes as well).

The extract from my D3debug.txt:

2012.11.10 10:46:35.531555000 Initializing client world trDun_Leoric_Level03...
2012.11.10 10:46:35.533408800 Disposing UI for World
2012.11.10 10:46:35.800302800 ERROR: Failed to validate file (Appearance\a1dun_Leor_NSE_01.app). Details:
334E748253A8F3472878D18B75E80CEE 9842104 1
Data_D3\PC\MPQs\Cache\base\patch-base-12480.mpq

2012.11.10 10:46:35.800627500 ERROR: [Data Validation Failure] Diablo III was unable to validate core data files.
2012.11.10 10:46:35.958414700 de activate app 0 iconic 0
2012.11.10 10:46:52.842840100 TestCoopLevel - D3DERR_DEVICELOST
2012.11.10 10:46:52.843995600 de activate app 1 iconic 1
2012.11.10 10:46:52.849516400 ACTIVATE APP 1 iconic 0
2012.11.10 10:46:52.890773900 TestCoopLevel - D3DERR_DEVICENOTRESET
2012.11.10 10:46:52.945947600 Reset() Attempt started - soft reset!
2012.11.10 10:46:54.078977800 Est. Available Texture Memory = 1523 MB
2012.11.10 10:46:54.079510800 DeviceReset() succeeded!
2012.11.10 10:46:54.080425100 Setting depth texture, fmt = 36
2012.11.10 10:46:54.080776600 PostFXGfxInit() success
2012.11.10 10:46:54.081315800 SubObjectGfxInit() 1
2012.11.10 10:46:55.607842800 TestCoopLevel - S_OK
2012.11.10 10:48:50.155671900 Disposing UI for World
2012.11.10 10:49:52.168326800 Disposing UI for World
Zenith,

Have you tried reinstalling the game?
Not yet, I would only do it as a last resort. Let me try that.

Never had any issues before 1.05, but started getting this around a week ago.

Thanks for the quick reply btw.
reinstalling worked again for third time. will see if stable after patch. might have to do it again in future if they keep patching. -_-

Join the Conversation

Return to Forum