A new patch is available - Workaround

Technical Support
Prev 1 15 16 17 26 Next
thnx for the help.....
eh too lazy to look ^^
Do you have a solution for Mac users? I'm currently running Snow Leopard. Had no problems with previous patches, but this one is doing the exact thing you described - saying the game is up to date, but when I try to log in, it tells me I need a patch and just exits the game.

I'm now on version

My game is based off the US client I think, but I'm playing from Asia (Indonesia). When I play on bnet, I'm always on the US servers.

Please help! I haven't been able to play since yesterday!

same problem here... THE GIANT WILL BE KILL BY THE LITTLE ANT !!!
so i tryed this changed my setting to show hidden files/ folders and im still not seeing any battle.net folder
07/10/2012 08:02 PMPosted by NGenius
any body? do i replace the .exe with the newly downloaded one? i think thats the only problem im having now

rename your old diablo 3.exe to something else

stick in the unzipped diablo 3.exe in there after that

load launcher
07/10/2012 08:06 PMPosted by Deadlokk
so i tryed this changed my setting to show hidden files/ folders and im still not seeing any battle.net folder

do not worry about this battle.net folder if its not there, I had the same problem because I re-installed the game, it is usually located in C:\ProgramData\

instead please try my hybrid method on page 13 onwards

if you do not wish to re-install, just proceed to step 2 onwards

hay could you put something out for macs cause this is happening on my mac and all the help on this page is for pc

This worked perfectly :D TYVM
To my fellow Mac users who are suffering, I found a solution on another thread.

1. Open the TextEdit application
2. Open agent.db (do it through a spotlight search)
3. Replace all en__ (whatever your region is, mine is enSG) to enUS
4. Save and close
5. Open launcher.db (through spotlight again)
6. Change it to enUS
7. Save and close, done

You'll have to download the WHOLE 2gb again, but at least it works.
hi...im using windows XP..ive accessed the C:\Document and settings\All Users\Application Data but i couldnt locate the Battle.net folder...please help
thanks man i found the folder and deleted the agent folder it worked but blizz is really disappointing me i had to go in and change stuff in my game files last time there was a patch i hope they fix this prob. its really annoying having to search the forums and take hours out of my life trying to fix a prob. with a game i payed $60 for . . . . and yes i know $60 is nothing to blizz i just expect better from them i guess
Thanks barthus!
i can't open .agent.db file with wordpad. it says its a database file and blah blah blah. none of any programs on my computer can open up the file. someone help please
1 close the game
2 delete Updates from Diablo III
3 delete Agent from C:\ProgramData\Battle.net
4 start the game, and wait for updates
5 login and sucess
I'm stuck at "Updating Blizzard Launcher (0%)" after using this fix.. any help?
Tried it step by step but it still won't work...any help?
Thank you for this solution. Worked well.
Really terrible that Blizzard hasn't acknowledged this problem at all...
Mate, you're a !@#$ing champion!

Join the Conversation

Return to Forum