Stuck at "Updating Setup Files" [Fix]

Technical Support
I recently reinstalled Diablo 3, by running the diablo 3 installing disk. It would start and soon be stuck around 60% during "Updating Setup Files". I did a google search, and found the solution. If anyone has this issue please follow one of the solution bellow:

" Fix #1

Go to Control Panel > Administrative Tools > Services

Scroll down and find “Secondary Logon”

Right Click > Properties

Change it from ‘Disabled’ to ‘Automatic’

Run your Diablo 3 setup as administrator and it should quickly go through Updating Setup Files and bring you to an install screen. Congratulations, your game now (hopefully) works! If this solved your issue, spread it around.

Fix #2

Right click on the Diablo 3 setup file you downloaded via the Blizzard Downloader

Select Properties > Compatibility > Check Run this in Compatibility Mode for… > Choose Windows XP (Service Pack 3) (Note: Does not work on Vista.)

Right Click the Icon, Run as Administrator.

Fix #3

Delete your C:\ProgramData\ folder.

Delete your C:\ProgramData\Blizzard Entertainment\ Cache folder.

Run the Downloader again, as administrator, and see if it gets past the “Updating Setup Files” window. If not, see Fix #1.

Fix #4 (Thanks Ron!)

This one worked for me: try and find the agent application in the folder (for example C:\Documents and Settings\All Users\Application Data\\Agent). Start the agent application manually and after that start Diablo III setup file in your Diablo-III-8370-enGB-Installer folder. Good luck!

Fix #4a – Clarification for Fix 4 by GarytheOak

1. Run the diablo insall thing… let it get stuck.
2. Close it, and ctrl+alt+delete and end the “Agent” process.
3. Go to C/programdata/ and run the “Agent” executable
4. Run the diablo install thing
5. WAIT! it will get stuck for a min or so and then work

Fix #5 (Thanks SCH)

NOTE: This Fix is experimental. Many are reporting success. Proceed with Fix #5 at your own risk,

“I followed all of the posted fixes and none of them were working for me. An user on the forums posted his version of the C:\ProgramData\Battle.Net folder and uploaded it. All you have to do is replace his version with your old version, and hopefully everything should work (as it did for me).” -SCH from comments

Fix #5 Additional Notes: If you get a decryption error it means you probably didn’t finish the download. Check the folder you downloaded your files into for any that say .PART as the presence of a .PART file means you haven’t finished downloading. decryption error might also indicate a corrupt download. Run the downloader in the same directly you chose originally and it should fix the files automatically and/or finish downloading. "

  • These fixes is not found by me, the original author who posted this is here (link bellow)
  • I hope this helps and Blizzard find a way to squish this bug
  • I will no longer update this thread so if any issues or concerns please address blizzard
  • Thanks :), peace.
    The issue was found also at: , but no clear solution was found.
    What I don't understand is if the game was working perfectly, and then a patch or an update was released which screwed up some systems, why we, the people who paid good money have to go and "fix" this ourselves.

    Go here download and install both files. Worked like a charm for me I was stuck at launcher 0%
    solution 1 fixed it thank bro for posting this
    Can't find a fix for me anywhere, the first fix worked, but then it wouldn't go past 0% on the installer, so I tampered with files, which set me back at square 1, and even if I delete everything and try again, nothing gets me past updating setup files again
    Blizzard is getting ridiculous. While I still have faith in the game. It still bugs the crap out of me.

    Fix# 1 fixed it for me. Thanks all!
    fiz #1 ftw, also, if you tried fix one and you hit the launcher button but it didnt launch, go to your task manager and end the process "Agent.exe*32"
    Thanks for sharing, fix #1 did the trick for me.

    Go here download and install both files. Worked like a charm for me I was stuck at launcher 0%

    this get me pass the invalid installing option, lets see..damn youblizzard, this is terrible bugging process. terrible
    option#3 worked for me, deleted those files and tried to run as admin. so far so good, its installing, ty so much!! was stuck for 3 days.
    what do you mean when you say "run as administrator'? I know this is probably a noob question but how do I know if I'm running as administrator or not?
    none of the solutions worked for me any other tips?

    Join the Conversation

    Return to Forum