New Stuttering Workaround!

Technical Support
Prev 1 6 7 8 19 Next
I would love to go to blizzards headquarters and back hand every programmer that worked on this game. By far the worst programmed game I have ever played.
I was so excited when i saw this fix, alas it didn't work.
This is crippling my ability to progress through inferno and my DH is stuck on Diablo in hell.
I think I am just going to stop playing until more of these bugs are cleared up, loving this game a lot but it is really starting to wear on me when my game play is limited in such a way.
After suffering various stuttering issues for weeks I recently gave up actually trying to play Diablo and started a massive troubleshoot guess and check hunt for a solution. For my situation I have found my own solution and wish to share as stuttering is a huge issue for many.

Current In Game Settings
----------------------------------

screen res - 1920x1080 Text Quality- High
V Sync- Enabled Shadow Quality- High
Max For FPS- Dissabled Physics- High
Mas Back FPS- Disabled Clutter- High
Anti-A- Enabled
Low FX- Enabled

D3Prefs
--------------------------------
Ok this is a file D3 uses to quick save ur settings and other small info, to accsess the file (in windows 7) go to [ Start] [Documents] open [D3Prefs] it should open in Notepad if not make it with right click open with then select it.

I will copy and paste my 'values' however there are only 4 settings that seem to make an effect
-----------------------------
PreferencesVersion "43"
PlayedCutscene0 "15"
PlayedCutscene1 "15"
PlayedCutscene2 "23"
PlayedCutscene3 "143"
DisplayModeFlags "0"
DisplayModeWindowMode "0"
DisplayModeWinLeft "320"
DisplayModeWinTop "180"
DisplayModeWinWidth "1280"
DisplayModeWinHeight "720"
DisplayModeUIOptWidth "1920"
DisplayModeUIOptHeight "1080"
DisplayModeWidth "1920"
DisplayModeHeight "1080"
DisplayModeRefreshRate "60"
DisplayModeBitDepth "32"
Gamma "1.500000"
MipOffset "0"
ShadowQuality "3"
PhysicsQuality "1"
ClutterQuality "3"
Vsync "1"
Letterbox "0"
Antialiasing "1"
LowFX "1"
LimitForegroundFPS "0"
MaxForegroundFPS "0"
LimitBackgroundFPS "0"
MaxBackgroundFPS "0"
DisableTrilinearFiltering "0"
ColorCorrection "1"
MipBias "0.000000"
ReflectionQuality "0"
TonemapExposure "1.900000"
TonemapContrast "1.500000"
TonemapSaturation "1.000000"
TonemapGain "1.000000"
HardwareClass "1" <-- leave your setting, mine was at 4 originality if you have to change[/u] it[/b]
PCIVendor "4098"
PCIDevice "26808"
MasterVolume "1.000000"
EffectVolume "0.800000"
MusicVolume "0.800000"
NarrationVolume "0.800000"
AmbientVolume "0.800000"
ChannelsToUse "32"
ReverseSpeakers "0"
QuestSubtitlesEnabled "0"
CinematicsSubtitlesEnabled "0"
EchoQuestDialogToChat "1"
MuteSound "0"
MuteEffects "0"
MuteAmbient "0"
MuteVoice "0"
MuteMusic "0"

What I changed

These 4 settings seem to be the problem for my situation
LimitForegroundFPS "0"
MaxForegroundFPS "0" <----------- These particularly
LimitBackgroundFPS "0"
MaxBackgroundFPS "0"<------------These particularly

Basically If you try to set the MaxBackground FPS and MaxForeground FPS sliders to 0 in game you cant, for good reason I suppose but in the D3Prefs file you can. SET THEM TO 0
Save the changes in notepad
If you were to start D3 it would remove your changes and go back to the previous settings, WE DONT WANT THIS
to stop D3 from doing it what you do is right click on D3Prefs (the file you just opened) go to properties, once in properties go to attributes and check Read-Only then exit

Thats it, Worked BEAUTIFUL for me I thought i had the hard drive lag problem but none of the fixes worked. I tried some Nvidia D3 micro stutter solutions and they also didnt work, Slaped in my radeon 5770 still had stuttering. Went on a witch hunt for days changing one setting at a time and diff combo settings and this worked immediately Good LUCK!!!

And remember if it doesn't work for you don't give up keep trying, It worked for me if this helps even one person i will be happy because it went from unplayable to very enjoyable.
This hasn't worked for me
sorry its not working out for you, to recap the only changes should have been set MaxForegroundFPS "0" and MaxBackgroundFPS "0" save it and make the file read only also make sure limiting them in game is disabled, but if that's what you did and it didn't work it doesn't surprise me, maybe when this beta is worked out it will smooth some things out ; )

Also these are my In game settings in my Op they came out kind of messy

screen res - 1920x1080 Text Quality- High
V Sync- Enabled
Shadow Quality- High
Max For FPS- Disabled
Physics- High
Mas Back FPS- Disabled
Clutter- High
Anti-A- Enabled
Low FX- Enabled
I tried this and it worked, so I thought.

I then found 2 different installations of the game. Removed the false copy. Then copied the other old directory from C:\windows\program files (x86) to a new folder named c:\Diablo 3\.

The reason for the duplicate was when I was downloading the client the power went out and I forgot which destination I chose.

Then I re-applied the above work around and I only stutter a little bit. I have not done any public games yet. I used to have the screen freeze then play catch up, which is graphical lag. Hope there is a fix for rubberbanding cause that crap is getting old fast.
l2 program, i don't have to tweak my windows because you have non-ability to create a game.
Also,lol OVERHEATING , it is ridiculous, ONLY on this game.
I play BF3 smoothly at 70 fps, and that game have graphics that blow d3 out of this planet, no overheat,no lag, no stuttering, i start d3 and my pc starts burning, lags and all other sorts of issues.
Seriously, who made this game?
play BF3 smoothly at 70 fps, and that game have graphics that blow d3 out of this planet, no overheat,no lag, no stuttering, i start d3 and my pc starts burning, lags and all other sorts of issues.
Seriously, who made this game?


When I was playing it on my GTX 285 OC edition it was overheating which caused me to think it was the card, switched to my Radeon 5770 I had laying around and it still happened, as far as the overheating not sure the temps haven't been checked and I don't care either b.c. I'm not playing much and the 5770 can run D3 max settings and save me some $$$ on the electric bill.... brutal in the summer

Anyway glad to see i'm not the only one with D3 overheating as my gtx 285 handled BF3 np
You people make me laugh when I see, "Blah Blah game runs without overheating my computer except when playing Diablo 3," not a direct quote mind you just merely an example. My computer NEVER overheats. Once a month I blow the dust out and clean every fan. Electricity (static) loves to attract dust and since I live in the high desert of Nevada I am prone to it, sadly. Keeping the dust out and NOT over-clocking make your equipment less prone to overheating. I know why some of you over clock, to me the performance gain just is not worth the hassle and time.

Now I agree that the problem may lie with Blizzards software, and I say this because I played Beta and even then it ran the same, CRAPPY. I honestly was expecting a big patch the night before the game went live. I remember when WC3 was in development the launch date was pushed out further. At that time Blizzard was known to wait till it had a polished, 99.8% bug-free game and would wait till they achieved that goal. Now we get teased and receive subpar software. I would rather have had to wait longer for a release date knowing these issues were addressed. I mean wasn't beta the testing ground for this sort of thing to fix and repair bugs or performance issues before going live. I just don't get it. Yes I have been a long time fan boy of Blizzard games and like many others (not claiming everyone) are losing faith in a great company.
Now the real question is, what the heck did you do in 1.03 it was fine before that patch. Blizz, I am hugely disappointed in your amateurish approach on this
Wow! This really helped a lot. There's still some stuttering but overall the game is more enjoyable :)
Going on months now waiting for a fix
Due to the number of suggested end user system settings changes in the technical forums that have been intended to (whether known to the suggester or not) reduce the load on your storage drive. The slow game speed most people are experiencing is due to more accesses than your storage drive can keep up with to data contained in the .MPQ files stored in the game folder on your storage drive. The way Diablo III is coded requires many on-the-fly accesses to these files, and even more in big fights. One advantage is that you don't have a loading screen. One disadvantage is that you could potentially lose performance when you need it most. Most people experiencing this problem installed Diablo III on their hard drive (HDD) which is much slower than a solid state drive (SSD) which is what (im assuming) most people not experiencing the problem installed Diablo III on.

The method if disabling Windows Indexing essentially trades speed of searches done on your storage drive for (hopefully) a bit more storage drive speed in general. The idea is that fewer reads from the search may free up time for the storage drive to do other stuff. I would like to see more information contained or linked in the OP about "what this suggested change does to your system," especially when it's in blue text and stickied. "It worked for me and my friends" is not sufficient.

Copying and linking the .MPQ files to RAM as suggested here and other places...

Hi !

If that not work, you can try this (work very well for me) :

HDD Major-Stuttering Solved
http://us.battle.net/d3/en/forum/topic/5642269402


...while a cool trick, requires more than the recommended system settings for RAM and must also be setup before playing each time the computer is rebooted due to the RAM losing its contained data upon power loss (volatile memory). While I learned some interesting tricks to do with my hardware, the bottom line is the end user shouldn't have to do it.

As a computer engineer, my suggestion for Blizzard is to acknowledge this openly and add a SSD to the list of recommended system specifications. I would also like to receive more news about what the devs are trying as far as this/any problem is concerned. Is there any thought of adding a loading screen? What changes are the devs thinking about making that affect how the game runs on my system? Please, get technical.

TLDR: My suggestion for the user is to get a SSD if you don't have one already.
Here to say:

http://us.battle.net/d3/en/forum/topic/5642269402

worked.

The blue suggestion did nothing.
Hi all,

I only read the first 4 pages, so maybe this has already been addressed, but I was running an 8800 with 600 MB and game ran perfectly. I got a 1.5GB GTX480 for birthday (damn thing needs it's own nuclear power supply) and after installing, the game was an absolute mess of jerky movement.

I looked at the graphic options (in game) and noticed the foreground FPS had defaulted to like 190 FPS, far beyond my meager abilities to discern. I reduced this to 80 and th game has been flawlessly smooth ever since.

My rudimentary theory is that the card was simply outperforming the data input, drawing, and then waiting for more info. Probably a stupid theory, but the result of this minor change worked wonders.
Not flaming just letting you know its something being looked at

http://us.battle.net/d3/en/forum/topic/5596249920

07/14/2012 11:09 AMPosted by Nosubstance
You people make me laugh when I see, "Blah Blah game runs without overheating my computer except when playing Diablo 3," not a direct quote mind you just merely an example. My computer NEVER overheats.
This doesn't do squat.
Not flaming just letting you know its something being looked at

http://us.battle.net/d3/en/forum/topic/5596249920

You people make me laugh when I see, "Blah Blah game runs without overheating my computer except when playing Diablo 3," not a direct quote mind you just merely an example. My computer NEVER overheats.


I need to reconsider my comment that my computer "NEVER" overheats. It has in the past but never caused by a game, best to my knowledge. I read that thread as well, my video card must be the lucky one as it runs cool. I was running it in crossfire and that's the only time it gets remotely hot.

Join the Conversation

Return to Forum