Press play, game won't start

Technical Support
Hey I was running Diablo 3 perfectly fine all the way since launch but now I have a major(?) problem. When I open the game and it shows its up to date and I click play, the game won't launch. The Diablo 3 graphic shows up like normal for a few seconds then goes away and the game doesn't launch. Looking at task manager it says that diablo is running but nothing shows on screen. If I try to open the program again it says diablo i already running. Can anyone help me out here?
I'm seeing the same issue; however, I've been able to get the game to start by ending the Agent.exe (updater) process in the windows task manager. I realize it's a goofy work around but I am currently searching for a more permanent solution.
Same issue

Falling the blue post in this thread helped me launch it the other day but even that isn't working now:
get the exact same damn thing. This is BS.
Try this, go into your Diablo 3 folder and delete the updates folder you find there. Then run the launcher again, let it patch and try to hit play then.
Same problem.. for some reason even after deleting the update folder it won't update or start
I have this issue too. When press play, it start and prompt that the game will close and there will be an update of patch. The game then halt and close. What is going on?

Help please !
im kinda having problem with this too

wen i press play the diablo 3 logo disappear but it wont go to the game. looks wierd can some 1 help me?
same here
Same here, i can't enter the game
same problem. i'm on a macbook pro. game doesn't start since 2 or 3 days.
tried to delete the update folder, the cache, and "agent.db" file. (it had worked before when same nonsense happened) updater downloads and completes the missing files that i deleted, but when it's %100 the game won't start anyway.

when i press play i'm stuck with the diablo logo forever. (until i force quit- "application is not responding")

i also tried to open diablo 3 directly from the terminal (it also worked before), now it doesn't work.

this is so annoying. with every update there's another problem and hours of looking at the forums for a fix. patches are meant to improve the game, not make it unplayable.

it shouldn't be this way really, it has been months since the release of the game and we're still discussing "launching problems" in the forums? shame on you blizzard. you really failed with D3, in my humble opinion.
i have this problem as well, weirdly ptr just working. but the game stucking at "diablo head" loading screen!
not a single admin giving help...
This is a disgrace...
I have exactly the same issue...
Same thing here. The game was working just fine a day ago.
I have the same problem. Was working fine until a few days ago. I've tried everything I could find, and nothing works. I just finished re-installing the whole thing, and same problem. Nothing has changed on my system since the time it use to work.

Would be nice if Blizzard at least acknowledged the problem.
admin really needs to respond to this I recently bought new hard drive reinstalled on new hard drive launched just fine then but this morning i go to play and stalls at the diabloIII head, task manageer says program is not responding... For the record all of my other games launch just fine just not diabloIII.... more than slightly aggravating
I am having the same problem! It worked fine last night before bed and got on WoW this morning and went to get on diablo and it shut down after I hit the play button? WTF?
I did everythiing I could think of. ended up reinstalling the game and that did not work either. used to work fine. get this error 38152E8C-D95C-4787-8376-AC9096A29F41
can anybody tell me about a fix?
Same problem here.
Game started at 4-5th try...

Join the Conversation

Return to Forum