failure to read required file. need help.

Mac Technical Support
When trying to start my D3 the launcher starts to load and seems to be trying to patch itself, then comes up with the error message:

"Failed to read a required file. Please close all other applications, temporarily deactivate your anti-virus, and try again.

I also get:

"An unexpected error has occured. Please try again." (or something along these lines)

Not entirely sure whats going on here but would like a fix.

I've played diablo on my new macbook pro before now it won't work.
now it says

ERROR the file "Application/Diablo III/Updates/d3-0-10235-OSX-final.mpq" is read only and cannot be updated (conflict manager;;DeleteFile

Delete that file in the Updates folder and run the launcher again. This will download another file and it should not be corrupted.
Hrm...another d3-0-10235-OSX-final.mpq problem. Has anybody bothered to check on Blizzard's end to see if their copy of the file is corrupted?
Same problem here - Started after I upgraded to Mountain Lion yesterday.

"Failed to read a required file. Please close all other application, temporarily disable your anti-virus software, and try again."

I dont have any anti-virus software.
This is happening to me to
and also my starcraft 2 is doing something similar as well
I have recently been downgraded to a non-admin user and thats when problems started occurring

I checked those files and they are executable

Are all these problems occurring on macs

Side Note: does anyone get the problem where on the first time you try to open d3 it tries to get you to install it again
Yes, mine is also switching randomly between trying to Install and Launch the game. I got the usual generic customer support response with a link to the support page that had read 3 times before I created a support ticket. The support process with this company is very slow and frustrating...
I am having the same issue, although in my instance, the game will (thankfully) sometimes fully load and become playable. Other times, I will receive one of the 3 above-mentioned errors, which I paraphrase as:

1. Failed to read a required file, close all applications and disable anti-virus.
2. Unexpected error, try again and/or contact Support.
3. File (d3-0-10235-OSX-final.mpq) is corrupted, reinstall Diablo and/or contact Support.

Also, after clicking the Launcher and waiting a few seconds for it to load,
4. Usually (but not always) prompted for my system's Administrator password.

This last one is an OS X dialog box bearing the logo ("The program Agent would like to make changes"). I was never prompted for Admin password by the Diablo Launcher under Lion, even when an update needed to be downloaded. I was only prompted for this during my initial installation back in May.

If someone at Blizzard is working on this issue, this is what I've tried:
- Upgraded to OS X 10.8, could not launch Diablo (error messages described above)
- Created new test OS X user account, launched - issue persists
- Created new test Administrator account, launched - issue persists
- Uninstalled Diablo, including Application Support files and other traces
- Created new test user account, reinstalled Diablo from, launched - issue persists

Specific info for my system, in case it helps in troubleshooting:
- 27-inch iMac 3.4GHz i7, 8GB RAM, AMD Radeon HD 6970M, 256GB SSD (no modifications)
- OS X 10.8 build 12A269
just being so infuriated when I have updated to the OS X 10.8 cause the Diablo3 cannot be reinstalled in my Mac, I have removed all the data in my Mac prior to install the new release version of MAC OS, but the installing progress just being stuck at the beginning and always 'initiating', I don't know how to deal with that, anyone could help me?
I have same problem patching 1.0.4. Error: The file "/Application/Diablo III/Updates/d3-0-10235-OSX-final.MPQ" is read only and cannot be updated. (ConflictManager::DeleteFile)

Submitted a ticket and all i get is a link to their support site. I've already did all those on the site which failed that's why I've submitted a ticket. I've also deleted the patch file and tried again and the problem persist. I'm using a Mac as well. please help.
08/23/2012 10:18 AMPosted by Tenzin
I have same problem patching 1.0.4. Error: The file "/Application/Diablo III/Updates/d3-0-10235-OSX-final.MPQ" is read only and cannot be updated. (ConflictManager::DeleteFile)

Delete the file indicated and open the launcher again.
Finally some one posted a solution i am having the exact same problem Please close all apps also deactivate anti virus. now u are suggesting a solution but that is not super clear to me. may u explain how to actually do it please?
thank u
Can you post the full error message? Or take a screenshot of the error?
"Failed to read required file. please close all other applications, temporarily deactivate your anti-virus software, and try again." i have tried %^-*en everything
Can you try our support article for this specific error?

Join the Conversation

Return to Forum