"Failed to Launch a Critical File"

Technical Support
Upon starting the launcher, the following error appears:
"Failed to launch a critical file. Please close all other applications (note: this doesn't work), temporarily deactivate your antivirus software (note: nope, this doesn't either), and try again. Alternatively, log in as an administrator (note: which I am, and also run as an administrator too) and try again."

Seriously guys, first SCII gets botched w/patch 1.5, and now you've broken D3? When's WoW gonna go down?
try ending explorer.exe process in win task menager
i got same msg once and disabling explorer.exe done it
at least for some ppl seems that explorer.exe is in conflict with launcher
Don't be a @@*# on the forums.
Bump - could use an acknowledgement of the problem.
08/06/2012 08:54 AMPosted by Shallaiya
Bump - could use an acknowledgement of the problem.


i get this problem with D3 and Sc2. My workaround is to end blizzard's 'agent' in processes but its a pain to do this every time i run the launcher.
Had this problem spring up on me today for a bit, reinstalled a few times, tried installing off the disc, etc etc.

What ended up working for me is turning off "Run as administrator" for D3. Hopefully you guys can get the same result.
Blatti's post in correct. I tried turning off run as admin and it is now working. I wonder why if would fail to load a critical file under administration rights..

Thanks Blatti
Thank you so much Blatti! I haven't played since September (wish I'd seen this thread earlier). I tried Blizzard support many times, copying good files over, following instructions to the letter, reinstalling, selective boot... and all this time, they were very specific to run with administrative privileges! Excellent work! I commend you.

Join the Conversation

Return to Forum