friends list causing game crash

Technical Support
so me and my friends login to d3 again for the first time in over a month excited for the new patch etc and as soon as we try to open friends list to invite to a game it freezes and says not responding.
playing solo ALL the time is the reason we stopped playing before
Getting the exact same problem here.

Odd thing is, immediately after I patched the game, it worked fine, it's only when I've tried to log in the past 20 mins that its started.
Same, since the new patch.
Bump - this is really annoying. Especially when I have 5 stacks of NV and accidentally press O instead of I.
Any luck here fellas? I've had ongoing ticket in, and after 6 "did you check __ " and maybe it's your __ ", they've come to the conclusion that they aren't seeing anything specific that is causing the crashes and hopefully (their words lolz) the next maintenance will resolve it. I've even explained I have this on two completely separate PCs plus 2 separate Macs, and I still have the problem so it would seem to me the problem would be on the Battle.net end. So after the extensive standard BS, this is what I'm left with. "HOPEFULLY".... -_-

Please post if you've got any solutions.
After a wordy reply on my part back to Blizz explaining my frustrations, I got a reply...AND A SOLUTION :

Maybe we can see if we can refresh the friends list.

If you try this, it will remove any Real ID friends and you'll have to invite them as friends again. So if you follow the steps below do so at your own risk as I don't have the names of your friends or any way to add your friends back. Here are the steps:

To do this, you would need to go into Battle.net under Settings and My commmunication preferences, then disable Real ID. Then reset your Password to refresh your Battle.net account. Then re-enable Real ID.

Then test the game and see if you're still crashing.

This totally worked for me. It also didn't wipe my friends list. It might for you, but I had all my friends still there. Good luck!!
This works! i had to do it 3 times but it works! i even logged in with it disabled then came back in with it enabled and it was fixed, and my friends were all there, so yay! thank you so much!
same thing going on here
kit,

Did you read the other posts in this thread and try what was suggested? I've also posted in another thread the same workaround.

http://us.battle.net/d3/en/forum/topic/7923533382?page=1#7

Join the Conversation

Return to Forum