[BUG] "Bashanishu" achievement not awarded

Bug Report
1 2 3 7 Next
The Bashanishu achievement is not awarded when hitting Bashiok with a normal attack with Rakanishu's blade equipped.

Difficulty: Normal
Character: Level 60 (1) barbarian
Realm: EU

I have tried this twice now, both times without success. I have made sure to hit Bashiok with a normal melee attack. Rakanishu's blade was equipped.

I have read some reports of this affecting other players. I would appreciate some word on this as it is very frustrating to have put in 10 hours of farming for a bugged achievement.

Screenshot of my skill setup & Bashiok:
Bumped because of edit.
I couldn't get this achievement either. I played with my WD on Inferno, equipped Rakanishu's Blade and the normal attack to my left mouse button, hit Bashiok and didn't get the achievement.

If it helps finding the problem here's the sequence of events as precisely as I can remember them. As I approached Bashiok my Templar and Gargantuan started to hit him. When I realized who's standing before me I swapped Rakanishu's Blade from my Templar (I kept it at him in case I finally found Bashiok) with my weapon, went to town and switched my Poison Dart skill to the normal attack. Then I went back to the Dahlgur Oasis, hit Bashiok and to my disappointment nothing happened. Switching back to Poison Dart and hitting him again didn't get me the achievement either.

As far as I'm concerned, this achievement is bugged.
Same thing happened to me too.

Difficulty: Inferno
Character: Level 60(4) Wizard
NA server
single player game
Follower: Scoundrel (lv60).

I found Bashiok, returned to town to grab Rakanishu's Blade, switched my left click to melee attack, then went back. Wacked Bashiok a couple times, dealt damage, but nothing else happened. Tried freezing him then attack, got the same results. Took off my offhand (shield) and attacked, made no difference. Switched back to my wand, dealt damage for a while, then switched back to Rakanishu's Blade and tried again, still no achievement.
Got annoyed and killed Bashiok....and forgot to take screenshots for proof.

So, achievement bugged? or did I do something wrong?
Same thing...

Difficulty : Normal
Character: Level 23 barbarian
In single player game mode
Follower: Templar

Found Bashiok but must returned to town to grab Rakanishu's Blade on right hand (nothing in left). Hit him 6 time or more with Rakanishu's Blade but nothing happend...After that i killed Bashiok always equiped with Rakanishu's blade but he dont give achievement. So sad....
I ran into the same issue. I am now carrying 5 Rakanishu's blades and have been on the bunt for Bashiok. I have encounter him multiple times and it did not give me credit. I removed my skill from my primary attack and stood there hitting him repeatedly with the blade. All the blades I have I found in normal difficulty. I was looking for Bashiok in nightmare difficulty and that was where I found him. So now I am trying to find him in normal difficulty to see if it has to be the same difficulty the blade was found in.
Second meet whit Bashiok...
The Templar and me equiped with Rakanishu's blade hit 6 time with this blade.
I take time to screen shoot him and kill him but no achievement...
Annoyed :(
Add me to the list of bugged Bashanishu achievement. Pretty much the same as others... except I removed my follower. I even stripped down everything except for blade and removed all abilities. This was in normal difficulty.

Btw, is there any way to confirm this and get credit for achievement? I've been trying this for months on and off and probably spent over 300 hours only to be bugged.
Bump again because I am having this issue too
add me to the list. same thing. wasted HOURS for a bugged achievement.
same here
Me too :(
This achievement is bugged for me as well. Hit him with the sword multiple times having no primary spell equipped and nothing was awarded.
I just came across the Even for the Sword and lucky enough found Bashiok in the same game, hit him multiple times and even killed him with the sword equipped. This was on Hardcore Normal mode with my lvl 20 WD. I was about to try it on my normal Softcore Wiz lvl 60(10) but then came across this thread.

So i guess add me to the list as well.
same trouble with my monk (normal mode, softcore)
first skill disabled to be sure to hit him with the blade.

Perhaps Biashok don't want anymore people hit him everytime ... ^^
Add me to the list.
I found Bashiok after 45 reset , me and friend tried and nothing happened.
When i open a ticket , they said they cant do anything...nice service......
I have the same problem here. Finally found Bashiok after about 50 - 60 runs and map resets, and hurt him with basic melee attack several times with Rakanishu's Blade equipped (3 different Rakanishu's Blades I found in normal mode), yet no achievement was awarded. Feel so disappointed and depressed after spending so many hours hunting for this achievement "Bashanishu", sigh..... :-(

I did use the print screen button to capture the picture as a proof, but I do not know how to upload it. Sorry.

Difficulty: Nightmare
Character: Level 60 (0) Male Demon Hunter
Region: South East Asia but using NA server (single player game)
No follower while finding Bashiok
Bugged for me too (v1.0.4) - see vid.

Pretty much as everyone else, searched for Bashiok for two weeks, finally spawned, my monk was naked both right and left click on normal(melee) attack, no passives active, no followers, Rakanishus blade equipped, hit Bashiok, no achievement.

I know some people have got this achievement so I'm guessing this is probably a bug since 1.04

Two weeks! Thanks for that.

Join the Conversation

Return to Forum