[BUG] "Bashanishu" achievement not awarded

Bug Report
Prev 1 2 3 7 Next
You can get it by someone bringing a rakanishu blade to your game. At least that's how I got it.

Maybe the blade has to be pre-patch or it cannot be your own, who knows?
Me too!

I happened to run into Bashiok today in a multiplayer hardcore game, in Nightmare with my 43 barbarian. I ported back to town, got my Rakaninshu's Blade out of my stash (which I had found while playing through normal mode solo in hardcore). Ported back, removed skill, hit, no achievement. Messed around with it a while, used various skills, left, came back later, tried again, no luck.

From reading other posts, it seems very likely that certain particular Rakanishu's blades are bugged and do not grant the achievement. Guess I'll wait for a fix, or maybe buy a bunch of Rak's blades off the AH or try to farm more hoping one is not bugged.
Perhaps my experience can help shed more light on this bug. The short version is I tried 3 blades, 2 that dropped this week and 1 that I had in my stash for months, and the old blade is the only one that worked. I hypothesize that blades created before a certain point (possibly 1.0.4 but not necessarily) are bugged and don't trigger the achievement.

Now the long version so you can all be sure I didn't do anything screwy.

I decided earlier this week to try to farm up a Leoric's Signet and figured I'd try to hunt Bashiok at the same time (i.e., this was on normal difficulty). So, the first time I got the Rakanishu shrine event, I grabbed the blade that dropped and kept it in my pack.

At this point in the story I'd like to take a moment and say holy !@#$ is this guy rare. Here's a list of what I found in the days of farming before I finally him to spawn:
-6 Liquid Rainbows
-5 Vigilante Belts
-4 Crudest Boots
-3 French Hens
-2 Leoric's Signets
-An Uskang in a palm tree (there are no pear trees in the oasis)

Anyway, Bashiok finally spawns today and upon seeing him I immediately vault away without damaging him and portal to town. I unequip all my items and equip the Rakanishu blade I have in my pack. I set my left click to regular melee attack and go melee him a few times. Nothing happens.

As luck would have it, the game I was in had a Rakanishu Shrine event and there was another blade lying on the ground nearby. At this point there are many possible reasons my blade doesn't work and I can test several of them by using a blade that drops in the same game as the Bashiok spawn. So I equip this blade and try again, hitting him multiple times, but without triggering the achievement.

Of course, I didn't really expect that to work, but having seen this thread what I was interested in trying was using a blade created before 1.0.4. So, I grab the blade in my stash (leftover after my last failed attempt to get the achievement months ago) and I get the achievement on the first melee hit. Unfortunately I can't be more specific on when I got the blade in my stash than "months ago", which is why, while 1.0.4 makes the most sense, I can't say at what point the blades started coming out bugged.

So if I'm correct, for now it looks like you're SOL unless you have an old blade you can use. Hopefully this will save someone a lot of wasted time.
Add me to the list... got the blade two days ago and found him today in Inferno... equipped the weapon attacked him with standard melee, cleave, bash, all my skills and nothing...
This is a bug, I attack him with 2 diffrent blades, didn't work.
I am in the hardcore nightmare game right now, i am using the blade i found month ago and hitting him is NOT TRIGGERING the achievement. I am so angry, I've clocked so many 100's of hours and this is my 1st time finding him and the achievement DOES NOT WORK!


I opened the game to the public, someone joined and i asked them to keep the game running while I got to the AH and bought the 3 lowest dmg blades. Got back in the game and i tried one of them and once I've changed my weapon and hit him the achievement unlocked! Phew! Hard to tell if this weapon was created before 1.0.4
Difficulty : Normal
Character: Level 25 barbarian
2 Rakanishu's blades equipped
Single player game mode
Follower: Enchantress

Same thing happened to me after searching for weeks. Frustrating.

Edited to reflect two blades used.
Difficulty: Inferno
Char: Level 60 Monk
Used 2 different Rakanuishu blades, still no achievement :(
even worse is that i have seen him twice this week
Have the sword. Have the melee skill. Finally found Bashiok, after 46 resets casually done on different toons over the week. Yet the achievement seems broken/bugged. No way to hold that reset with him spawned so I guess it's wait for someone to confirm they fixed it and try to farm him up again.

I didn't bother to start D3 till after 1.04 so older blades are a no go here.

I have no idea if any of my six blades are older than 1.04. Sigh. I guess I'll stop trying to get this achievement and let the characters move on to their next quest--at least until I hear otherwise.
10 minutes ago i kill bashiok, 3 blades and nothing ... achievement DOES NOT WORK!

Waste of time, i'm quite bored. I hope they fix the problem soon.
~50 runs on Inferno and finaly I found him...
Same problem - achieve don't work.
I've tryed several things: to remove all gear, sell and buyback blade, invite other people to party - nothing.
Seems to be (as it was said before) blade itself is bugged.
BUGGED! so lame, shame on you blizzard for wasting all of these people's time - and not just a few hours for most of us...

same story for me, tried 2 blades, removed all skills, blah blah blah!

I had the same problem... had someone hold my game and I bought all the blades in the AH! One of them actually worked, I am saving it, in case someone is interested in giving it a try as well, contact me in game.
bumping this to the top, since I wasted many days on this bugged achievement, and did not see this massive list of people failing at the achievement like I did.
You'd think this would not be on page 2, it would be stickied, so people won't waste a week of gametime on this !
Butz is right, the achievement is not bugged, but the blade is, i myself got a blade from 1.04 patch, spent 2 days finding bashiok, whacked him but no achievement, didn't want my 2 days of finding go to waste, so i've made a thread asking for help (http://us.battle.net/d3/en/forum/topic/6794830916), this player happened to have a pre 1.04 blade which he is kind enough to lend me after joining my game and done with his achievement.
After hitting bashiok with his blade my achievement popped up and i'm done with Bashanishu achievement.

Hope Blizzard will notice this blade bug and fix it soonest.
im joining this list aswell, just found him, allready had rakanishu's blade equiped on my lvl 23 barbarian ( was lucky enough to find one, with a socket, and placed a big shiny red gem in it, does 46,6 DPS alone)
put normal attack on my right mouse button, and my cleave on my left mouse button.

after spending the entire day, farming bashiok, my dissapointment got really high, when nothing happended when i hit him.. :(

now i can look forward to farm him again, once you have cleared this bug, as i know there is no reimbursment on bugged achievements.... plz. blizzard fix this soon, its one of the last ones i need in challenges achievements.
Same here, hunted him for 2 days, no followers, no skill used, no thorns, just plain whacked him to bits in one hit (normal) and received? zilch!


It would be nice if someone from Blizz at least acknowledged that there is a problem. :(
Bump for one more annoyed customer. I racked up a full inventory of Rakanishu blades from all the runs looking for him, but I didn't know I'd need to hit him with a pre-1.0.4 one until after I finally found Bashiok after a week.

Join the Conversation

Return to Forum