[BUG] "Bashanishu" achievement not awarded

Bug Report
Prev 1 4 5 6 7 Next
Just got the achieve. Was farming keys and just happened to see Bashiok.

Tried a blade I got on AH, it didn't work. Invited this other guy when looking for a solution in chat (he didn't have achieve either), his blades didn't work.

Invited my brother who got the achieve pre-patch, his blade worked.

I can confirm the blade matters. It's a bit ridiculous this achieve isn't fixed considering how annoying it is to get...
Still have the blade? Have Bash up finally, but blade doesn't work...
Just here to confirm it is bugged as a mafaka. REALLY annoying.

left and right mouse buttons cleared for skills. (lost my NV for that mind you!)
Rakanishus blade equipped.

punching at the bashiok like a retard, to no avail.

All this done on MP1 inferno.
A friend and I just found Basiok ingame and had the same problem. Two different swords and neither one worked. His sword is definitely new (post 1.05) but I'm not sure whether mine was pre 1.04 or not (I was changing mine for a newer Rakanishu's if it had decent stats).

Is there confirmation that this is a bug and not just everyone screwing up (somehow)?
and a friend of my and myself occurs the same

hit Bashiok with 1.0.5 sword and no achievemente

post ->> http://us.battle.net/d3/en/forum/topic/7200050237#1
hi i have this problem i encounter 2 times

both at inferno
i hit it so many times i didnt awarded.

is so hard to find him. can blizzard give me that achievement.
i have screen shot

Difficulty: Inferno
Character: Level 60 (77) Male Demon Hunter
Region: Ameria

(single player game)
No follower while finding Bashiok

screen shot
A buddy and I had same issue 3 weeks ago, after just under 30 hours(not straight through, over 4 days) of farming for him. We're in seperate games, got pre-1.04 blade, 1.04 blade, and a 1.05 blade. He tells me we finally have him....I jump over to his game, excitement flowing....in to battle we go, hitting him over and over, switching out blades, we let him live for almost 20 min, trying to figure out what was going on....finally, while my buddy was punching his desktop, I regeared and disinegrated him, demoralized. A complete waste of time, complete let down. This achievement plus the 3 Uniques achieves should be fixed instead of all the stupid fixes no one cares about getting done. Like changing the shades of drops, although a nice touch, no where close to as important as being able to finish an achievement.

Edit - Before someone else points it out, yeah, guess had I read the forums before wasting the time I would ot have wasted the time...but I didn't think I would have to research everytime I try an achievement...I know better now.

i got him now in hardcore nightmare. I have the blade but hitting bashiok does not work.

If anyone has a blade please contact me, i will keep the game up an hour or so.

Bugged for me aswell,........ 1.0.5.

Farmed this guy for hours on my main, but couldn't find him now i met him on my lvl 53 HC Witch Doctor,

Equiped blade no attacks on left and right click.... sup blizzard?!?!

Even have screenshots,
Still bugged :-(

Same as the rest

Barb 60 (6)
Had two blades, not sure how old, I think one of them was from the week after release, not sure though. The other was new. I have screen shots of me hitting him with both and no skill, and with skills, and I killed the bastard out of spite...

For the record, these are other achievements which are bugged:
1. Everybody Loves Shen
Victory (Act IV) - I've seen a Blue Post indicating that this conversation was removed from the game pre-release and shouldn't be a requirement anyway. That post was made 10/24 btw, doesn't seem like a big issue or do these things only get fixed on big patches, not hotfixes?

Which means I can't get these two either
- Talk is Cheap, Friends are Priceless
- The Art of Conversation

2. Quick Study
Wandering Tinker's Diary, have it, can play it from my log, doesn't drop anymore, but the achievement doesn't reflect that. I'm not the only one with this problem, I've seen multiple threads about it

3. Judge of Character
Orders from Magda, they don't exist in Act 2, they're from Act 1 and are required for Quick Study. I have those.

Because I can't get 2 and 3, I can't get Grand Lorekeeper of Sanctuary.

All of these total to 100 achievement points and hours of my time, please fix these issues, or remove the achievements all together if you can't do them right...
Are you serious blizzard? I just found him, hit him with 1 blade hit him with 2 blades, got a friend to try ... nothing only thing i can think of is that I wasn't naked. First time I have ever seen him and its bugged gfg. Do I hold onto this pos weapon or what.

Wasnt there a patch just a few hours ago .... could this not be fixed or removed then?

Inferno farming key run, finally see bashiok for the first time in EVER, 1.0.5 blade doesnt work.

The worst part is i had a pre-patch blade from the night the game came out like 2 days ago and vendored it by accident. GG.
This.....is... lvl60 HC trolling!
Waste SO MANY hours on finding this bloody mob and then - just blew the achi... HAHAHAHHAAHA
Hunted for him for 5 days, finally found him and no achievement. Basic attack, blade equipped. This is pissing me off so much.
I just found him and no achievement, normal attack........ :\ *sigh*

Why hasn't blizzard fixed this yet!!!!
I have the same problem like all others in this topic. :(
What is most annoying is that this *used* to work, i got this achievement early on several patches ago, to see that blizzard fix some things while breaking others is a bit disheartening.. It leaves a shadow of doubt in your mind if you are having difficulty with an achievement you always have to wonder if it is bugged. I really hope they fix this (along with the others, i.e. the rare/champ achievements) soon, because I recall exactly how much grinding is needed to find Bashiok.
The blade itself is bugged. One of the patches broke the blade, to unlock the achievement you need a blade that dropped from around 1.03 or before. New blades won't trigger the achievement, I was having the same trouble till I saw a thread on General regarding an open Bashiok game. The guy who posted the thread had a working blade.

I suggest you just wait for the same.
This achievement is not working for me also. Basic melee attack on Bashiok mob with rakinishu's blade equipped and nothing happens.
I just found Bashiok after 5 months and got no achievement! So what now? I need to w8 blizzard fix it and searching for him 5 more months? Or a life?? I even dual wield with 2 rakanishu and no achiev. Better increase his spawn rate after you fix it or give us the achiev after you fix it.. not willing to lose my time on searching Bashiok all the time.....and after all this you want to be the game of the year.. yea right!

Join the Conversation

Return to Forum