diablo 3 launch stuck on initializing

Technical Support
when i launch diablo 3 it just stays at the initializing stage. the play button is all grey. havnt had this happen before 200 plus hours. i just downloaded warcraft starter edition and played it yesterday. after i stoped playing warcraft i tyred to play diablo 3. it just said initialzing so i tryed warcraft and it said the same thing. still having problem over 24hours please help. thank you for your time
Same problem here. Can we get some blue info or something on this?

I was able to play the game fine, but when I exited the game and rebooted my slow-as-molasses modem that was causing me real bad lag and tried to get back into the game, I'm now stuck at the launcher's initializing screen with no way past it in sight. Why is this happening? I was able to play fine earlier.
yeah this isnt cool waiting for days before a reply sucks. i bet they will reply to us after problem is solved. why even bother every hour im at work ill just keep trying to play. i will know when its working again all i want to know is why isnt it working now. and if there isnt a solution in sight soon it would be nice just to hear that
Try deleting the following Battle.net folders. Worked for me..

C:\ProgramData\Battle.net\Agent
C:\ProgramData\Battle.net\Client
C:\ProgramData\Battle.net\Setup

These are all hidden files, so make sure "Show hidden files" option is checked...
that is exactly the same thing that is happening to me right now.... idk whats going on.. been waiting since 7am!!!! restart computer, my wifi, blah blah ive done it all... about to uninstall wow

Anyone know what i should do
The servers are down right now.

Join the Conversation

Return to Forum