1.0.4 CRASHING

Mac Technical Support
Never had a problem with crashing, after patch constant crashing.
Same here... I search for an item in the action house, it crashes... I'm changing a quest, it crashes... It's really annoying...
Same here. Game crashes, gives me a Blizzard error message (657C91AA-565D-4E7B-948B-D240021B659F this time). Happens after about 30 mins of play, and so far I've noticed it seems to happen the instant a blue or yellow drops from a a chest or breakable. I've noticed some people saying it happens when they move gems; maybe this is related?

My specs:

Model Name: MacBook
Model Identifier: MacBook7,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.4 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 3 MB
Memory: 2 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MB71.0039.B0B
SMC Version (system): 1.60f5
Sudden Motion Sensor:
State: Enabled

NVIDIA GeForce 320M:

Chipset Model: NVIDIA GeForce 320M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x08a0
Revision ID: 0x00a2
ROM Revision: 3533
Displays:
Color LCD:
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Display Connector:
Status: No Display Connected
Okay, I can confirm that the game crashes for me as well when moving gems. I really want to enjoy 1.04, but it's currently not playable for me. :(
I can confirm that the gem move crashes as well and that it still randomly crashes for me after 30-40 min on gameplay. Why can't we get blizzard to acknowledge that this is a known issue?

Crash codes:

8786DAA2-2B4E-4997-88FA-ED08FCA71333
412E153F-874C-4C53-A7C5-4D2EA0E72F22

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro6,2
Processor Name: Intel Core i7
Processor Speed: 2.66 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 8 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: MBP61.0057.B0F
SMC Version (system): 1.58f16
Sudden Motion Sensor:
State: Enabled

NVIDIA GeForce GT 330M:

Chipset Model: NVIDIA GeForce GT 330M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0a29
Revision ID: 0x00a2
ROM Revision: 3560
gMux Version: 1.9.21
Displays:
Color LCD:
Resolution: 1680 x 1050
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Is Blizzard going to acknowledge this 1.0.4 crashing issue I wonder. I want to play.
To be fair it is the weekend. When people come back on Monday hopefully they'll look into it. That's the nicest you'll get out of me though.
Not sure if this is a permanent fix, but uninstalling and reinstalling seems to have fixed this problem for me. No more crashes from gems or chests/breakables, and I played for about 45 mins with no random crashes. Hope this helps :)
Thanks for the reports on this. We're looking into this.
I started up the game; Joined Act III Inferno
Went to sell to, "Vidar The Collector";
Sold a blue item; picked up my yellow in the inventory
moved yellow item one slot over;
walked away from seller, "Vidar The Collector."
Game Crashed.

Error Code: 45760CD8-82E2-4FBB-8E6D-0290AC123006

Model Name: MacBook Pro
Model Identifier: MacBookPro5,5
Processor Name: Intel Core 2 Duo
Processor Speed: 2.26 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 3 MB
Memory: 4 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MBP55.00AC.B03
SMC Version (system): 1.47f2
Hardware UUID: 020538CA-04F3-51B1-9FF2-581F8BF6E6E8

NVIDIA GeForce 9400M:

Chipset Model: NVIDIA GeForce 9400M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0863
Revision ID: 0x00b1
ROM Revision: 3427
Displays:
Color LCD:
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

System Version: Mac OS X 10.6.8 (10K549)
Kernel Version: Darwin 10.8.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Computer Name: w3rdn4
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: No
Time since boot: 1 day20:58

Error Code: 45760CD8-82E2-4FBB-8E6D-0290AC123006

Also where did the 800x600 graphics go?
I could use that and everything at the lowest setting and it won't crash

When the error took place
I had the following settings:
Lowest Widescreen resolution
All settings on the lowest possible setting or turned off
Physics low
Low FX check marked

Restarted my Diablo 3 Launcher and it is updating now for no reason.
800x600 should be there still. What resolution options do you see?

As for the crashes, it may look like the game is crashing due to corrupted data for some sound files. Some users have attempting to reinstall to resolve this issue, but let's try and see if we can rebuild the cache folder first to resolve these crashes.

Rebuild the Diablo III Cache
    1. Navigate to /Applications/Diablo III/Data_D3/PC/MPQs and delete the Cache folder.
    2. Then, navigate to Users/Shared/Battle.net/Agent and delete the Agent.db file.
    3. Run the Diablo III Launcher and let the game update it's files.
    4. Press Play when you see Game is up to date
800x600 should be there still. What resolution options do you see?


960x600 (16:10 Widescreen)
1010x630(16:10 Widescreen)
1050x660(16:10 Widescreen)
1090x680(16:10 Widescreen)
1130x710(16:10 Widescreen)
1170x730(16:10 Widescreen)
1210x750(16:10 Widescreen)
1280x800(16:10 Widescreen)

Also error Code: F993E07C-DE2E-4F20-AE71-7DD4A9CF8055

I joined a game; played around and did some stuff in act I;
Did a Butcher Run
Go back to the chest to drop off loot
Clicked to drop off 1 square Ruby
Game Crashed.

I rebuilt the Cache and 800x600 didn't show up.
08/27/2012 05:00 PMPosted by WeRDn4
I rebuilt the Cache and 800x600 didn't show up.

Did it fix the crashing? This was for the crashing.

Is you desktop resolution set to its native resolution? I know there is a bug currently where if the OS resolution is not set to the native resolution, then it will have different resolutions available.
Uninstall D3 (http://eu.battle.net/support/en/article/diablo-iii-uninstall-instructions) and then reinstall. Worked for me. No more crashes.
Testing it out; I have not crashed after rebuilding.I had to change my resolution to 800x600 on my mac settings to get 800x600 enabled on diablo 3. So I think it is good for now. Thanks

Although the game doesn't crash when playing.
I get an input limit reached and it disconnects me sometimes while searching the Auction house.
800x600
lowest setting
killed Diablo in hell mode
end of the game sequence
hit escape
Credits
hit Escape
Game Crashed

Error Code 8409C8C3-997F-4408-8DB4-05FE5AD7714C
Hello,
have same problem with crashing system and sound loop, being forced to power off system with power button. tried the recommended above, problem persists. I have also uninstalled D3 and reinstalled it (via client download, not from dvd), nothing solved...every 30-40 minutes i'm crashing. specs apparently do not matter if high or low. regarding sound i'm running on a sound blaster X-fi notebook with latest updated drivers. i'm on an nvidia quadro 3700m (GF9800gtx) and run relatively smooth with mid-high settings on a 2560x1600 30' monitor.

anything to suggest? any news from Blizzard about this?
Don't think my case is as severe or preventing me from playing as much as the ppl above me, but my client seems to crash occasionally when I log into a game (clicking on the "Start/Resume Quest button) and sometimes when I log out of a game (clicking "Leave Game" in the esc menu in game). It's not denying me NV stacks or farming, but it's just annoying, and it would be helpful if Blizz looked into it. Been happening post 1.0.4, on my Macbook Pro 13inch from 2011.
800x600 should be there still. What resolution options do you see?

As for the crashes, it may look like the game is crashing due to corrupted data for some sound files. Some users have attempting to reinstall to resolve this issue, but let's try and see if we can rebuild the cache folder first to resolve these crashes.

Rebuild the Diablo III Cache
    1. Navigate to /Applications/Diablo III/Data_D3/PC/MPQs and delete the Cache folder.
    2. Then, navigate to Users/Shared/Battle.net/Agent and delete the Agent.db file.
    3. Run the Diablo III Launcher and let the game update it's files.
    4. Press Play when you see Game is up to date


This worked for me. I only needed to delete my Cache. I also Started the game in Windowed mode.

Join the Conversation

Return to Forum