lighting bug nvidia drivers 306.23

Technical Support
so today i updated the new drivers from nvidia to 306.23 and i noticed a lighting bug in d3.

basically the brightness on the screen seems to jump back and forth and flicker as i run around tristram.

i have a geforce 550ti. never had a problem like this before.
Just did a sweep of both Old and New Tristram to see if I could find similar, but the closest I came across was some fog in areas of New Tristram (such as near where the Mercenaries hang out when they aren't following you). Mind you, this is with a GTX 670, rather than a 550Ti, so that may make a difference.

Are the flickers you're seeing consistant, in that they're always in the same basic palce? Further to this, are you able to screenshot a "before" and "after" and upload them to somewhere like Photobucket?
I'm having the same problems as HGN as well, running on a GTX 670 with 306.23.

Brightness of screen flickers as I run around Tristram. Flickers are abit to quick to be captured though.
Same here my graphics card is an EVGA 545GT and I updated it yesterday now im noticing the light flickering in different acts/areas. Also seeing some slight stuttering when moving around.
Just an update I don't believe its the graphics card or anything on user end I was walking around and decided to test something out. I found that the lighting is dimming when highlighting my stash, NPC's and whatnot and brightening when moving your cursor over an open area that doesn't have anything around it.
I'm not able to reproduce any of these symptoms on a GTX 580.

@Scardjinn - your symptom description sounds like it might be related to the desktop text size set in Windows 7 actually. If you use that OS, try this troubleshooting step:

1. Right click anywhere on the desktop and select Screen Resolution
2. Click on Make text and other items larger or smaller
3. Change the size of text to Smaller - 100% (default)
4. Apply, click on Log off now and restart
I've checked my text size and its at 100% smaller default. I've already restarted my computer and restarted Diablo III yet still having the same issue.

Are you using full screen mode and do you have vertical sync enabled? Have you made any changes at all to Nvidia's Control Panel for the 3D settings?
took screenshots, but i won't be able to upload them till maybe tomorrow night...

what info do you need blizz?

i have an i7-930, 2.80 ghz, windows 7, geforce 550ti. i've updated all my bios and drivers, the new nvidia driver is the latest to be updated. didn't have this problem before i updated nvidia. Was actually hoping the driver update would fix sc2 (the whole 1fps lag bug) but that didn't seem to work.

i have all my d3 settings on high, no vsync. didn't change any settings before or after driver update either.

It looks like the brightness of the screen jumps higher and lower, only as i run around. if i'm idle it wont change by itself.
In the game I have vertical sync enabled as well as full screen. I checked my 3D settings in the Nvidia control panel went ahead an reset reset all settings as nothing seemed out of place. I've logged back in and the flickering has stopped good call on the 3D settings I've just recently updated my drivers on my video card as well as my Realtek HD audio drivers. Now I have to figure out why I still don't have sound >.<. Thanks for the helpful posts!
Same issue here. The problem seems to pop up whenever my mouse hovers over something clickable. I've attached a video to show the problem:

I'm on an i7-3610qm with 660m GPU. Asus g75vw-as71 laptop

With previous drivers I get stuttering issues. With this new one, the stuttering is all but gone but now I have these lighting problems. I don't think D3 and I are meant to be together anymore
Could you try booting up in selective startup mode and seeing if it happens when other apps aren't auto-starting?

Make sure there aren't any mods for Diablo III in use like Dark3D or apps like Fraps too.
Unfortunately that didn't change anything
yah happened to me as well roll back ur drivers for nvidia im using a gtx 680 atm
I am having this issue as well. 306.02 drivers running two MSI GTX 560ti video cards in SLI.
Same issue here. Driving me nuts. Basically every time you mouse over item label etc the screen darkens around the edges so you get this contstant flashing effect as you mouse over monsters and items on the ground.

The ONLY change was me updating from beta 304 drivers to the new 306.23 drivers. Unplayable as is.
After some testing I found out what is causing this.

If you set the Diablo 3 NVCP Profile settings to:

Anti-aliasing - Mode = Override any application setting
(problem persists even with Enhance Setting)

Anti-aliasing - Setting = 16xQ
(problem persists even with 8x Setting)

Turn In-game FSAA on = Problem appears
Turn In-game FSAA off = Problem disappears

What it looks like is happening is the In-game FSAA and Diablo 3 NVCP Profile AA settings are conflicting with each other and is enabling/disabling itself everytime you highlight a clickable item.


In the Diablo 3 NVCP Profile:

Set FXAA off.

Set Anti-Aliasing to Application-Controlled for both Mode and Setting.

Or use the NVCP Anti-Aliasing settings and turn the in-game FSAA off.
That worked! Thanks!
yes turning ingame anti alias to "off" is working now! thank you!
case closed, we all worked good on this one. we deserve hots beta keys. *grins*

Join the Conversation

Return to Forum