Software Update broke performance?

Mac Technical Support
Hi all. I've noticed some complaints about recent performance drops, and because of Lorena and hunter's threads, it looks like the problem might be the most recent update.

I run on 10.6.8 on a 2008 Macbook and while D3 wasn't flawless on my system, I could at least squeeze out 20 to 25 fps windowed with low settings. In a fairly cool room with a cooling pad and smcfancontrol, I could play for hours with no problems.

Apple issued an update late last month, something like 2012-004. After applying the update, my performance plunged and temperature issues started popping up. My system now rockets up to 90ºC, and I had to tweak my D3Prefs to bitdepth 16 and drop mipbias to even get under 85ºC.

Looks like this latest update has somehow messed things up for us. I'd highly recommend reinstalling OS X and only applying necessary updates from before this last one, which seemed to have worked for Lorena. Don't have my install disc on me though, so I guess I'll have to resort to wearing a fur coat in a fully airconditioned room while playing D3 :(
Also remember it is a suplemental update, which means it is not critically needed.

Now, this solves the issue for now. One wonders what will happen with further updates.
I am also running on 10.6.8, and I don't believe I have installed that update yet. Looking over the patch notes ( I don't see anything that could cause a drop in performance. However this is far from saying it didn't cause the problem. We have seen many patches break things with graphics and performance with the OS that had nothing in the patch related to that. If you can reproduce this on multiple computers then I would recommend submitting a radar to apple about this and seeing about having blizzard + apple looking into it.
It happend to me on a mac mini 2010 (the fan died) and a macbook pro 2012.

I'll try and submit it to Apple, as I already did to Blizzard. It is true that nothing in the supplementary update seems to have the potential to cause problems. But it's been happening to several users, so hum, who knows.
Lorena, you mentioned somewhere that an SMC reset fixed things for you? Looks like a blue confirmed it as well. Hasn't helped my situation though, le sigh.

Join the Conversation

Return to Forum