Sokahr the Keywarden BUG

Bug Report
I've been running on act 2 for that key now for some time and I've noticed that most of the times, Sokahr the Keywarden freezes up and you can't beat him...

Sometimes it happens quickly and other times just before i'm about to kill him...

I'm using a sorc and my monster power setting is on 3...

You gotta fix this bug... It's pretty annoying having to start over and over...!
Same for Europe as it just released here.

For info Inferno (2)
Likewise Sorc MP5
Same this just happened to me
I had this problem too, and I managed to kill him.

I got him down to 1 HP
Then I got frustrated
Then I paused the game and came to the forums to read about it
After searching through the forums and not finding anything I went back into the game
Then when I unpaused it, my templar instantly killed him...

Good luck everyone
Thanks for the info gabu. The other way around it's to set the machine level on "0" but it will take more time to get the key.

The second solution it's not to get on inferno but on hell mp10.

Regards,

ps: hope they will fix it soon.
This is what happens when you rush a patch into live....this was a known issue for pretty much the whole time the PTR was up, I have no idea why it hasnt been fixed yet...
Same thing is happening to me, WD MP5. Three different times unfortunately.
+1 - Witch Doctor level 26, Normal difficulty, Monster Power 10

Can get Sokahr down to 1hp, but no further after several minutes.
next time anyone runs into this, can you guys list what MP level you are on, if you are grouped or solo, and perhaps what follower you were using at the time?

also it appears gabu found a possible work-around by pausing the game. this tells me he was solo. but regardless, can anyone else try the workaround & let us know if it also works for them?

I have seen tons of players reporting this issue but not yet experienced it myself, I absolutely believe it's an issue but I also haven't done any key farming solo, only in groups...

just trying to help digup as much details as possible to help recreate and identify the issue so QA can pass it to dev for fixing
Workaround to kill Sokahr posted at http://us.battle.net/d3/en/forum/topic/6934193507?page=1#3 by Shaggy.

Long story short, TP back to town and hire the Rogue, respecc him into Powered Shot. It will finish off Sokahr. Personally tested and works 100% of the time for me so far.
10/18/2012 10:35 AMPosted by Lezard
Long story short, TP back to town and hire the Rogue, respecc him into Powered Shot. It will finish off Sokahr. Personally tested and works 100% of the time for me so far.


This worked for me. Thanks
Worked indeed ;)
I'll try the Scoundrel trick next time this happens. Tried to do the bugger 3 times today and every single time he glitched on me. Needless to say, I was getting really frustrated by the 3rd time.
I've had an instance where Powered Shot did not finish him off - in that case, I switched to the Templar, respecced him into Charge, and was able to kill Sokahr.

For safer results, try to get a cheap piece of Stun/Fear gear (fears seem to debug him, as the link I mentioned above stated that WD Horrify works) and keep it in your stash until Blizzard fixes this.
Bump so this is not ignored.
10/17/2012 04:45 PMPosted by Vasadan
Thanks guys, we are working on fixing this as soon as we can.
Ditto. Couldn't kill him in Normal as a Barbarian somewhere in the 20-24 level range. Sorry, wasted 5 hours playing today so I don't remember the level exactly.
This just happened to me in a multiplyer game, stuck at 1 hp, was forced to move on.
For any DH players, I found an arrow storm killed it nicely, and I think that it might be AoE abitilities that can kill, as powers such as sentries and shadow pets wouldn't work, and i'm assuming summons wouldn't work for a witch doctor. Good luck all, although rogue and templar can kill if my notes don't help

Join the Conversation

Return to Forum