Bug Report
10/25/2012 07:08 PMPosted by Ender

Actually, no, because players are able to get this achievement. The achievement reads "Hurt Bashiok using Rakanishu's Blade."

Basic Attack is literally Basic Attack. It is the attack you have when you do not have a skill equipped to LMB or RMB.

I'd like some clarification on the "Punch Diablo" achievement. Is it literal? I've tried attacking without a weapon/offhand, but nothing happens.

The only way I could get this was to switch primary skills during the battle, this causes the primary skill to enter a short cooldown where you can't use it, and clicking the left mouse button will then make you punch.
yep bugged. i tried all possible primary skills, no skill, lmb, rmb... kill him with the blade... and no achieve..
I've done this myself.. and which sword you use makes a big difference

I found bash in a preclear keyrun I set up I then posted for anyone needing hte achieve

one guy purchased 15 rak swords form the AH .. 15 of them... 15... ten plus 5.. 15 freaking swords...

only one of them worked... this is yet another bug Blizz stop denying it... get to work fixing stuff soon please
I was unable to get it several times, then a friend invited to come to his game. Several had gotten achievement already that game. I equipped sword without skill then proceeded to attack him. No achievement. I did again and again -- no achievement. He said to try doing with his sword. I got the achievement. Strange -- one sword no achievement, his I got it. So then it wasn't my character that was bugged but my sword.
i friend of mine and myself happend the same :(

Post ->
11/07/2012 10:28 AMPosted by CrazyCarl
It doesn't work for me whether I use a skill or use a basic attack, so I don't really see how "unobtainable" is incorrect. It literally is unobtainable unless I can somehow find a blade from an older patch.

this >,< glad i got lucky

dude spent over 1mil in blades we kept the game open for over 2 hrs passing the 8th one around

like 20 peeps got the achieve @ least before i stopped keeping track
I found Bashiok twice and hit him with two different blades and did not get the achievement.
I had the blade equipped and was using Way of the Hundred Fists; as far as I know there is currently no way to drag a skill off the skill bar in order to use a basic melee attack.

One of the blades that I used was older than the last few patches for sure, and the 2nd blade I tried was acquired today, old or new neither blade worked. So I'd say it's definitely bugged, and this bug has nothing to do with using a non-skill attack.
I completed this with a friend recently.
It seems to be an issue with the blade. My blade worked just fine, my friend's blade did not.
I gave her my blade and bam. It worked.

I don't remember where I got the blade from but I would suggest getting a couple from different difficulties or have a friend bring you a bunch from outside the game since Bashiok seems to be a pretty rare spawn.

Maybe the friend's blade was pre-patch drop, and this guy's blade was drop from the recent patch.

I'm just facing the same bug problem at this very moment : during a solo game I encounter Bashiok and hit him with the LMB and no assigned skill with my monk, it's a non pre patch Raka sword.
Damn it !
Basic skill attack still works with current patch. Unfortunately though swords become bugged for some reason. Some work and some don't. Friend invited me to his game where he found
Bashanishu as I still needed the quest. My sword didn't work. His did. Suggest getting multiple swords before you do this quest.
1. elective mode
2. While the blade is equipped, drag the skill off the bar so that it's literally your basic attack you had at level 1.
3. Hit him with your button marked basic attack now.
4. profit
OK, I have a slight case of OCD, so when I finally found Bashiok after 100+ runs, making sure my thorns were off and I used a basic attack and it did not register the achievement, I was about to cry. I tried to look up the issue, and all it said in the support site was that they 'cannot award or alter achievements in Diablo III. If an achievement is not awarded and you feel that it should be, please attempt the achievement’s criteria again.'

I don't want to have to do this again! If he spawned say in one out of ten runs, sure, not a problem. But it just can't be right that you have to find several versions of the blade and then do another 100 runs in order to even try to get the achievement to work!

Argh, I know I'm ranting, but gods, it's frustrating!
I tried this today and finally found Bashiok. Tried with melee on off one sword two it dont matter nothing. This is bugged. I dont care if you did it. It was luck. I tried 4 diff swrods and nothing. NO achievment should be this much a pain in the butt, ESPECIALLY when the bad guy does not spawn that much.
Fix this bug, Blizzard. It is a bug and it's incredibly frustrating. After days trying to find the monster being denied this achievement is absurd.
12/14/2012 02:10 PMPosted by leloup
Fix this bug, Blizzard. It is a bug and it's incredibly frustrating. After days trying to find the monster being denied this achievement is absurd.

^ This.
So how glad i was that i found a free achievement during my key run.

Guess what, didnt work with basic attack nor any skill.

Sometimes it seems like Blizzard hasn't ever heard about testing things.
I found this NPTs, I cleaned all skills and I broke it simple attack by a sword. Achivka didn't give, in what the reason? ? ? ?
You need an old sword for the achiev to work, I was lucky enough to find a guy who found Bash on mp8 inferno and someone gave him a working sword, so he kept the game up and the sword on-hand, lots of people including myself got the achievement there.

The currently-dropped swords are broken! Only the old ones work! The bug lies in the swords, and if Blizzard doesn't acknowledge this, it can't get fixed.
Yeah, this is terrible! Yesterday, after what must have been hundreds of runs, my friend finally found Bashiok and invited me to the game. We each had several Rakanishu blades, and not a *single* one of them worked!

For a long time, we pinged everyone on our contact lists to see if they had got the Bashanishu achievement. Barely anyone even knew what that was, and the couple of guys who did have it had gotten rid of their swords a long time ago.

Finally, after a lot of IMing, I found one of my contacts who joined the game and his sword worked. We passed it around and everyone got the achievement, but we were lucky that we were able to find someone with a legacy blade from a previous patch. If he hadn't been there, I'd be super mad because finding Bashiok in any one run is ridiculously improbably.

Blizzard, please fix this!
It REALLY amazes me that a question so silly as 'i cant get this achievement!' deserves so many blue replies, and many many bug reports about dead HC heros are ignored...

Way to show you care about your customers, Blizz!

Join the Conversation

Return to Forum