"Orders from Maghda" showing in Act II

Bug Report
Prev 1 2 3 5 Next
I'm really, really glad I'm not the only one with this issue. I've been going insane trying to figure out where the hell that drop is. Like you guys, it's the last thing I need for that achievement! :(
I'm also having this issue. Last one I need for Act 2's Judge of Character achievement, but in the wrong act.
I got the drop of the lore book on a new character today, and my achievement popped.

Act I, Leoric's Manor.

It's a workaround for now, and it will NOT drop again if you have already picked it up with your character, and it will not drop unless you are on the proper quest.

TL;DR go get Orders from Maghda from Act I - it drops off the last mob that dies, from the pack of trash that swarms you when you first enter Leoric's Manor. That "Orders from Maghda" is appearing to be a part of "Judge of Character" is a bug.

Posting to confirm - something is up with Orders From Maghda / Judge of Character.

On my Judge of Character video guides, I've had a couple of YouTube posters ask questions regarding OfM. First, on part 1/2:


YouTube user:
where did you find orders from maghda?

My reply:
Orders from Maghda - this should have come from Act I. When you first enter Leoric's Manor, and kill the slew of cultists that come at you, the last one to die should drop the journal.
Well...that's how it was, anyway. It may have been moved to Act II, and made a part of Judge of Character. I don't know for certain, just speculating - I gave up D3 over two months ago.

And then another user, on part 2/2:


YouTube user #1:
Excuse me, i see there are 35 hournals to get for this achievments. Can someone explain me WHY i have to find 36 ? The additional is Orders from Mahda....

YouTube user #2:
With me the same.
I haven't found anything usefull about it on the internet yet.

My reply:
Sorry for the delayed response - been moving to a new home, working at a new job, etc...
Orders from Maghda - this should have come from Act I. When you first enter Leoric's Manor, and kill the slew of cultists that come at you, the last one to die should drop the journal.

YouTube user #2:
Act I - Taking Notes - Orders from Maghda: check
Act II - Judge of Character - Orders from Maghda: still open.
Here's a sceenshot, just so you know I'm not stupid or making things up :P
(link to flickr)

My reply:
I'm unable to get the link to work, but it's alright - I believe you. :P
I stopped playing D3 months ago, so I won't be of much help, but I'll see if I can at least offer some ideas.
Orders from Maghda - would probably drop off a cultist-related mob, found on a cultist-related mob corpse, or be found in a zone/minidungeon, before the Maghda boss fight. Check all areas between Caldeum and the ruins of Alcarnus - all "minidungeons" included, such as the Secret Altars, The Deserted Cellar, etc.

I offered that advice, in the hopes that other's might be able to locate the lore book - I assumed Blizzard had made a change to D3, and Act II now had a "Orders from Maghda" as well. However, their reply surprised me:

YouTube user #2:
I got the Judge of Character complete now :D
I made a new character and went to Leoric's Manor, got the lore and with it the Judge of Character achievement XD

My reply:
Oh wow, that is bizarre...Judge of Character is an Act II 'chieve - that's odd how an Act I lore-book influences it. xD
Still, what's important is that everything worked out in the end for you - glad to hear it! ^^
I am also having this issue... I don't wish to make a new character to fix it, especially since some people say doing so hasn't helped them. Please fix it Blizzard. That's the only act 2 achievement I don't have, and I DO have the corresponding one in act 1, so it's silly.
Ditto, I have all the books except for that non existant orders from maghda and It's preventing me from completing 2 achievements :( hope blizzard fixes soon figured they'd of found that one by now since its been in there from day 1 ... Sigh
Yup, I have the same problem.
Yeah, I am having this issue too. Hope it gets resolved soon, cause i want that achievement. I know it wasn't there before 1.0.5 though cause all I needed then was The Musings of Sardar, for some reason i never picked it up.
I have the same issue.
Ugh this bug is really annoying. Especially when you're working on your achievements. -_-
I second Ziplex and I Confirm: I just created a new Wiz, went up to Leoric's Manor in act I, got the orders from Maghda drop and it completed the Act II Judge of Character achievement since I also had only this one missing ...also got the Grand Lorekeeper of Sanctuary achievement at the same time. :))
Right guys (and girls) : same issue here. So dear Blizzard, please do something about it!!!
(And fast)
I have no interest in creating a new hero/character.
I can't create a new character, I already have 10.
Time to fix this Blizzard, please put it on your known issues list so that we can stop bugging you about it.
Same issue. All my characters have the book from act 1 so it is not dropping if I go back. Please fix this.
I understand there is a work around for this one by using a character who has not done the Leoric stuff yet in act I, which I will be doing shortly. The problem is this achievement has been marked as bugged and complained about by the players, yet Blizzard doesn't seem to be doing anything to fix it.
Please fix.
Same here...I was going nuts over this...well..next time I will read this forum first :)
I entered Leoric's Manor with a new character(Act1), picked up Orders from Maghda dropped by the first group in the Manor, and got the Act2 achievement. Cant explain, but it worked.
Help from a blue would be nice.

Join the Conversation

Return to Forum