Game crashing at startup?!

Mac Technical Support
Every time i try to run Diablo 3 after the latest patch i get a logo -> blackscreen -> logo again -> error message.
it just won't start up.
Report ID = 1CB391B9-C61C-4287-B354-0F3EE68B59A8

Plz help!
If you're running more than 8 cores, you may want to give this a try:
I have a Mac Pro with 4 cores but 8 threats. (multithreading turned on)
Does shutting down multithreading still apply's in this case?
Tried it anyhow. Didn't work for me.
Still same problem i read so much about all across the mac forum.
no solutions avaiable in the forums...
Unacceptable. Still no fix? Im haunting the forums everyday. I payed money for this game but its only providing frustration. Plz Give us a blue post with a fix asap.
This issue isn't the same as the greater than 8 cores issue.

This seems to be pointing to some issues with sound. Can we try some basic troubleshooting and see if this helps in anyway.

Rebuild the Diablo III Cache
    1. Navigate to /Applications/Diablo III/Data_D3/PC/MPQs and delete the Cache folder.
    2. Then, navigate to Users/Shared/ and delete the Agent.db file.
    3. Run the Diablo III Launcher and let the game update it's files.
    4. Press Play when you see Game is up to date

Repair Permissions via Disk Utility
    1. Navigate to /Applications/Utilities/ and open Disk Utility.
    2. Select the hard drive the game is installed on.
    3. Select the First Aid option.
    4. Click on the Repair Disk Permissions button.
Resetting permissions on the Diablo III folder
    1. Select the Diablo III folder
    2. Press Command + I
    3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
    4. Make sure you have Read & Write permissions
    5. Click on the Burst icon (cog wheel) and select Apply to enclosed items
Tried it all. Still crashes on every startup.
Did you try to remove the Diablo III.mfil file mentioned? This should be in your /Applications/Diablo III folder.
I am experiencing the same problem and have tried everything suggested to no avail. Very frustrating!! Running os x10.8.2
I would like to add that I have been suffering from this since the 1.05 patch as well. I was able to get the game to launch after 4-5 tries at launching. Now it will not launch at all. Logo, black screen, logo, error message in the dock.
Can y'all post full system specs and the error report ID you get?

    1. Launch Diablo III.
    2. Put Diablo III into Windowed Mode if it is not already in Windowed Mode.
    3. From the system menu bar, select Help > Copy Support Information:
    4. Paste the contents of the copied system information here (Command-V)

System Software Overview:

System Version: Mac OS X 10.7.4 (11E53)
Kernel Version: Darwin 11.4.0
64-bit Kernel and Extensions: Yes
Time since boot: 5 days 20:07


Hardware Overview:

Model Name: iMac
Model Identifier: iMac11,2
Processor Name: Intel Core i3
Processor Speed: 3.06 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 4 GB
Processor Interconnect Speed: 5.86 GT/s
Boot ROM Version: IM112.0057.B01
SMC Version (system): 1.64f5


ATI Radeon HD 4670:

Chipset Model: ATI Radeon HD 4670
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 256 MB
Vendor: ATI (0x1002)
Device ID: 0x9488
Revision ID: 0x0000
ROM Revision: 113-B8030H-114
EFI Driver Version: 01.00.403
Resolution: 1920 x 1080
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort


Input Source ID:
Keyboard Layout: ANSI
I cannot get into the diablo menu to copy my system specs. It won't let me pass the Diablo 3
Is there another way to give u the desired spec overview?

Everytime i get another error ID

Thanks Chiel. Looking at the report, it seems the OS is forcing the game closed but we don't know why. Our team is looking into these crashes you have.
Thanks. I guess ill wait for the next blue post.
Chiel, do you have a Sonix webcam? or any webcam?
No i do not.
Sometimes i use my dslr camera as webcam with a screen capture program.
I run dual monitors and here are some of my system specs:

Modelnaam: Mac Pro
Modelaanduiding: MacPro3,1
Processornaam: Intel Core i7
Processorsnelheid: 3,49 GHz
Aantal processors: 1
Totale aantal cores: 4
L2-cache (per core): 256 KB
L3-cache: 8 MB
Geheugen: 16 GB
SMC-versie (systeem): 1.30f3

Chipsetmodel: GeForce GTX 570
Type: GPU
Bus: PCIe
Sleuf: Slot-1
Breedte PCIe-baan: x16
VRAM (totaal): 1280 MB
Fabrikant: NVIDIA (0x10de)
Apparaatcode: 0x1086
Revisiecode: 0x00a1
Resolutie: 1920 x 1080 @ 60 Hz
Pixeldiepte: 32-bits kleur (ARGB8888)
Serienummer beeldscherm: 1113814501266
Hoofdbeeldscherm: Ja
Synchrone weergave: Uit
Online: Ja
Rotatie: Ondersteund
Resolutie: 1920 x 1080 @ 60 Hz
Pixeldiepte: 32-bits kleur (ARGB8888)
Serienummer beeldscherm: 1113813800942
Synchrone weergave: Uit
Online: Ja
Rotatie: Ondersteund
Look in your /Library/Quicktime folder. If there's anything called Sonix in there delete it and reboot.

If you don't see any file called Sonix, can you tell which files you see?
These are Quicktime plugins by the way.
I found 2 quicktime plugin folders.
One under System -> Library -> Quicktime
the other under Library -> Quicktime

Im a video editor so have a lot of third party plugins. Recently i used my dslr camera as a webcam with a program called camtwist It installed some plugins and maybe they have something to do with it.
Cant find the Sonix plugin though.
These i got: &

Join the Conversation

Return to Forum