Patch required glitch happening right now?

General Discussion
Its downloading the patch now, No need to delte anything.
Now it tries to download something and hangs on 0.0% "Initializing..."

Come on what is this sorcery
I deleted files in updates direction, now it downloads again and stops at 93% total download remaining 2.10mb..
"Failed to dowload information about the next patch. Check your network Connections"

Is this problem still going on for pple?
Have you read the technical support forums???
I'm pretty sure you haven't...

but as lazy d3 players want everything in their hands[/quote]

*Congrats winning the most ignorant and arrogant post of the day award.

Yes I have read that post and every other post on the entire internet that google can find on the subject. I have spent days backing up and fiddling with the contents of the folder. this originally happened for me with the 1.04 patch, so I downladed the entire 8GB enUS client, which worked... but only until the next patch. I have opened support tickets and provided them with reams of info and got told to delete my folder... like I hadn't already tried that 10 times over. I think this may have something to do with me having a SG copy of starcraft2 on the same computer. The blizzard downloader/agent system is massively over-complicated and in my case totally broken by doing nothing other than buying and installing blizzard products. For 1.0.5 i eventually just dled the patch from a 3rd party website. Took 10 minutes worked first time. Ten days later and my game is broken AGAIN.

still doesn't work.. must be hard to apply a 10mb patch by a billion trillion company..

cant even get to options.... my my wtf.

so i gotta wait several hours to try again, with uncertainty that it will or wont work
i patched 4 times already, keeps randomly asking, and still can't get in........ must be hard moving a portal...

patches are differnt sizes sometimes
Really all these patch_server entrys in config files are a bunch of malarky, all you need is for the client to attempt logon, and the server to say "no you need these files, here's the url go download em". If it's so hard I'll code it for you for 500 bucks.
so..anybody have any solution? i dont see any solution here. please help

Any advice plz?
whens this gonna work?
Changing the language worked for me.
fresh-install and still same problem. ...
Same here, where is Blizz??? Give us an answer!! HELPS US OUT!
I can login just fine in "The Americas" and "Asia" servers but when I try to login in Europe I get a message saying there is a new patch the game needs to restart in order to install but when it does it says that the game is ready without any download. It's an endless loop....
It happened about 5-6 times for me then it started the download...
got a issue like that myself
I don't think they are done with the update that's why we still cant log in.
But what annoys is that the patch note says nothing about the being disconnected every 10 mins or so problem.
So many players complaining and i haven't seen any light on it.

Join the Conversation

Return to Forum